When you only have one /64 prefix from upstream, the default configuration which tries to delegate an additional prefix to the lan port will not work.
Instead use a relay configuration. The clients on the LAN will get an address in the same /64 as upstream. The LAN interface itself will not hold a GUA address, as it does not need to. The router's GUA is on wan.
/etc/config/network:
config interface 'lan'
...
option proto 'static'
option ipaddr 'USUAL IPv4 ADDRESS'
# There is no assignment of a global ipv6 address, or an `option ip6assign` line.
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
option reqaddress 'no'
option reqprefix 'none'
# This will acquire a SLAAC address.
/etc/config/dhcp
config dhcp 'lan'
# ... the usual ipv4 options...
option dhcpv6 'server'
option ra 'relay'
option ndp 'relay'
config dhcp 'wan6'
option interface 'wan6'
option ra 'relay'
option ndp 'relay'
option master '1'
Additional routers can be chained after this first one-- use the same configuration since it is relaying dhcp down the line.