My clients are not getting the dns servers. "Conected without internet". Openwrt working with a Router which don't have enabled dhcp

Someone can help?`
I set up a openwrt with dhcp server with dns 1.1.1.1 and 8.8.8.8 in lan interface.

The problem
"Conected without internet" from android device.

My clients are not getting the dns servers. I must to set dns manually.

What I want
When client connect get dns 1.1.1.1 and 8.8.8.8.

I can shate my scream in discord to help me if any one need to do that in order to help me. Or team viewer anything that can help me and learn.

Config files

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd65:0967:e83c::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.2'
        option broadcast '192.168.1.255'
        option gateway '192.168.1.3'
        list dns '1.1.1.1'
        list dns '8.8.8.8'

config interface 'tun0'
        option ifname 'tun0'
        option proto 'none'

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option start '90'
        option leasetime '1h'
        option limit '110'
        option force '1'
        list dhcp_option '6,1.1.1.1,8.8.8.8

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

Should be enough to just configure forwarding in server settings, no need to touch interface(s)

missing something at the end?

6 Likes

Thanks I already solved :slight_smile: Now I'm struggling with this

What I want
While being connected to VPN have access to LAN Hosts

The problem
I cannot access LAN clients

10.2.2.0 VPN
192.168.1.99 Nextcloud In lan

then please start a new topic on a new issue

I already did

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.