My brother printer shows offline and I have to reboot my TP link C2600 to resolve

Hi I have LEDE 17.01.4 installed on my TP link C2600 and I noticed sometimes my brother printer (connected via WIFI) shows offline, and I have to reboot my router to resolve, ie, after rebooting, the printer becomes online and I can print.

It took me some time to try this solution, ie, I have tried to reconnect the printer by re-entering the WIFI password, re-installing its driver, etc, none worked, and finally I simply rebooted the router and it worked.

Any idea why?


Edit: never had such issue with stock firmware.

Assign a static IP address to the printer and set the lease time to infinite.

1 Like

I set static IP address under Network - DHCP and DNS - Static Leases.
Do I need to set Network - Hostnames also?

I hope it resolves the issue.

Thanks again.

You can, but it's not required.

1 Like

Unfortunately setting static IP did not resolve the issue.
I powered on the printer this morning and it shows offline, I restarted the router and the printer became online.

What else to do?


In the printer's web interface...

  1. Did you also set up the static IP in the WiFi section?

  2. Obtain IP address set to manual?

Thanks! I was not aware about that.
I checked the printer IP address and it is indeed different from the one I assigned. I changed its IP.
Will see how it goes.
Thanks again!

Also, as mentioned above, check that the option to get an IP address is set to manual.