MX4200 - No access to one SSID, no SSH access, too many connections

Hi folks,

I have a few problems that have just compounded somewhat, over the last 24 hours. Setup details below. I've done my best to trawl for answers, but I can't quite find something that matches my various issues. I've also done my best to give as much info as possible, but let me know if I've missed anything.

Symptoms and what I've tried

I came home from a week on holiday and wanted to set up a new Raspberry Pi Zero 2 W. I did so, but it wouldn't connect to the WiFi. I logged into LuCI to get the IP (having set it up using RPi Imager with my IoT network creds) but it wasn't there. Tried re-flashing a few times, etc., but no bueno.

Other devices seemed to be connected still (including to the IoT network). I logged onto LuCI and saw logs that looked something like this (can't copy them now, as I no longer have access to LuCI - more on this shortly):

ath11k[something like this] a000000.wifi: refusing to associate station: too many connected already (512)

I thought this was odd, since I definitely don't have 512 devices connected. A quick google suggested that there are a few options for trying to solve this, but I thought I might as well try restarting my router first. So I did (by unplugging and plugging back in). I did this with my second AP too.

I also noticed that the 5GHz SSIDs were showing as disabled. I've seen this before and I can't remember how I sorted it out - possibly it's just because nothing's "chosen" to connect to that band?

Since then, my laptop (and phone, fwiw) will now not connect to my Home network, so I can't access LuCI or ssh over WiFi. I've tried connecting by ethernet, using all ports in the router (but at least one that I know I have used before), but no SSH that way either.

Last thing: as below, I have 3 SSIDs set up (x2, on 2.4 and 5GHz) and the Guest and IoT SSIDs seem to be fine (apart from the RPi not connecting to IoT, it would seem). The unfortunate thing is that, while I can use Guest to access the internet, I can't access LuCI, for firewall and/or VLAN reasons.

Options

I can obviously go into failsafe mode and/or reset, but I'd rather not and, even if I do, it would be interesting and useful to know why this might have happened. I have a backup for each router from about a month ago, so I can obviously just restore those, if needed.

If I can regain access, my intent is to try one or more of the following:

  • see if changing from WPA3 to 2 makes a difference (although it was working fine before)
  • play around with WiFi/radio channels (rather than using default/dynamic)
  • possibly look at something like this forum post to solve the underlying problem

Setup

Not sure what is useful here, but here goes.

  • I have 2 routers. One is internet gateway (IGW) and AP combo, the other is dumb AP.
  • Both of the following are Linksys Velop MX4200 V2s, running a month-old snapshot
  • I have a batman-adv mesh set up (wireless only), which has been working well. I used OneMarcFifty's videos to set this up, if that makes any difference
  • I have 3 "proper" SSIDs (Home, Guest, IoT) on both 2.4 and 5GHz, plus one "mesh" SSID
  • Since the MX4200 is tri-band, I have one of the 2.4GHz radios (radio0) dedicated to the mesh, and then the 3 SSIDs on each of radio1 and radio2

So I did the backup restore that I mentioned in my "options" above, and it didn't make much difference, but it did give me Ethernet-based access to LuCI again. All other issues persisted (got a bit worse actually - the Guest network stopped connecting too).

I'm not sure why this would be a thing, but since the logs showed error-looking logs relating to hostapd, I checked the Software list for updates. There was one for hostapd-common and, when I installed it, things work again... I also updated ath11k-firmware-ipq8074, so it could have been that I guess.

Any thoughts from anyone?

FWIW, I'm still having the issue of all 3 SSIDs on 5GHz showing as disabled.

We'd need to see configs to be able to know what is going on... otherwise, there's just no way to know.

If you use failsafe mode, once engaged enter mount_root and then get the config files:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall