Hi Guys,
I'm trying to set up a Banana Pi BPI-R4 (OpenWrt SNAPSHOT r28714-d981f28f76 / LuCI Master 25.027.67616~b9e3d79) with an MWAN3 setup. I have a new fiber provider (interface: giganetz
) and my old cable provider (interface: wan
), and I want to configure a setup where fiber is the primary connection and cable serves as a fallback.
The fiber provider offers a DS-Lite connection, meaning native IPv6 and "IPv4 in IPv6 tunnel." The setup is running fine so far, but when the fiber connection goes down, the status switches to "Disabled." When the connection comes back, the IPv6 connection remains disabled, while the IPv4 connection mostly switches back to "Online."
When I go to Diagnostics and ping the tracking IPs, I can see that the connection is working and the router has 0% packet loss. However, when I change something in the MultiWAN Manager and save the change, the interfaces come back up as "Online" in the MWAN3 overview.
It looks to me like the interface monitoring stops at some point. I suspect this is a configuration issue. I have experimented with the interface and tracking settings, but nothing has changed—the same behavior persists.
Does anyone have experience with MWAN3 and could give me a hint on what I can change to make the interface switch back to "Online" in the MWAN overview?
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd79:21b9:8aa6::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
config device
option name 'br-wan'
option type 'bridge'
list ports 'wan'
list ports 'sfp-wan'
config device
option name 'wan'
option macaddr '8a:c2:4e:6d:9f:c5'
config device
option name 'sfp-wan'
option macaddr '8a:c2:4e:6d:9f:c5'
config interface 'wan'
option device 'br-wan'
option proto 'dhcp'
option metric '2'
config interface 'wan6'
option device 'br-wan'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option norelease '1'
option metric '2'
option ip6assign '72'
config device
option type 'bridge'
option name 'switch'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'sfp-lan'
config bridge-vlan
option device 'switch'
option vlan '1'
list ports 'lan2:u*'
config bridge-vlan
option device 'switch'
option vlan '2'
list ports 'lan2:t'
config bridge-vlan
option device 'switch'
option vlan '3'
list ports 'lan2:t'
list ports 'lan3'
config bridge-vlan
option device 'switch'
option vlan '7'
list ports 'lan1:t'
config interface 'LAN'
option proto 'static'
option device 'switch.1'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '64'
config interface 'giganetz'
option proto 'pppoe'
option device 'switch.7'
option username 'ZZZZZZZ@dgn.digital'
option password 'QQQQQQQQQQQQQQQQQQQ'
option ipv6 'auto'
option metric '1'
option ip6assign '64'
config interface 'giganetz4'
option proto 'dslite'
option peeraddr 'aftr.fra.purtel.com'
option encaplimit 'ignore'
option metric '1'
option tunlink 'giganetz_6'
config interface 'Cam'
option proto 'static'
option device 'switch.3'
option ipaddr '10.3.0.1'
option netmask '255.255.0.0'
option ip6assign '64'
config interface 'Guest'
option proto 'static'
option device 'switch.2'
option ipaddr '10.2.0.1'
option netmask '255.255.0.0'
root@OpenWrt:~# mwan3 status ; echo; uci export mwan3
Interface status:
interface wan is online and tracking is active (online 76h:40m:32s, uptime 145h:19m:37s)
interface wan6 is online and tracking is active (online 76h:40m:32s, uptime 145h:19m:28s)
interface giganetz is disabled and tracking is paused
interface giganetz4 is online and tracking is active (online 05h:00m:51s, uptime 05h:01m:12s)
Current ipv4 policies:
giganetz_to_wan:
giganetz4 (100%)
Current ipv6 policies:
giganetz_to_wan:
wan6 (100%)
Directly connected ipv4 networks:
10.2.0.1
224.0.0.0/3
10.3.255.255
10.3.0.0/16
10.0.255.255
10.3.0.1
10.0.0.0/16
192.168.2.255
192.0.0.2
127.255.255.255
192.0.0.1
127.0.0.0/8
10.2.255.255
10.2.0.0/16
192.168.2.1
127.0.0.1
10.0.1.70
192.168.2.0/24
Directly connected ipv6 networks:
fe80::4e73:4fff:fe22:4826
fd79:21b9:8aa6:0:d58f:70fd:d709:423
fd79:21b9:8aa6:0:857d:9b8a:90be:f46a
XXXX:XXXX:XXXX:b900::/64
fe80::/64
fd79:21b9:8aa6:1::/64
fd79:21b9:8aa6:0:c0a5:4bed:8044:2006
XXXX:XXXX:XXXX:b900:857d:9b8a:90be:f46a
XXXX:XXXX:XXXX:b902::/64
fd79:21b9:8aa6:0:613a:4a21:2d49:eb56
fe80::5c8d:9b61:849c:4fa5
fd79:21b9:8aa6::/64
XXXX:XXXX:XXXX:b901::/64
YYYY:YYYY:YYYY:a720::/64
Active ipv4 user rules:
18979 2719K - giganetz_to_wan 0 -- * * 0.0.0.0/0 0.0.0.0/0
Active ipv6 user rules:
8394K 728M - giganetz_to_wan 0 -- * * ::/0 ::/0
package mwan3
config globals 'globals'
option mmx_mask '0x3F00'
config interface 'wan'
option enabled '1'
list track_ip '1.0.0.1'
list track_ip '1.1.1.1'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'
option family 'ipv4'
option reliability '2'
option initial_state 'offline'
option track_method 'ping'
option count '1'
option size '56'
option max_ttl '60'
option timeout '4'
option interval '10'
option failure_interval '5'
option recovery_interval '5'
option down '5'
option up '5'
option keep_failure_interval '1'
config interface 'wan6'
option enabled '1'
list track_ip '2606:4700:4700::1001'
list track_ip '2606:4700:4700::1111'
list track_ip '2620:0:ccd::2'
list track_ip '2620:0:ccc::2'
option family 'ipv6'
option reliability '2'
option initial_state 'offline'
option track_method 'ping'
option count '1'
option size '56'
option max_ttl '60'
option timeout '4'
option interval '10'
option failure_interval '5'
option recovery_interval '5'
option down '5'
option up '5'
option keep_failure_interval '1'
config member 'wan_m1_w3'
option interface 'wan'
option metric '1'
option weight '3'
config member 'wan_m2_w3'
option interface 'wan'
option metric '2'
option weight '3'
config member 'wan6_m1_w3'
option interface 'wan6'
option metric '1'
option weight '3'
config member 'wan6_m2_w3'
option interface 'wan6'
option metric '2'
option weight '3'
config rule 'default_rule_v4'
option dest_ip '0.0.0.0/0'
option use_policy 'giganetz_to_wan'
option family 'ipv4'
option proto 'all'
option sticky '0'
config rule 'default_rule_v6'
option dest_ip '::/0'
option use_policy 'giganetz_to_wan'
option family 'ipv6'
option proto 'all'
option sticky '0'
config interface 'giganetz'
option enabled '1'
option initial_state 'offline'
option family 'ipv6'
list track_ip '2001:4860:4860::8888'
list track_ip '2001:4860:4860::8844'
list track_ip '2620:fe::fe'
list track_ip '2620:fe::9'
option track_method 'ping'
option reliability '1'
option count '1'
option size '24'
option max_ttl '60'
option timeout '4'
option interval '10'
option failure_interval '5'
option recovery_interval '5'
option down '5'
option up '5'
option keep_failure_interval '1'
config interface 'giganetz4'
option enabled '1'
option initial_state 'offline'
option family 'ipv4'
list track_ip '8.8.8.8'
list track_ip '8.8.4.4'
list track_ip '9.9.9.9'
list track_ip '149.112.112.112'
option track_method 'ping'
option reliability '1'
option count '1'
option size '24'
option max_ttl '60'
option timeout '4'
option interval '10'
option failure_interval '5'
option recovery_interval '5'
option down '5'
option up '5'
option keep_failure_interval '1'
config member 'giganetz_m1_w3'
option interface 'giganetz'
option metric '1'
option weight '3'
config member 'giganetz_m2_w3'
option interface 'giganetz'
option metric '2'
option weight '3'
config member 'giganetz4_m1_w3'
option interface 'giganetz4'
option metric '1'
option weight '3'
config member 'giganetz4_m2_w3'
option interface 'wan'
option metric '2'
option weight '3'
config policy 'giganetz_to_wan'
list use_member 'wan_m2_w3'
list use_member 'wan6_m2_w3'
list use_member 'giganetz_m1_w3'
list use_member 'giganetz4_m1_w3'
option last_resort 'unreachable'