MWAN3 second interace is up and active but no connectivity

Hi, I've just finished following the mwan3 tutorial for a DSA router:

My setup is the one below:

.
└── OpenWRT Router
    ├── Wan1: ADSL/EE Router
    └── Wan2: 4G/TP-Link MR6400

NOTE: My router would not work with the VLAN approach described in the tutorial.
So I had to put the first ethernet port (lan1) as a bridge, and then create an interface for it. Using the tutorial's VLAN 802.1q did not get the interface to acquire a DHCP IP from the 4G router, no matter what.

Bringing up wan2 using a bridge, it gets an IP from the 4G route using DHCP. The 4G router has an IP range of 192.168.2.0/24 and the ADSL router has an IP range of 192.168.1.0/24. Everything Internal to the OpenWRT Router (VLANS, etc) seem to work fine.

Everything else I've done is according to the tutorial.

My routing tables are:

default via 192.168.1.254 dev wan proto static src 192.168.1.121 metric 10
default via 192.168.2.1 dev lan1 proto static src 192.168.2.100 metric 20
192.168.1.0/24 dev wan proto static scope link metric 10
192.168.2.0/24 dev lan1 proto static scope link metric 20
192.168.10.0/24 dev br-lan.1 proto kernel scope link src 192.168.10.1
192.168.20.0/24 dev br-lan.2 proto kernel scope link src 192.168.20.1
192.168.30.0/24 dev br-lan.3 proto kernel scope link src 192.168.30.1
192.168.60.0/24 dev br-lan.4 proto kernel scope link src 192.168.60.1
192.168.80.0/24 dev br-lan.5 proto kernel scope link src 192.168.80.1
192.168.90.0/24 dev br-lan.6 proto kernel scope link src 192.168.90.1

And as you can see, the interfaces are:

wan       Link encap:Ethernet  HWaddr 5A:EF:68:B5:BA:C9
          inet addr:192.168.1.121  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::58ef:68ff:feb5:bac9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:96118945 errors:0 dropped:1062023 overruns:0 frame:0
          TX packets:38979846 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:113342680560 (105.5 GiB)  TX bytes:33759191887 (31.4 GiB)

lan1      Link encap:Ethernet  HWaddr 58:EF:68:B5:BA:C9
          inet addr:192.168.2.100  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:105387 errors:0 dropped:0 overruns:0 frame:0
          TX packets:51343 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:15481236 (14.7 MiB)  TX bytes:4500514 (4.2 MiB)

Following the instructions in the tutorial, when I ping using the interfaces this happens:

ping -c 1 -I wan 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=117 time=15.234 ms

--- 8.8.8.8 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 15.234/15.234/15.234 ms

But when I use the second wan:

root@InnerRouter:~#  ping -c 1 -I lan1 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes

--- 8.8.8.8 ping statistics ---
1 packets transmitted, 0 packets received, 100% packet loss

What's even more bizarre, is that I can access the 4G router from OpenWRT:

ping -c 1 -I lan1 192.168.2.1
PING 192.168.2.1 (192.168.2.1): 56 data bytes
64 bytes from 192.168.2.1: seq=0 ttl=64 time=0.634 ms

--- 192.168.2.1 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 0.634/0.634/0.634 ms

Which tells me that either DNS Resolution isn't working properly for Wan2 or that for some reason the packets aren't routed properly?

The Wan1 connection works fine, but I have setup the following over the past few weeks:

  • DNS Crypt (I suspect this may have something to do with it?)
  • USB overlay for extra storage
  • Wireguard client (not using it, this is another question for another post)
  • VLANs for inside the OpenWRT network
  • Firewall for each VLAN.

My intentions are:

  1. To use the ADSL Line for myself, and the 4G Router for my partner; she's constantly streaming Netflix and YouTube eating up my bandwidth. So her VLAN should use only Wan2 and not Wan1 as it currently is.
  2. To use the 4G as a failsafe/backup when ADSL goes down (it does go down once a day)

What am I missing? I've setup the firewall to masquerade from the VLAN to the 4G router, My suspicion is that the DNSMasq config is incorrect, as I set it up prior to setting up mwan3.

Passing the test of pinging via both gateways is a prerequisite to proceed with mwan setup. In your case you don't have internet connectivity over the 4G. Connect a PC on the 4G router and troubleshoot why is that.

I do have connectivity over 4G. I've hooked up the PC directly to it, and it works fine, albeit a bit slow. It just seems that routing and name resolution doesn't work over 4G only over ADSL.

Name resolving is not going to work if there is no internet access. Try this one from the router:
traceroute -s 192.168.2.100 -i lan1 -m 15 -q 2 -v 8.8.8.8

This is what I got:

traceroute -s 192.168.2.100 -i lan1 -m 15 -q 2 -v 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8) from 192.168.2.100, 15 hops max, 38 byte packets
 1
64 bytes from 8.8.4.4 to 192.168.1.121: icmp type 0 (Echo Reply) code 0
0000: 00 00 fe 4e 1b 5e 00 00 8f 83 56 cf 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

64 bytes from 8.8.8.8 to 192.168.1.121: icmp type 0 (Echo Reply) code 0
0000: 00 00 15 f7 1b 61 00 00 77 d8 56 cf 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  192.168.2.100 (192.168.2.100) 46 bytes to 192.168.2.100  3137.859 ms !H
64 bytes from 8.8.8.8 to 192.168.2.100: icmp type 0 (Echo Reply) code 0
0000: 00 00 e4 55 1b 66 00 00 61 74 9e cf 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  3103.697 ms !H

I think there is something wrong with your configuration, you are getting an answer from the wrong gateway.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*

Here you go:

{
	"kernel": "5.4.179",
	"hostname": "InnerRouter",
	"system": "ARMv7 Processor rev 1 (v7l)",
	"model": "Linksys WRT1900ACS",
	"board_name": "linksys,wrt1900acs",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.2",
		"revision": "r16495-bf0c965af0",
		"target": "mvebu/cortexa9",
		"description": "OpenWrt 21.02.2 r16495-bf0c965af0"
	}
}
package network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd95:91ec:45c3::/48'

config device
	option name 'wan'
	option macaddr '5a:ef:68:xx:xx:xx'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option metric '10'
	option reliability '2'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan2'

config bridge-vlan
	option device 'br-lan'
	option vlan '2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'devlan'
	option device 'br-lan.1'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	list dns '8.8.4.4'

config interface 'pubface'
	option device 'br-lan.2'
	option proto 'static'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'

config interface 'holly'
	option proto 'static'
	option device 'br-lan.3'
	option ipaddr '192.168.30.1'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'

config interface 'GUESTS'
	option proto 'static'
	option device 'br-lan.4'
	option ipaddr '192.168.60.1'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'

config interface 'MediaNet'
	option proto 'static'
	option device 'br-lan.5'
	option ipaddr '192.168.80.1'
	option netmask '255.255.255.0'

config bridge-vlan
	option device 'br-lan'
	option vlan '6'

config interface 'IoT'
	option proto 'static'
	option device 'br-lan.6'
	option ipaddr '192.168.90.1'
	option netmask '255.255.255.0'

config interface 'wan2'
	option proto 'dhcp'
	option device 'lan1'
	option metric '20'
	option reliability '1'

package dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option localservice '1'
	option ednspacket_max '1232'
	option logqueries '1'
	option noresolv '1'
	option localuse '1'
	option resolvfile '/etc/resolv-crypt.conf'
	option allservers '0'
	list server '::1#5253'
	list server '::1#5254'
	list server '127.0.0.1#5255'
	list server '127.0.0.1#5256'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'isolated'
	option interface 'isolated'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config dhcp 'devlan'
	option interface 'devlan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config dhcp 'pubface'
	option interface 'pubface'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config dhcp 'holly'
	option interface 'holly'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config dhcp 'GUESTS'
	option interface 'GUESTS'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config dhcp 'MediaNet'
	option interface 'MediaNet'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config dhcp 'IoT'
	option interface 'IoT'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config host
	option name 'L530'
	option ip '192.168.90.150'
	option mac '5C:A6:E6:XX:XX:XX'

config host
	option ip '192.168.90.135'
	option mac 'A0:9F:10:XX:XX:XX'

config host
	option name 'RokuExpress'
	option ip '192.168.80.123'
	option mac '8C:49:62XX:XX:XX'

config domain
	option name 'Doorbell'
	option ip '192.168.90.135'

config domain
	option name 'Air'
	option ip '192.168.10.145'

config domain
	option name 'deep.pc'
	option ip '192.168.10.200'

config domain
	option name 'smart.bulb'
	option ip '192.168.90.150'

package firewall

config defaults
	option output 'ACCEPT'
	option synflood_protect '1'
	option drop_invalid '1'
	option input 'REJECT'
	option forward 'REJECT'

config include
	option path '/etc/firewall.user'

config zone
	option name 'devlan'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option input 'ACCEPT'
	list network 'devlan'

config zone
	option name 'pubface'
	option output 'ACCEPT'
	option masq '1'
	option input 'REJECT'
	option log '1'
	option forward 'ACCEPT'
	list network 'pubface'

config rule
	option src 'pubface'
	option dest_port '53'
	option target 'ACCEPT'
	option name 'DNS PubNet'

config rule
	option dest_port '68'
	option target 'ACCEPT'
	option src 'pubface'
	list proto 'udp'
	option name 'DHCP PubNet'

config zone
	option output 'ACCEPT'
	option masq '1'
	option input 'DROP'
	option forward 'DROP'
	option name 'wanA'
	list network 'wan'
	list network 'wan6'

config forwarding
	option dest 'pubface'

config forwarding
	option dest 'pubface'

config forwarding
	option src 'devlan'
	option dest 'wanA'

config forwarding
	option src 'pubface'
	option dest 'wanA'

config redirect
	option target 'DNAT'
	option name 'XMR Node'
	list proto 'tcp'
	option dest_ip '192.168.20.229'
	option dest 'pubface'
	option src_dport '18080'
	option dest_port '18080'
	option src 'wanA'

config rule
	option src 'pubface'
	option dest_port '67'
	option target 'ACCEPT'
	option name 'DHCPd PubNet'

config zone
	option name 'Holly'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'holly'

config forwarding
	option src 'Holly'
	option dest 'wanA'

config rule
	option name 'DNS Holly'
	option src 'Holly'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'DHCPd Holly'
	list proto 'udp'
	option dest_port '67'
	option target 'ACCEPT'
	option src 'Holly'

config rule
	option name 'DHCP Holly'
	list proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option src 'Holly'

config zone
	option name 'Guests'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'GUESTS'

config rule
	option name 'DNS Guests'
	option src 'Guests'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'DHCPd Guests'
	list proto 'udp'
	option src 'Guests'
	option dest_port '67'
	option target 'ACCEPT'

config rule
	option name 'DHCP Guests'
	list proto 'udp'
	option src 'Guests'
	option dest_port '68'
	option target 'ACCEPT'

config zone
	option name 'MediaNet'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'MediaNet'

config forwarding
	option src 'MediaNet'
	option dest 'wanA'

config rule
	option name 'DNS MediaNet'
	option src 'MediaNet'
	option dest_port '53'
	option target 'ACCEPT'

config rule
	option name 'DHCPd MediaNet'
	list proto 'udp'
	option src 'MediaNet'
	option dest_port '67'
	option target 'ACCEPT'

config rule
	option name 'DHCP MediaNet'
	list proto 'udp'
	option src 'MediaNet'
	option dest_port '68'
	option target 'ACCEPT'

config zone
	option name 'IoT'
	option forward 'REJECT'
	option output 'ACCEPT'
	option masq '1'
	option input 'REJECT'
	list network 'IoT'

config rule
	option name 'DHCP IoT'
	list proto 'udp'
	option src 'IoT'
	option dest_port '67'
	option target 'ACCEPT'

config rule
	option name 'DHCPd IoT'
	list proto 'udp'
	option src 'IoT'
	option dest_port '68'
	option target 'ACCEPT'

config forwarding
	option src 'IoT'
	option dest 'wanA'

config rule
	option name 'DNS IoT'
	option src 'IoT'
	option dest_port '53'
	option target 'ACCEPT'

config zone
	option name 'wanB'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	list network 'wan2'

config redirect
	option dest 'pubface'
	option target 'DNAT'
	option name 'TOR OR Port'
	list proto 'tcp'
	option src 'wanA'
	option dest_ip '192.168.20.229'
	option src_dport '9998'
	option dest_port '9998'

config redirect
	option dest 'pubface'
	option target 'DNAT'
	option name 'TOR DIR Port'
	list proto 'tcp'
	option src 'wanA'
	option src_dport '9999'
	option dest_ip '192.168.20.229'
	option dest_port '9999'

config forwarding
	option src 'Guests'
	option dest 'wanB'

config forwarding
	option src 'devlan'
	option dest 'wanB'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
6: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.2.100/24 brd 192.168.2.255 scope global lan1
       valid_lft forever preferred_lft forever
7: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.1.121/24 brd 192.168.1.255 scope global wan
       valid_lft forever preferred_lft forever
11: br-lan.1@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.10.1/24 brd 192.168.10.255 scope global br-lan.1
       valid_lft forever preferred_lft forever
12: br-lan.2@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.20.1/24 brd 192.168.20.255 scope global br-lan.2
       valid_lft forever preferred_lft forever
13: br-lan.3@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.30.1/24 brd 192.168.30.255 scope global br-lan.3
       valid_lft forever preferred_lft forever
14: br-lan.4@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.60.1/24 brd 192.168.60.255 scope global br-lan.4
       valid_lft forever preferred_lft forever
15: br-lan.5@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.80.1/24 brd 192.168.80.255 scope global br-lan.5
       valid_lft forever preferred_lft forever
16: br-lan.6@br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.90.1/24 brd 192.168.90.255 scope global br-lan.6
       valid_lft forever preferred_lft forever
default via 192.168.1.254 dev wan table 1 proto static src 192.168.1.121 metric 10
192.168.1.0/24 dev wan table 1 proto static scope link metric 10
192.168.10.0/24 dev br-lan.1 table 1 proto kernel scope link src 192.168.10.1
192.168.20.0/24 dev br-lan.2 table 1 proto kernel scope link src 192.168.20.1
192.168.30.0/24 dev br-lan.3 table 1 proto kernel scope link src 192.168.30.1
192.168.60.0/24 dev br-lan.4 table 1 proto kernel scope link src 192.168.60.1
192.168.80.0/24 dev br-lan.5 table 1 proto kernel scope link src 192.168.80.1
192.168.90.0/24 dev br-lan.6 table 1 proto kernel scope link src 192.168.90.1
default via 192.168.2.1 dev lan1 table 2 proto static src 192.168.2.100 metric 20
192.168.2.0/24 dev lan1 table 2 proto static scope link metric 20
192.168.10.0/24 dev br-lan.1 table 2 proto kernel scope link src 192.168.10.1
192.168.20.0/24 dev br-lan.2 table 2 proto kernel scope link src 192.168.20.1
192.168.30.0/24 dev br-lan.3 table 2 proto kernel scope link src 192.168.30.1
192.168.60.0/24 dev br-lan.4 table 2 proto kernel scope link src 192.168.60.1
192.168.80.0/24 dev br-lan.5 table 2 proto kernel scope link src 192.168.80.1
192.168.90.0/24 dev br-lan.6 table 2 proto kernel scope link src 192.168.90.1
default via 192.168.1.254 dev wan proto static src 192.168.1.121 metric 10
default via 192.168.2.1 dev lan1 proto static src 192.168.2.100 metric 20
192.168.1.0/24 dev wan proto static scope link metric 10
192.168.2.0/24 dev lan1 proto static scope link metric 20
192.168.10.0/24 dev br-lan.1 proto kernel scope link src 192.168.10.1
192.168.20.0/24 dev br-lan.2 proto kernel scope link src 192.168.20.1
192.168.30.0/24 dev br-lan.3 proto kernel scope link src 192.168.30.1
192.168.60.0/24 dev br-lan.4 proto kernel scope link src 192.168.60.1
192.168.80.0/24 dev br-lan.5 proto kernel scope link src 192.168.80.1
192.168.90.0/24 dev br-lan.6 proto kernel scope link src 192.168.90.1
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast 192.168.1.0 dev wan table local proto kernel scope link src 192.168.1.121
local 192.168.1.121 dev wan table local proto kernel scope host src 192.168.1.121
broadcast 192.168.1.255 dev wan table local proto kernel scope link src 192.168.1.121
broadcast 192.168.2.0 dev lan1 table local proto kernel scope link src 192.168.2.100
local 192.168.2.100 dev lan1 table local proto kernel scope host src 192.168.2.100
broadcast 192.168.2.255 dev lan1 table local proto kernel scope link src 192.168.2.100
broadcast 192.168.10.0 dev br-lan.1 table local proto kernel scope link src 192.168.10.1
local 192.168.10.1 dev br-lan.1 table local proto kernel scope host src 192.168.10.1
broadcast 192.168.10.255 dev br-lan.1 table local proto kernel scope link src 192.168.10.1
broadcast 192.168.20.0 dev br-lan.2 table local proto kernel scope link src 192.168.20.1
local 192.168.20.1 dev br-lan.2 table local proto kernel scope host src 192.168.20.1
broadcast 192.168.20.255 dev br-lan.2 table local proto kernel scope link src 192.168.20.1
broadcast 192.168.30.0 dev br-lan.3 table local proto kernel scope link src 192.168.30.1
local 192.168.30.1 dev br-lan.3 table local proto kernel scope host src 192.168.30.1
broadcast 192.168.30.255 dev br-lan.3 table local proto kernel scope link src 192.168.30.1
broadcast 192.168.60.0 dev br-lan.4 table local proto kernel scope link src 192.168.60.1
local 192.168.60.1 dev br-lan.4 table local proto kernel scope host src 192.168.60.1
broadcast 192.168.60.255 dev br-lan.4 table local proto kernel scope link src 192.168.60.1
broadcast 192.168.80.0 dev br-lan.5 table local proto kernel scope link src 192.168.80.1
local 192.168.80.1 dev br-lan.5 table local proto kernel scope host src 192.168.80.1
broadcast 192.168.80.255 dev br-lan.5 table local proto kernel scope link src 192.168.80.1
broadcast 192.168.90.0 dev br-lan.6 table local proto kernel scope link src 192.168.90.1
local 192.168.90.1 dev br-lan.6 table local proto kernel scope host src 192.168.90.1
broadcast 192.168.90.255 dev br-lan.6 table local proto kernel scope link src 192.168.90.1
0:	from all lookup local
1001:	from all iif wan lookup 1
1002:	from all iif lan1 lookup 2
2001:	from all fwmark 0x100/0x3f00 lookup 1
2002:	from all fwmark 0x200/0x3f00 lookup 2
2061:	from all fwmark 0x3d00/0x3f00 blackhole
2062:	from all fwmark 0x3e00/0x3f00 unreachable
3001:	from all fwmark 0x100/0x3f00 unreachable
3002:	from all fwmark 0x200/0x3f00 unreachable
32766:	from all lookup main
32767:	from all lookup default
-rw-r--r--    1 root     root            19 Aug 18 00:16 /etc/resolv.conf
-rw-r--r--    1 root     root            47 Sep  2 01:26 /tmp/resolv.conf
-rw-r--r--    1 root     root           131 Sep  7 06:10 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           131 Sep  7 06:10 resolv.conf.auto
==> /etc/resolv.conf <==
nameserver 8.8.8.8

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface devlan
nameserver 8.8.4.4
# Interface wan
nameserver 192.168.1.254
search home
# Interface wan2
nameserver 192.168.2.1

Thanks for all the help! :smiley:

I am not quite sure what is the reliability option in the wan interfaces. Do you have more information? Could you try to disable it and give it another try?
A sidenote, add nameservers under interfaces when they are reachable via that interface. If you want to advertise a specific DNS to the customers, it needs to be done from dhcp.

I didn't add it, I think mwan3 added it?
I don't have nameservers because DNS crypt was supposed to take care of it, but I can add them for now to see if that solves anything.

mwan3 related configuration is in its own file.

There is nameserver configured in devlan,

I've removed it, and added nameservers for both wan interfaces.

So, I cannot use VLAN (802.1q) as the mwan3 tutorial says, I have a DSA router. So I've tried something else, I've put the lan1 port back to the bridge which uses VLAN filtering (software vlan). I then setup wan2 to connect to the 4G router.

I can ping the 4G router, and I can even traceroute the 4G router's external (public) IP. What I can't do, is still traceroute outside of it using the openwrt router. I'm wondering if the packets are simply not being routed properly because I haven't followed the mwan3 tutorial?

I am literally following the instructions except this bit, so maybe something at the VLAN level or the resolution/routing isn't working as intended?

So, I think I've made some progress:

traceroute -s 192.168.2.100 -i br-lan.100 -m 15 -q 2 -v 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8) from 192.168.2.100, 15 hops max, 38 byte packets
 1  192.168.2.100 (192.168.2.100) 46 bytes to 192.168.2.100  3117.043 ms !H  192.168.2.1 (192.168.2.1) 46 bytes to 192.168.2.100  0.452 ms

I've put the DSA bridge back together (br-lan1) so it has all four ports (lan1, lan2, lan3, lan4) and then used the software VLAN filtering as before. I added a new interface wan2 on that port, setup DHCP Client, and it got the IP.

From there I followed the instructions for firewall, gateway metrics. One caveat is that mwan uses wanb instead of my wan2 interface. So I changed that too.

However, I still can't figure out why routing from that interface seems broken.

Can you run a tcpdump? I am curious what are the contents of the packet. And so far this issue is not connected to mwan3, we are testing basic connectivity from the router to the internet.
opkg update; opkg install tcpdump; tcpdump -i br-lan.100 -vn

tcpdump: listening on br-lan.100, link-type EN10MB (Ethernet), capture size 262144 bytes
20:33:18.147413 IP (tos 0x0, ttl 62, id 31425, offset 0, flags [DF], proto TCP (6), length 1138)
    192.168.2.100.44416 > 73.142.122.206.18080: Flags [P.], cksum 0x67be (correct), seq 603482862:603483948, ack 4272738260, win 1454, options [nop,nop,TS val 124165168 ecr 2812833892], length 1086
20:33:18.302343 IP (tos 0x0, ttl 48, id 50787, offset 0, flags [DF], proto TCP (6), length 64)
    73.142.122.206.18080 > 192.168.2.100.44416: Flags [.], cksum 0x8ae9 (correct), ack 4294966088, win 530, options [nop,nop,TS val 2812834547 ecr 124164963,nop,nop,sack 1 {0:1086}], length 0
20:33:18.367226 IP (tos 0x0, ttl 62, id 31426, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.44416 > 73.142.122.206.18080: Flags [.], cksum 0xf9b3 (correct), seq 4294966088:0, ack 1, win 1454, options [nop,nop,TS val 124165223 ecr 2812834547], length 1208
20:33:18.520387 IP (tos 0x0, ttl 48, id 50788, offset 0, flags [DF], proto TCP (6), length 52)
    73.142.122.206.18080 > 192.168.2.100.44416: Flags [.], cksum 0xd83c (correct), ack 1086, win 523, options [nop,nop,TS val 2812834767 ecr 124165223], length 0
20:33:18.924689 IP (tos 0x0, ttl 63, id 4560, offset 0, flags [DF], proto UDP (17), length 122)
    192.168.2.100.51413 > 27.95.159.146.24713: UDP, length 94
20:33:19.097290 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 192.168.2.1 tell 192.168.2.100, length 28
20:33:19.097569 ARP, Ethernet (len 6), IPv4 (len 4), Reply 192.168.2.1 is-at 68:ff:7b:17:ee:20, length 46
20:33:19.222476 IP (tos 0x0, ttl 112, id 15559, offset 0, flags [none], proto UDP (17), length 317)
    27.95.159.146.24713 > 192.168.2.100.51413: UDP, length 289
20:33:19.223301 IP (tos 0x0, ttl 63, id 17705, offset 0, flags [DF], proto UDP (17), length 86)
    192.168.2.100.51413 > 179.152.15.239.34143: UDP, length 58
20:33:19.263703 IP (tos 0x0, ttl 60, id 54816, offset 0, flags [DF], proto ICMP (1), length 84)
    192.168.2.100 > 8.8.8.8: ICMP echo request, id 14861, seq 0, length 64
20:33:19.324443 IP (tos 0x80, ttl 114, id 0, offset 0, flags [none], proto ICMP (1), length 84)
    8.8.8.8 > 192.168.2.100: ICMP echo reply, id 14861, seq 0, length 64
20:33:20.127008 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 64) fe80::6aff:7bff:fe17:ee20 > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 64
	hop limit 64, Flags [other stateful], pref medium, router lifetime 0s, reachable time 0ms, retrans timer 0ms
	  prefix info option (3), length 32 (4): ::6aff:7bff:fe17:ee20/64, Flags [onlink, auto, router], valid time 300s, pref. time 120s
	  mtu option (5), length 8 (1):  1500
	  source link-address option (1), length 8 (1): 68:ff:7b:17:ee:20
20:33:21.361765 IP (tos 0x0, ttl 62, id 10005, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xa1f3), seq 366809654:366812070, ack 925244745, win 1454, options [nop,nop,TS val 124165971 ecr 2645949275], length 2416
20:33:21.361985 IP (tos 0x0, ttl 62, id 10007, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xb566), seq 2416:4832, ack 1, win 1454, options [nop,nop,TS val 124165971 ecr 2645949275], length 2416
20:33:21.362127 IP (tos 0x0, ttl 62, id 10009, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x67ec), seq 4832:7248, ack 1, win 1454, options [nop,nop,TS val 124165971 ecr 2645949275], length 2416
20:33:21.362280 IP (tos 0x0, ttl 62, id 10011, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x274f), seq 7248:9664, ack 1, win 1454, options [nop,nop,TS val 124165971 ecr 2645949275], length 2416
20:33:21.362428 IP (tos 0x0, ttl 62, id 10013, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xf20d), seq 9664:12080, ack 1, win 1454, options [nop,nop,TS val 124165971 ecr 2645949275], length 2416
20:33:21.365629 IP (tos 0x0, ttl 62, id 16774, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xbd16), seq 375696254:375698670, ack 2229340780, win 1454, options [nop,nop,TS val 124165972 ecr 1748324172], length 2416
20:33:21.365831 IP (tos 0x0, ttl 62, id 16776, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xd089), seq 2416:4832, ack 1, win 1454, options [nop,nop,TS val 124165972 ecr 1748324172], length 2416
20:33:21.365991 IP (tos 0x0, ttl 62, id 16778, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0x830f), seq 4832:7248, ack 1, win 1454, options [nop,nop,TS val 124165972 ecr 1748324172], length 2416
20:33:21.366141 IP (tos 0x0, ttl 62, id 16780, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0x4272), seq 7248:9664, ack 1, win 1454, options [nop,nop,TS val 124165972 ecr 1748324172], length 2416
20:33:21.366298 IP (tos 0x0, ttl 62, id 16782, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0x0d31), seq 9664:12080, ack 1, win 1454, options [nop,nop,TS val 124165972 ecr 1748324172], length 2416
20:33:21.531077 IP (tos 0x0, ttl 46, id 43023, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x79ed (correct), ack 1208, win 4924, options [nop,nop,TS val 2645970550 ecr 124165971], length 0
20:33:21.531717 IP (tos 0x0, ttl 62, id 10015, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x9c8e), seq 12080:14496, ack 1, win 1454, options [nop,nop,TS val 124166014 ecr 2645970550], length 2416
20:33:21.534558 IP (tos 0x0, ttl 46, id 43024, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x7533 (correct), ack 2416, win 4924, options [nop,nop,TS val 2645970552 ecr 124165971], length 0
20:33:21.535155 IP (tos 0x0, ttl 62, id 10017, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x7b1d), seq 14496:16912, ack 1, win 1454, options [nop,nop,TS val 124166015 ecr 2645970552], length 2416
20:33:21.544963 IP (tos 0x0, ttl 46, id 43025, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x7078 (correct), ack 3624, win 4924, options [nop,nop,TS val 2645970555 ecr 124165971], length 0
20:33:21.544963 IP (tos 0x0, ttl 46, id 43026, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x6bbf (correct), ack 4832, win 4924, options [nop,nop,TS val 2645970556 ecr 124165971], length 0
20:33:21.545181 IP (tos 0x0, ttl 46, id 43027, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x6702 (correct), ack 6040, win 4924, options [nop,nop,TS val 2645970561 ecr 124165971], length 0
20:33:21.545829 IP (tos 0x0, ttl 62, id 10019, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xb754), seq 16912:19328, ack 1, win 1454, options [nop,nop,TS val 124166017 ecr 2645970555], length 2416
20:33:21.545862 IP (tos 0x0, ttl 62, id 10021, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xca8d), seq 19328:21744, ack 1, win 1454, options [nop,nop,TS val 124166017 ecr 2645970556], length 2416
20:33:21.545982 IP (tos 0x0, ttl 62, id 10023, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x9116), seq 21744:24160, ack 1, win 1454, options [nop,nop,TS val 124166017 ecr 2645970561], length 2416
20:33:21.557939 IP (tos 0x0, ttl 46, id 43029, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x5d83 (correct), ack 8456, win 4924, options [nop,nop,TS val 2645970576 ecr 124165971], length 0
20:33:21.558546 IP (tos 0x0, ttl 62, id 10025, offset 0, flags [DF], proto TCP (6), length 4884)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0x08eb (incorrect -> 0xe01e), seq 24160:28992, ack 1, win 1454, options [nop,nop,TS val 124166020 ecr 2645970576], length 4832
20:33:21.561557 IP (tos 0x0, ttl 49, id 35348, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xc9ae (correct), ack 1208, win 1146, options [nop,nop,TS val 1748335755 ecr 124165972], length 0
20:33:21.562125 IP (tos 0x0, ttl 62, id 16784, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xdd87), seq 12080:14496, ack 1, win 1454, options [nop,nop,TS val 124166021 ecr 1748335755], length 2416
20:33:21.565056 IP (tos 0x0, ttl 46, id 43030, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x58c4 (correct), ack 9664, win 4924, options [nop,nop,TS val 2645970583 ecr 124165971], length 0
20:33:21.565614 IP (tos 0x0, ttl 62, id 10029, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x3da0), seq 28992:31408, ack 1, win 1454, options [nop,nop,TS val 124166022 ecr 2645970583], length 2416
20:33:21.568685 IP (tos 0x0, ttl 49, id 35349, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xc4f9 (correct), ack 2416, win 1138, options [nop,nop,TS val 1748335760 ecr 124165972], length 0
20:33:21.569285 IP (tos 0x0, ttl 62, id 16786, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xbc12), seq 14496:16912, ack 1, win 1454, options [nop,nop,TS val 124166023 ecr 1748335760], length 2416
20:33:21.572182 IP (tos 0x0, ttl 46, id 43031, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x5405 (correct), ack 10872, win 4924, options [nop,nop,TS val 2645970590 ecr 124165971], length 0
20:33:21.572771 IP (tos 0x0, ttl 62, id 10031, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x4784), seq 31408:33824, ack 1, win 1454, options [nop,nop,TS val 124166024 ecr 2645970590], length 2416
20:33:21.575806 IP (tos 0x0, ttl 49, id 35350, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xc043 (correct), ack 3624, win 1130, options [nop,nop,TS val 1748335766 ecr 124165972], length 0
20:33:21.576625 IP (tos 0x0, ttl 62, id 16788, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xf846), seq 16912:19328, ack 1, win 1454, options [nop,nop,TS val 124166025 ecr 1748335766], length 2416
20:33:21.579440 IP (tos 0x0, ttl 46, id 43032, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x4f46 (correct), ack 12080, win 4924, options [nop,nop,TS val 2645970597 ecr 124165971], length 0
20:33:21.580025 IP (tos 0x0, ttl 62, id 10033, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x3372), seq 33824:36240, ack 1, win 1454, options [nop,nop,TS val 124166026 ecr 2645970597], length 2416
20:33:21.583180 IP (tos 0x0, ttl 49, id 35351, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xbb8a (correct), ack 4832, win 1122, options [nop,nop,TS val 1748335775 ecr 124165972], length 0
20:33:21.583764 IP (tos 0x0, ttl 62, id 16790, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0x0b76), seq 19328:21744, ack 1, win 1454, options [nop,nop,TS val 124166027 ecr 1748335775], length 2416
20:33:21.586930 IP (tos 0x0, ttl 49, id 35352, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xb6d5 (correct), ack 6040, win 1115, options [nop,nop,TS val 1748335779 ecr 124165972], length 0
20:33:21.587518 IP (tos 0x0, ttl 62, id 16792, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x1ff0 (correct), seq 21744:22952, ack 1, win 1454, options [nop,nop,TS val 124166028 ecr 1748335779], length 1208
20:33:21.610007 IP (tos 0x0, ttl 49, id 35353, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xb212 (correct), ack 7248, win 1107, options [nop,nop,TS val 1748335798 ecr 124165972], length 0
20:33:21.610007 IP (tos 0x0, ttl 49, id 35354, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xad60 (correct), ack 8456, win 1099, options [nop,nop,TS val 1748335800 ecr 124165972], length 0
20:33:21.610007 IP (tos 0x0, ttl 49, id 35355, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xa8b0 (correct), ack 9664, win 1091, options [nop,nop,TS val 1748335800 ecr 124165972], length 0
20:33:21.610007 IP (tos 0x0, ttl 49, id 35356, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0xa3fe (correct), ack 10872, win 1084, options [nop,nop,TS val 1748335801 ecr 124165972], length 0
20:33:21.611011 IP (tos 0x0, ttl 62, id 16793, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0x2392), seq 22952:25368, ack 1, win 1454, options [nop,nop,TS val 124166033 ecr 1748335798], length 2416
20:33:21.611040 IP (tos 0x0, ttl 62, id 16795, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x1020 (correct), seq 25368:26576, ack 1, win 1454, options [nop,nop,TS val 124166033 ecr 1748335800], length 1208
20:33:21.611104 IP (tos 0x0, ttl 62, id 16796, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x3c67 (correct), seq 26576:27784, ack 1, win 1454, options [nop,nop,TS val 124166033 ecr 1748335800], length 1208
20:33:21.619946 IP (tos 0x0, ttl 49, id 35357, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x9f42 (correct), ack 12080, win 1076, options [nop,nop,TS val 1748335813 ecr 124165972], length 0
20:33:21.620496 IP (tos 0x0, ttl 62, id 16797, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xf73b), seq 27784:30200, ack 1, win 1454, options [nop,nop,TS val 124166036 ecr 1748335813], length 2416
20:33:21.683668 IP (tos 0x0, ttl 46, id 43033, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x49f8 (correct), ack 13288, win 4924, options [nop,nop,TS val 2645970704 ecr 124166014], length 0
20:33:21.684145 IP (tos 0x0, ttl 62, id 10035, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x78fc), seq 36240:38656, ack 1, win 1454, options [nop,nop,TS val 124166052 ecr 2645970704], length 2416
20:33:21.689942 IP (tos 0x0, ttl 46, id 43034, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x453c (correct), ack 14496, win 4924, options [nop,nop,TS val 2645970708 ecr 124166014], length 0
20:33:21.690496 IP (tos 0x0, ttl 62, id 10037, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x879a), seq 38656:41072, ack 1, win 1454, options [nop,nop,TS val 124166053 ecr 2645970708], length 2416
20:33:21.695937 IP (tos 0x0, ttl 46, id 43035, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x407e (correct), ack 15704, win 4924, options [nop,nop,TS val 2645970713 ecr 124166015], length 0
20:33:21.696541 IP (tos 0x0, ttl 62, id 10039, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xd39d), seq 41072:43488, ack 1, win 1454, options [nop,nop,TS val 124166055 ecr 2645970713], length 2416
20:33:21.699569 IP (tos 0x0, ttl 46, id 43036, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x3bc2 (correct), ack 16912, win 4924, options [nop,nop,TS val 2645970717 ecr 124166015], length 0
20:33:21.700173 IP (tos 0x0, ttl 62, id 10041, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x504f), seq 43488:45904, ack 1, win 1454, options [nop,nop,TS val 124166056 ecr 2645970717], length 2416
20:33:21.703181 IP (tos 0x0, ttl 46, id 43037, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x3703 (correct), ack 18120, win 4924, options [nop,nop,TS val 2645970722 ecr 124166017], length 0
20:33:21.703769 IP (tos 0x0, ttl 62, id 10043, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x2bdc), seq 45904:48320, ack 1, win 1454, options [nop,nop,TS val 124166057 ecr 2645970722], length 2416
20:33:21.706932 IP (tos 0x0, ttl 46, id 43038, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x3247 (correct), ack 19328, win 4924, options [nop,nop,TS val 2645970726 ecr 124166017], length 0
20:33:21.707520 IP (tos 0x0, ttl 62, id 10045, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xf3d8), seq 48320:50736, ack 1, win 1454, options [nop,nop,TS val 124166058 ecr 2645970726], length 2416
20:33:21.715971 IP (tos 0x0, ttl 46, id 43039, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x28cc (correct), ack 21744, win 4924, options [nop,nop,TS val 2645970737 ecr 124166017], length 0
20:33:21.716527 IP (tos 0x0, ttl 62, id 10047, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xb38d), seq 50736:53152, ack 1, win 1454, options [nop,nop,TS val 124166060 ecr 2645970737], length 2416
20:33:21.716676 IP (tos 0x0, ttl 62, id 10049, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0xbc0c), seq 53152:55568, ack 1, win 1454, options [nop,nop,TS val 124166060 ecr 2645970737], length 2416
20:33:21.729944 IP (tos 0x0, ttl 46, id 43040, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x1f4e (correct), ack 24160, win 4924, options [nop,nop,TS val 2645970751 ecr 124166017], length 0
20:33:21.730567 IP (tos 0x0, ttl 62, id 10051, offset 0, flags [DF], proto TCP (6), length 3676)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0x0433 (incorrect -> 0x71a7), seq 55568:59192, ack 1, win 1454, options [nop,nop,TS val 124166063 ecr 2645970751], length 3624
20:33:21.730664 IP (tos 0x0, ttl 62, id 10054, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xb77c (correct), seq 59192:60400, ack 1, win 1454, options [nop,nop,TS val 124166063 ecr 2645970751], length 1208
20:33:21.739947 IP (tos 0x0, ttl 49, id 35358, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x999c (correct), ack 13288, win 1146, options [nop,nop,TS val 1748335932 ecr 124166021], length 0
20:33:21.740556 IP (tos 0x0, ttl 62, id 16799, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xf8e9), seq 30200:32616, ack 1, win 1454, options [nop,nop,TS val 124166066 ecr 1748335932], length 2416
20:33:21.743173 IP (tos 0x0, ttl 46, id 43041, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x15cf (correct), ack 26576, win 4924, options [nop,nop,TS val 2645970763 ecr 124166020], length 0
20:33:21.744001 IP (tos 0x0, ttl 62, id 10055, offset 0, flags [DF], proto TCP (6), length 4884)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0x08eb (incorrect -> 0x4fe7), seq 60400:65232, ack 1, win 1454, options [nop,nop,TS val 124166067 ecr 2645970763], length 4832
20:33:21.763076 IP (tos 0x0, ttl 46, id 43042, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x0c4f (correct), ack 28992, win 4924, options [nop,nop,TS val 2645970779 ecr 124166020], length 0
20:33:21.763683 IP (tos 0x0, ttl 62, id 10059, offset 0, flags [DF], proto TCP (6), length 4884)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0x08eb (incorrect -> 0x8b1d), seq 65232:70064, ack 1, win 1454, options [nop,nop,TS val 124166072 ecr 2645970779], length 4832
20:33:21.774949 IP (tos 0x0, ttl 49, id 35360, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x9017 (correct), ack 15704, win 1130, options [nop,nop,TS val 1748335967 ecr 124166023], length 0
20:33:21.775533 IP (tos 0x0, ttl 62, id 16801, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0x65c8), seq 32616:35032, ack 1, win 1454, options [nop,nop,TS val 124166075 ecr 1748335967], length 2416
20:33:21.786962 IP (tos 0x0, ttl 49, id 35361, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x8b5a (correct), ack 16912, win 1122, options [nop,nop,TS val 1748335980 ecr 124166023], length 0
20:33:21.786962 IP (tos 0x0, ttl 49, id 35361, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x8b5a (correct), ack 16912, win 1122, options [nop,nop,TS val 1748335980 ecr 124166023], length 0
20:33:21.787068 IP (tos 0x0, ttl 49, id 35361, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x8b5a (correct), ack 16912, win 1122, options [nop,nop,TS val 1748335980 ecr 124166023], length 0
20:33:21.787068 IP (tos 0x0, ttl 49, id 35361, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x8b5a (correct), ack 16912, win 1122, options [nop,nop,TS val 1748335980 ecr 124166023], length 0
20:33:21.787792 IP (tos 0x0, ttl 62, id 16803, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0xab87 (correct), seq 35032:36240, ack 1, win 1454, options [nop,nop,TS val 124166078 ecr 1748335980], length 1208
20:33:21.790682 IP (tos 0x0, ttl 46, id 43043, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0x02c0 (correct), ack 31408, win 4924, options [nop,nop,TS val 2645970808 ecr 124166022], length 0
20:33:21.791307 IP (tos 0x0, ttl 62, id 10063, offset 0, flags [DF], proto TCP (6), length 4884)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0x08eb (incorrect -> 0xacd2), seq 70064:74896, ack 1, win 1454, options [nop,nop,TS val 124166079 ecr 2645970808], length 4832
20:33:21.808984 IP (tos 0x0, ttl 49, id 35362, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x8691 (correct), ack 18120, win 1115, options [nop,nop,TS val 1748336002 ecr 124166025], length 0
20:33:21.809598 IP (tos 0x0, ttl 62, id 16804, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0xb980), seq 36240:38656, ack 1, win 1454, options [nop,nop,TS val 124166083 ecr 1748336002], length 2416
20:33:21.817942 IP (tos 0x0, ttl 49, id 35363, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x81d9 (correct), ack 19328, win 1107, options [nop,nop,TS val 1748336010 ecr 124166025], length 0
20:33:21.818535 IP (tos 0x0, ttl 62, id 16806, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x59bc (correct), seq 38656:39864, ack 1, win 1454, options [nop,nop,TS val 124166085 ecr 1748336010], length 1208
20:33:21.821567 IP (tos 0x0, ttl 46, id 43044, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0xf931 (correct), ack 33824, win 4924, options [nop,nop,TS val 2645970836 ecr 124166024], length 0
20:33:21.822215 IP (tos 0x0, ttl 62, id 10067, offset 0, flags [DF], proto TCP (6), length 1260)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0x5b80 (correct), seq 74896:76104, ack 1, win 1454, options [nop,nop,TS val 124166086 ecr 2645970836], length 1208
20:33:21.822320 IP (tos 0x0, ttl 62, id 10068, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0xff7a (incorrect -> 0x2517), seq 76104:78520, ack 1, win 1454, options [nop,nop,TS val 124166086 ecr 2645970836], length 2416
20:33:21.854968 IP (tos 0x0, ttl 46, id 43045, offset 0, flags [DF], proto TCP (6), length 52)
    65.60.241.155.18080 > 192.168.2.100.39150: Flags [.], cksum 0xef99 (correct), ack 36240, win 4924, options [nop,nop,TS val 2645970874 ecr 124166026], length 0
20:33:21.855800 IP (tos 0x0, ttl 62, id 10070, offset 0, flags [DF], proto TCP (6), length 4884)
    192.168.2.100.39150 > 65.60.241.155.18080: Flags [.], cksum 0x08eb (incorrect -> 0xd356), seq 78520:83352, ack 1, win 1454, options [nop,nop,TS val 124166095 ecr 2645970874], length 4832
20:33:21.861672 IP (tos 0x0, ttl 62, id 20621, offset 0, flags [DF], proto TCP (6), length 2480)
    192.168.2.100.44752 > 175.139.92.5.18080: Flags [.], cksum 0xd83f (incorrect -> 0x12b1), seq 115347395:115349835, ack 3790161905, win 4332, length 2440
20:33:21.861931 IP (tos 0x0, ttl 62, id 20623, offset 0, flags [DF], proto TCP (6), length 2480)
    192.168.2.100.44752 > 175.139.92.5.18080: Flags [.], cksum 0xd83f (incorrect -> 0xa477), seq 2440:4880, ack 1, win 4332, length 2440
20:33:21.862083 IP (tos 0x0, ttl 62, id 20625, offset 0, flags [DF], proto TCP (6), length 2480)
    192.168.2.100.44752 > 175.139.92.5.18080: Flags [.], cksum 0xd83f (incorrect -> 0xd409), seq 4880:7320, ack 1, win 4332, length 2440
20:33:21.862244 IP (tos 0x0, ttl 62, id 20627, offset 0, flags [DF], proto TCP (6), length 2480)
    192.168.2.100.44752 > 175.139.92.5.18080: Flags [.], cksum 0xd83f (incorrect -> 0x6844), seq 7320:9760, ack 1, win 4332, length 2440
20:33:21.862400 IP (tos 0x0, ttl 62, id 20629, offset 0, flags [DF], proto TCP (6), length 2480)
    192.168.2.100.44752 > 175.139.92.5.18080: Flags [.], cksum 0xd83f (incorrect -> 0x75cb), seq 9760:12200, ack 1, win 4332, length 2440
20:33:21.864921 IP (tos 0x0, ttl 62, id 31866, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.55998 > 76.115.209.107.18080: Flags [.], cksum 0xea81 (incorrect -> 0x6307), seq 429460711:429463127, ack 3056354859, win 1454, options [nop,nop,TS val 124166097 ecr 3077197032], length 2416
20:33:21.865132 IP (tos 0x0, ttl 62, id 31868, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.55998 > 76.115.209.107.18080: Flags [.], cksum 0xea81 (incorrect -> 0x767a), seq 2416:4832, ack 1, win 1454, options [nop,nop,TS val 124166097 ecr 3077197032], length 2416
20:33:21.865287 IP (tos 0x0, ttl 62, id 31870, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.55998 > 76.115.209.107.18080: Flags [.], cksum 0xea81 (incorrect -> 0x2900), seq 4832:7248, ack 1, win 1454, options [nop,nop,TS val 124166097 ecr 3077197032], length 2416
20:33:21.865445 IP (tos 0x0, ttl 62, id 31872, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.55998 > 76.115.209.107.18080: Flags [.], cksum 0xea81 (incorrect -> 0xe862), seq 7248:9664, ack 1, win 1454, options [nop,nop,TS val 124166097 ecr 3077197032], length 2416
20:33:21.865603 IP (tos 0x0, ttl 62, id 31874, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.55998 > 76.115.209.107.18080: Flags [.], cksum 0xea81 (incorrect -> 0xb321), seq 9664:12080, ack 1, win 1454, options [nop,nop,TS val 124166097 ecr 3077197032], length 2416
20:33:21.866628 IP (tos 0x0, ttl 62, id 285, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39396 > 188.34.179.199.18080: Flags [.], cksum 0x3c8d (incorrect -> 0x9a4e), seq 2301976642:2301979058, ack 3960046762, win 2192, options [nop,nop,TS val 124166097 ecr 1817777483], length 2416
20:33:21.866822 IP (tos 0x0, ttl 62, id 287, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39396 > 188.34.179.199.18080: Flags [.], cksum 0x3c8d (incorrect -> 0xadc1), seq 2416:4832, ack 1, win 2192, options [nop,nop,TS val 124166097 ecr 1817777483], length 2416
20:33:21.867210 IP (tos 0x0, ttl 62, id 289, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39396 > 188.34.179.199.18080: Flags [.], cksum 0x3c8d (incorrect -> 0x6047), seq 4832:7248, ack 1, win 2192, options [nop,nop,TS val 124166097 ecr 1817777483], length 2416
20:33:21.867364 IP (tos 0x0, ttl 62, id 291, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39396 > 188.34.179.199.18080: Flags [.], cksum 0x3c8d (incorrect -> 0x1fa9), seq 7248:9664, ack 1, win 2192, options [nop,nop,TS val 124166098 ecr 1817777483], length 2416
20:33:21.867584 IP (tos 0x0, ttl 62, id 293, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.39396 > 188.34.179.199.18080: Flags [.], cksum 0x3c8d (incorrect -> 0xea67), seq 9664:12080, ack 1, win 2192, options [nop,nop,TS val 124166098 ecr 1817777483], length 2416
20:33:21.869564 IP (tos 0x0, ttl 49, id 35364, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x6581 (correct), ack 26576, win 1060, options [nop,nop,TS val 1748336063 ecr 124166027], length 0
20:33:21.870267 IP (tos 0x0, ttl 62, id 16807, offset 0, flags [DF], proto TCP (6), length 4884)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0xa59e (incorrect -> 0x227c), seq 39864:44696, ack 1, win 1454, options [nop,nop,TS val 124166098 ecr 1748336063], length 4832
20:33:21.870380 IP (tos 0x0, ttl 62, id 16811, offset 0, flags [DF], proto TCP (6), length 2468)
    192.168.2.100.60720 > 91.198.115.197.18280: Flags [.], cksum 0x9c2e (incorrect -> 0x49d6), seq 44696:47112, ack 1, win 1454, options [nop,nop,TS val 124166098 ecr 1748336063], length 2416
20:33:21.908010 IP (tos 0x0, ttl 49, id 35365, offset 0, flags [DF], proto TCP (6), length 52)
    91.198.115.197.18280 > 192.168.2.100.60720: Flags [.], cksum 0x5745 (correct), ack 30200, win 1037, options [nop,nop,TS val 1748336100 ecr 124166033], length 0

Nothing weird, everything works as expected.
Can you run again the tcpdump and at the same time from another ssh session run the traceroute.

1 Like

Hope this is better.

00:00:29.898524 IP (tos 0x28, ttl 45, id 10458, offset 0, flags [DF], proto TCP (6), length 257)
    209.126.8.142.18080 > 192.168.2.100.58892: Flags [P.], cksum 0x4357 (correct), seq 61047:61252, ack 61101, win 2285, options [nop,nop,TS val 3425049132 ecr 148872501], length 205
00:00:29.899189 IP (tos 0x0, ttl 62, id 23519, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.58892 > 209.126.8.142.18080: Flags [.], cksum 0x6ffc (correct), ack 61252, win 4815, options [nop,nop,TS val 148873109 ecr 3425049132], length 0
00:00:29.904453 IP (tos 0x0, ttl 62, id 23520, offset 0, flags [DF], proto TCP (6), length 331)
    192.168.2.100.58892 > 209.126.8.142.18080: Flags [P.], cksum 0xeda2 (correct), seq 61101:61380, ack 61252, win 4815, options [nop,nop,TS val 148873110 ecr 3425049132], length 279
00:00:30.054399 IP (tos 0x28, ttl 45, id 10459, offset 0, flags [DF], proto TCP (6), length 52)
    209.126.8.142.18080 > 192.168.2.100.58892: Flags [.], cksum 0x7829 (correct), ack 61380, win 2283, options [nop,nop,TS val 3425049291 ecr 148873110], length 0
00:00:30.147289 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 8.8.8.8 tell 192.168.2.100, length 28
00:00:30.718511 IP (tos 0x48, ttl 108, id 37466, offset 0, flags [DF], proto TCP (6), length 245)
    71.120.98.88.18080 > 192.168.2.100.32822: Flags [P.], cksum 0xf86e (correct), seq 1:206, ack 60994, win 514, length 205
00:00:30.718995 IP (tos 0x0, ttl 62, id 42057, offset 0, flags [DF], proto TCP (6), length 40)
    192.168.2.100.32822 > 71.120.98.88.18080: Flags [.], cksum 0xddd6 (correct), ack 206, win 1462, length 0
00:00:30.721363 IP (tos 0x0, ttl 62, id 42058, offset 0, flags [DF], proto TCP (6), length 520)
    192.168.2.100.32822 > 71.120.98.88.18080: Flags [P.], cksum 0xc4aa (correct), seq 60994:61474, ack 206, win 1462, length 480
00:00:31.021520 IP (tos 0x48, ttl 108, id 37467, offset 0, flags [DF], proto TCP (6), length 40)
    71.120.98.88.18080 > 192.168.2.100.32822: Flags [.], cksum 0xdfac (correct), ack 61474, win 512, length 0
00:00:31.827116 IP (tos 0x0, ttl 64, id 62914, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 5154+ PTR? 229.20.168.192.in-addr.arpa. (45)
00:00:31.827308 IP (tos 0x0, ttl 64, id 62915, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 10937+ PTR? 179.80.168.192.in-addr.arpa. (45)
00:00:31.827435 IP (tos 0x0, ttl 64, id 62916, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 25738+ PTR? 200.30.168.192.in-addr.arpa. (45)
00:00:31.827548 IP (tos 0x0, ttl 64, id 62917, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 14182+ PTR? 170.80.168.192.in-addr.arpa. (45)
00:00:31.827655 IP (tos 0x0, ttl 64, id 62918, offset 0, flags [DF], proto UDP (17), length 72)
    192.168.2.100.39842 > 8.8.8.8.53: 57014+ PTR? 100.2.168.192.in-addr.arpa. (44)
00:00:31.827767 IP (tos 0x0, ttl 64, id 62919, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.2.100.39842 > 8.8.8.8.53: 36574+ PTR? 1.10.168.192.in-addr.arpa. (43)
00:00:31.827997 IP (tos 0x0, ttl 64, id 62920, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.2.100.39842 > 8.8.8.8.53: 64894+ PTR? 1.20.168.192.in-addr.arpa. (43)
00:00:31.828244 IP (tos 0x0, ttl 64, id 62921, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.2.100.39842 > 8.8.8.8.53: 53012+ PTR? 1.30.168.192.in-addr.arpa. (43)
00:00:31.828428 IP (tos 0x0, ttl 64, id 62922, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.2.100.39842 > 8.8.8.8.53: 42016+ PTR? 1.60.168.192.in-addr.arpa. (43)
00:00:31.828641 IP (tos 0x0, ttl 64, id 62923, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.2.100.39842 > 8.8.8.8.53: 58272+ PTR? 1.80.168.192.in-addr.arpa. (43)
00:00:31.828825 IP (tos 0x0, ttl 64, id 62924, offset 0, flags [DF], proto UDP (17), length 71)
    192.168.2.100.39842 > 8.8.8.8.53: 43096+ PTR? 1.90.168.192.in-addr.arpa. (43)
00:00:31.829075 IP (tos 0x0, ttl 64, id 62925, offset 0, flags [DF], proto UDP (17), length 72)
    192.168.2.100.39842 > 8.8.8.8.53: 30413+ PTR? 121.1.168.192.in-addr.arpa. (44)
00:00:31.829274 IP (tos 0x0, ttl 64, id 62926, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 36909+ PTR? 150.90.168.192.in-addr.arpa. (45)
00:00:31.829456 IP (tos 0x0, ttl 64, id 62927, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 20905+ PTR? 145.10.168.192.in-addr.arpa. (45)
00:00:31.829570 IP (tos 0x0, ttl 64, id 62928, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 2187+ PTR? 145.60.168.192.in-addr.arpa. (45)
00:00:31.829768 IP (tos 0x0, ttl 64, id 62929, offset 0, flags [DF], proto UDP (17), length 70)
    192.168.2.100.39842 > 8.8.8.8.53: 2974+ PTR? 1.2.168.192.in-addr.arpa. (42)
00:00:31.829954 IP (tos 0x0, ttl 64, id 62930, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 57331+ PTR? 141.60.168.192.in-addr.arpa. (45)
00:00:31.830142 IP (tos 0x0, ttl 64, id 62931, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 51418+ PTR? 139.60.168.192.in-addr.arpa. (45)
00:00:31.830250 IP (tos 0x0, ttl 64, id 62932, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 30529+ PTR? 136.80.168.192.in-addr.arpa. (45)
00:00:31.830359 IP (tos 0x0, ttl 64, id 62933, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 5641+ PTR? 224.90.168.192.in-addr.arpa. (45)
00:00:31.830540 IP (tos 0x0, ttl 64, id 62934, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 56324+ PTR? 123.80.168.192.in-addr.arpa. (45)
00:00:31.830754 IP (tos 0x0, ttl 64, id 62935, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 8191+ PTR? 135.10.168.192.in-addr.arpa. (45)
00:00:31.830935 IP (tos 0x0, ttl 64, id 62936, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 59320+ PTR? 204.10.168.192.in-addr.arpa. (45)
00:00:31.831087 IP (tos 0x0, ttl 64, id 62937, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 15075+ PTR? 104.20.168.192.in-addr.arpa. (45)
00:00:31.831241 IP (tos 0x0, ttl 64, id 62938, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 34846+ PTR? 108.10.168.192.in-addr.arpa. (45)
00:00:31.831425 IP (tos 0x0, ttl 64, id 62939, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 25023+ PTR? 141.10.168.192.in-addr.arpa. (45)
00:00:31.831574 IP (tos 0x0, ttl 64, id 62940, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 43161+ PTR? 154.80.168.192.in-addr.arpa. (45)
00:00:31.831767 IP (tos 0x0, ttl 64, id 62941, offset 0, flags [DF], proto UDP (17), length 72)
    192.168.2.100.39842 > 8.8.8.8.53: 36659+ PTR? 254.1.168.192.in-addr.arpa. (44)
00:00:31.831909 IP (tos 0x0, ttl 64, id 62942, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 50810+ PTR? 172.30.168.192.in-addr.arpa. (45)
00:00:31.885497 IP (tos 0x0, ttl 118, id 12192, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 5154 NXDomain 0/0/0 (45)
00:00:31.888707 IP (tos 0x0, ttl 118, id 22593, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 10937 NXDomain 0/0/0 (45)
00:00:31.888707 IP (tos 0x0, ttl 118, id 36391, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 14182 NXDomain 0/0/0 (45)
00:00:31.888707 IP (tos 0x0, ttl 118, id 64068, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 25738 NXDomain 0/0/0 (45)
00:00:31.888707 IP (tos 0x0, ttl 118, id 3418, offset 0, flags [none], proto UDP (17), length 72)
    8.8.8.8.53 > 192.168.2.100.39842: 57014 NXDomain 0/0/0 (44)
00:00:31.888882 IP (tos 0x0, ttl 118, id 43673, offset 0, flags [none], proto UDP (17), length 71)
    8.8.8.8.53 > 192.168.2.100.39842: 36574 NXDomain 0/0/0 (43)
00:00:31.888882 IP (tos 0x0, ttl 118, id 33626, offset 0, flags [none], proto UDP (17), length 71)
    8.8.8.8.53 > 192.168.2.100.39842: 64894 NXDomain 0/0/0 (43)
00:00:31.892046 IP (tos 0x0, ttl 118, id 25129, offset 0, flags [none], proto UDP (17), length 71)
    8.8.8.8.53 > 192.168.2.100.39842: 53012 NXDomain 0/0/0 (43)
00:00:31.892194 IP (tos 0x0, ttl 118, id 22633, offset 0, flags [none], proto UDP (17), length 71)
    8.8.8.8.53 > 192.168.2.100.39842: 43096 NXDomain 0/0/0 (43)
00:00:31.892194 IP (tos 0x0, ttl 118, id 63544, offset 0, flags [none], proto UDP (17), length 71)
    8.8.8.8.53 > 192.168.2.100.39842: 42016 NXDomain 0/0/0 (43)
00:00:31.892194 IP (tos 0x0, ttl 118, id 2872, offset 0, flags [none], proto UDP (17), length 71)
    8.8.8.8.53 > 192.168.2.100.39842: 58272 NXDomain 0/0/0 (43)
00:00:31.892194 IP (tos 0x0, ttl 118, id 22303, offset 0, flags [none], proto UDP (17), length 72)
    8.8.8.8.53 > 192.168.2.100.39842: 30413 NXDomain 0/0/0 (44)
00:00:31.892299 IP (tos 0x0, ttl 118, id 64070, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 36909 NXDomain 0/0/0 (45)
00:00:31.892300 IP (tos 0x0, ttl 118, id 33627, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 20905 NXDomain 0/0/0 (45)
00:00:31.892300 IP (tos 0x0, ttl 118, id 36393, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 2187 NXDomain 0/0/0 (45)
00:00:31.892430 IP (tos 0x0, ttl 118, id 63545, offset 0, flags [none], proto UDP (17), length 70)
    8.8.8.8.53 > 192.168.2.100.39842: 2974 NXDomain 0/0/0 (42)
00:00:31.895697 IP (tos 0x0, ttl 118, id 22305, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 57331 NXDomain 0/0/0 (45)
00:00:31.895697 IP (tos 0x0, ttl 118, id 12194, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 51418 NXDomain 0/0/0 (45)
00:00:31.895698 IP (tos 0x0, ttl 118, id 46204, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 5641 NXDomain 0/0/0 (45)
00:00:31.895698 IP (tos 0x0, ttl 118, id 51407, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 30529 NXDomain 0/0/0 (45)
00:00:31.895876 IP (tos 0x0, ttl 118, id 51408, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 56324 NXDomain 0/0/0 (45)
00:00:31.895876 IP (tos 0x0, ttl 118, id 46205, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 8191 NXDomain 0/0/0 (45)
00:00:31.899111 IP (tos 0x0, ttl 118, id 2875, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 59320 NXDomain 0/0/0 (45)
00:00:31.899111 IP (tos 0x0, ttl 118, id 43675, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 15075 NXDomain 0/0/0 (45)
00:00:31.899111 IP (tos 0x0, ttl 118, id 59583, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 25023 NXDomain 0/0/0 (45)
00:00:31.899111 IP (tos 0x0, ttl 118, id 25131, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 34846 NXDomain 0/0/0 (45)
00:00:31.899293 IP (tos 0x0, ttl 118, id 43676, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 43161 NXDomain 0/0/0 (45)
00:00:31.899293 IP (tos 0x0, ttl 118, id 22601, offset 0, flags [none], proto UDP (17), length 72)
    8.8.8.8.53 > 192.168.2.100.39842: 36659 NXDomain 0/0/0 (44)
00:00:31.902413 IP (tos 0x0, ttl 118, id 12195, offset 0, flags [none], proto UDP (17), length 73)
    8.8.8.8.53 > 192.168.2.100.39842: 50810 NXDomain 0/0/0 (45)
00:00:32.782567 IP (tos 0x0, ttl 50, id 35783, offset 0, flags [DF], proto TCP (6), length 257)
    94.130.216.209.18080 > 192.168.2.100.45156: Flags [P.], cksum 0xbaea (correct), seq 60995:61200, ack 61100, win 2110, options [nop,nop,TS val 3053624552 ecr 148872393], length 205
00:00:32.783232 IP (tos 0x0, ttl 62, id 31736, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.45156 > 94.130.216.209.18080: Flags [.], cksum 0xdb36 (correct), ack 61200, win 6972, options [nop,nop,TS val 148873830 ecr 3053624552], length 0
00:00:32.788785 IP (tos 0x0, ttl 62, id 31737, offset 0, flags [DF], proto TCP (6), length 544)
    192.168.2.100.45156 > 94.130.216.209.18080: Flags [P.], cksum 0xac50 (correct), seq 61100:61592, ack 61200, win 6972, options [nop,nop,TS val 148873831 ecr 3053624552], length 492
00:00:32.862471 IP (tos 0x0, ttl 50, id 35784, offset 0, flags [DF], proto TCP (6), length 52)
    94.130.216.209.18080 > 192.168.2.100.45156: Flags [.], cksum 0xebf6 (correct), ack 61592, win 2107, options [nop,nop,TS val 3053624636 ecr 148873831], length 0
00:00:33.081593 IP (tos 0x0, ttl 51, id 668, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [.], cksum 0xc357 (correct), seq 35439:36647, ack 61379, win 5380, options [nop,nop,TS val 3930053180 ecr 148872008], length 1208
00:00:33.081698 IP (tos 0x0, ttl 51, id 669, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [P.], cksum 0x07d4 (correct), seq 36647:37855, ack 61379, win 5380, options [nop,nop,TS val 3930053180 ecr 148872008], length 1208
00:00:33.082492 IP (tos 0x0, ttl 62, id 61676, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.41974 > 65.108.195.176.18080: Flags [.], cksum 0xb930 (correct), ack 37855, win 4046, options [nop,nop,TS val 148873905 ecr 3930053180], length 0
00:00:33.084737 IP (tos 0x0, ttl 51, id 670, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [.], cksum 0x8215 (correct), seq 37855:39063, ack 61379, win 5380, options [nop,nop,TS val 3930053180 ecr 148872008], length 1208
00:00:33.084842 IP (tos 0x0, ttl 51, id 671, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [P.], cksum 0x40ca (correct), seq 39063:40271, ack 61379, win 5380, options [nop,nop,TS val 3930053180 ecr 148872008], length 1208
00:00:33.084947 IP (tos 0x0, ttl 51, id 672, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [.], cksum 0xf24a (correct), seq 40271:41479, ack 61379, win 5380, options [nop,nop,TS val 3930053183 ecr 148872008], length 1208
00:00:33.085056 IP (tos 0x0, ttl 51, id 673, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [P.], cksum 0x7de5 (correct), seq 41479:42687, ack 61379, win 5380, options [nop,nop,TS val 3930053183 ecr 148872008], length 1208
00:00:33.085155 IP (tos 0x0, ttl 51, id 674, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [.], cksum 0x1dd7 (correct), seq 42687:43895, ack 61379, win 5380, options [nop,nop,TS val 3930053183 ecr 148872008], length 1208
00:00:33.085258 IP (tos 0x0, ttl 51, id 675, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [P.], cksum 0xfcf2 (correct), seq 43895:45103, ack 61379, win 5380, options [nop,nop,TS val 3930053183 ecr 148872008], length 1208
00:00:33.085361 IP (tos 0x0, ttl 51, id 676, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [.], cksum 0x7874 (correct), seq 45103:46311, ack 61379, win 5380, options [nop,nop,TS val 3930053185 ecr 148872008], length 1208
00:00:33.085465 IP (tos 0x0, ttl 51, id 677, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [P.], cksum 0x90e9 (correct), seq 46311:47519, ack 61379, win 5380, options [nop,nop,TS val 3930053185 ecr 148872008], length 1208
00:00:33.086073 IP (tos 0x0, ttl 62, id 61677, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.41974 > 65.108.195.176.18080: Flags [.], cksum 0x93b3 (correct), ack 47519, win 3978, options [nop,nop,TS val 148873906 ecr 3930053180], length 0
00:00:33.163630 IP (tos 0x0, ttl 51, id 678, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [.], cksum 0x79c4 (correct), seq 47519:48727, ack 61379, win 5380, options [nop,nop,TS val 3930053272 ecr 148873905], length 1208
00:00:33.163735 IP (tos 0x0, ttl 51, id 679, offset 0, flags [DF], proto TCP (6), length 1260)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [P.], cksum 0xf2a4 (correct), seq 48727:49935, ack 61379, win 5380, options [nop,nop,TS val 3930053272 ecr 148873905], length 1208
00:00:33.164321 IP (tos 0x0, ttl 62, id 61678, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.41974 > 65.108.195.176.18080: Flags [.], cksum 0x899a (correct), ack 49935, win 4036, options [nop,nop,TS val 148873925 ecr 3930053272], length 0
00:00:33.166743 IP (tos 0x0, ttl 51, id 680, offset 0, flags [DF], proto TCP (6), length 2023)
    65.108.195.176.18080 > 192.168.2.100.41974: Flags [P.], cksum 0xd002 (incorrect -> 0x1c5e), seq 49935:51906, ack 61379, win 5380, options [nop,nop,TS val 3930053272 ecr 148873905], length 1971
00:00:33.167427 IP (tos 0x0, ttl 62, id 61679, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.41974 > 65.108.195.176.18080: Flags [.], cksum 0x81e6 (correct), ack 51906, win 4036, options [nop,nop,TS val 148873926 ecr 3930053272], length 0
00:00:33.562700 IP (tos 0x0, ttl 113, id 12243, offset 0, flags [DF], proto TCP (6), length 2468)
    109.226.236.39.18080 > 192.168.2.100.40886: Flags [.], cksum 0x26ad (incorrect -> 0x4a81), seq 58132:60548, ack 61405, win 259, options [nop,nop,TS val 76156879 ecr 148872721], length 2416
00:00:33.563609 IP (tos 0x0, ttl 62, id 9267, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.40886 > 109.226.236.39.18080: Flags [.], cksum 0x3583 (correct), ack 60548, win 2263, options [nop,nop,TS val 148874025 ecr 76156879], length 0
00:00:33.565756 IP (tos 0x0, ttl 113, id 12245, offset 0, flags [DF], proto TCP (6), length 1260)
    109.226.236.39.18080 > 192.168.2.100.40886: Flags [.], cksum 0x1612 (correct), seq 60548:61756, ack 61405, win 259, options [nop,nop,TS val 76156879 ecr 148872721], length 1208
00:00:33.565864 IP (tos 0x0, ttl 113, id 12246, offset 0, flags [DF], proto TCP (6), length 1314)
    109.226.236.39.18080 > 192.168.2.100.40886: Flags [P.], cksum 0x222b (incorrect -> 0x6183), seq 61756:63018, ack 61405, win 259, options [nop,nop,TS val 76156879 ecr 148872721], length 1262
00:00:33.566621 IP (tos 0x0, ttl 62, id 9268, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.40886 > 109.226.236.39.18080: Flags [.], cksum 0x2bdc (correct), ack 63018, win 2263, options [nop,nop,TS val 148874026 ecr 76156879], length 0
00:00:34.121637 IP (tos 0x0, ttl 44, id 5954, offset 0, flags [DF], proto TCP (6), length 1870)
    121.99.197.52.18080 > 192.168.2.100.34566: Flags [P.], cksum 0x08e5 (incorrect -> 0x71aa), seq 61200:63018, ack 64720, win 4640, options [nop,nop,TS val 2101793115 ecr 148872526], length 1818
00:00:34.122441 IP (tos 0x0, ttl 62, id 1158, offset 0, flags [DF], proto TCP (6), length 52)
    192.168.2.100.34566 > 121.99.197.52.18080: Flags [.], cksum 0x9566 (correct), ack 63018, win 7083, options [nop,nop,TS val 148874165 ecr 2101793115], length 0

Something really weird is happening. I've turned off the wan interface on purpose, and now the 4G failsafe works fine:

traceroute  -i br-lan.100 -m 15 -q 2 -v 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 15 hops max, 38 byte packets
 1  192.168.2.1 (192.168.2.1) 46 bytes to 192.168.2.100  0.478 ms  0.408 ms
 2  *
64 bytes from 8.8.8.8 to 192.168.2.100: icmp type 0 (Echo Reply) code 0
0000: 00 00 bc d1 56 e0 00 00 99 ef 52 5e 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  *
 3  172.21.211.1 (172.21.211.1) 36 bytes to 192.168.2.100  47.290 ms  50.883 ms
 4  *
64 bytes from 8.8.8.8 to 192.168.2.100: icmp type 0 (Echo Reply) code 0
0000: 00 00 9a 07 56 e5 00 00 22 b4 ec 5e 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  *
 5  *
64 bytes from 8.8.8.8 to 192.168.2.100: icmp type 0 (Echo Reply) code 0
0000: 00 00 0f 60 56 ea 00 00 13 56 86 5f 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  *
 6  172.21.216.93 (172.21.216.93) 36 bytes to 192.168.2.100  40.299 ms  34.835 ms
 7  *
64 bytes from 8.8.8.8 to 192.168.2.100: icmp type 0 (Echo Reply) code 0
0000: 00 00 73 a3 56 ef 00 00 15 0d 20 60 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  *
 8  172.21.195.146 (172.21.195.146) 46 bytes to 192.168.2.100  45.066 ms  45.249 ms
 9  *
64 bytes from 8.8.8.8 to 192.168.2.100: icmp type 0 (Echo Reply) code 0
0000: 00 00 bb ce 56 f4 00 00 33 dc b9 60 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  *
10  142.250.162.44 (142.250.162.44) 46 bytes to 192.168.2.100  48.115 ms  44.790 ms
11
  *  108.170.246.161 (108.170.246.161) 76 bytes to 192.168.2.100  50.848 ms
12  dns.google (8.8.8.8) 36 bytes to 192.168.2.100  53.049 ms  142.251.52.149 (142.251.52.149) 46 bytes to 192.168.2.100  56.259 ms

Turn wan on again, and the test fails again:

traceroute  -i br-lan.100 -m 15 -q 2 -v 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 15 hops max, 38 byte packets
 1  192.168.2.1 (192.168.2.1) 46 bytes to 192.168.2.100  0.437 ms  0.400 ms
 2  192.168.2.100 (192.168.2.100) 46 bytes to 192.168.2.100  3080.591 ms !H
64 bytes from 8.8.8.8 to 192.168.2.100: icmp type 0 (Echo Reply) code 0
0000: 00 00 42 3b 5a 45 00 00 b2 16 b1 68 00 00 00 00
0010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
0030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
  3104.692 ms !H

So I did some more digging; I suspect that dns-crypt was ill configured; it was throwing exceptions, so I fixed that and restarted it.

So now, the ping test passes:

root@InnerRouter:~# ping -c 1 -I wan 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=117 time=15.588 ms

--- 8.8.8.8 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 15.588/15.588/15.588 ms

root@InnerRouter:~# ping -c 1 -I br-lan.100 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=114 time=64.595 ms

--- 8.8.8.8 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max = 64.595/64.595/64.595 ms

However, traceroute doesn't work as expected:

root@InnerRouter:~# traceroute -s 192.168.1.121 -i wan 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8) from 192.168.1.121, 30 hops max, 38 byte packets
 1  192.168.1.121 (192.168.1.121)  3122.408 ms !H  192.168.1.254 (192.168.1.254)  4.542 ms  192.168.1.121 (192.168.1.121)  3084.009 ms !H

root@InnerRouter:~# traceroute -s 192.168.2.100 -i br-lan.100 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8) from 192.168.2.100, 30 hops max, 38 byte packets
 1  192.168.2.1 (192.168.2.1)  0.450 ms  0.396 ms  0.317 ms
 2  *  *  192.168.2.100 (192.168.2.100)  3083.239 ms !H
 3  192.168.2.100 (192.168.2.100)  3105.064 ms !H  172.21.211.1 (172.21.211.1)  1061.043 ms  192.168.2.100 (192.168.2.100)  3148.341 ms !H

Surely this isn't to be expected?

A couple of things I find weird:

00:00:30.147289 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 8.8.8.8 tell 192.168.2.100, length 28

For some reason, it is trying to ARP 8.8.8.8, when it obviously should forward the packet to the gateway.
You have set the resolver for OpenWrt in /etc/resolv.conf the 8.8.8.8 and as a result you forward many useless queries.

00:00:31.827116 IP (tos 0x0, ttl 64, id 62914, offset 0, flags [DF], proto UDP (17), length 73)
    192.168.2.100.39842 > 8.8.8.8.53: 5154+ PTR? 229.20.168.192.in-addr.arpa. (45)

I am out of ideas here. I can only suggest to backup, reset, reconfigure, making sure in each step that everything works as it should.

1 Like

I figured it out and you won’t believe what it was!

I had setup the check connection option from mwan3 and then I had set it to ping every five seconds. This was for the 4G for the VDSL it wasn’t that frequently, I think every 10 seconds.

And the server I was pinging was 8.8.8.8!

So my guess is that my traffic got filtered/ignored/rejected from Google. I changed the setting to “always assume online” meaning there’s no pinging anymore, and guess what? It now works fine! Both pinging and trace routing!

I’ve tested with different wan interfaces and split them across the VLANs as I wanted and all seems fine.

I admit that the name resolution is sketchy, I’ve since removed all references to 8.8.8.8 and 8.8.4.4 and I’m using dns crypt again. I still don’t know why it wasn’t forwarding the packet to the gateway. I’ve since setup mwan3 to use one wan for some VLANs and the other for the rest. I haven’t tested with tcpdump to see if this problem still persists.

I think that the lesson here is to not use Google’s name server as the ping target to check if the connection is alive. Or if you do, make it a lot less frequent. Every 5 or 10 seconds is way too frequent and they probably dropped my traffic because of it.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.