Hello,
I just started using Openwrt on my Netgear R6220. I have three different Internet connections from 3 different providers. I have successfully configured LAN1 and LAN2 into WANB and WANC. All the the WAN ports connect to internet individually.
But Load Balancing is not working with mwan3.
WANB and WANC are shown disabled on load Balancing status window.
The mwan interfaces show WAN, WANB and WANC but WANB and WANC don't show a metric.
I have already assigned the metric as 10, 20 and 30 for WAN, WANB and WANC respectively while creating the interfaces. But it does not show here.
Load Balancing Status
Interfaces
Mwan interfaces
WANB and WANC don't seem to have metrics applied.
Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have
ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
uci export mwan3; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
Connecting to 192.168.0.1 port 22, please wait...
login as:
root@192.168.0.1's password:
BusyBox v1.30.1 () built-in shell (ash)
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -| || | | || || |
|_____|| |||||___||| |____|
|| W I R E L E S S F R E E D O M
OpenWrt 19.07.5, r11257-5090152ae3
root@OpenWrt:~# ubus call system board; \ uci export network; uci export wireles
s; \ uci export dhcp; uci export firewall; \ head -n -0 /etc/firewall.user; \ uc
i export mwan3; \ ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \ ip -6 addr ; ip
-6 ro li tab all ; ip -6 ru; \ ls -l /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/
- ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv./
{
"kernel": "4.14.209",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "Netgear R6220",
"board_name": "r6220",
"release": {
"distribution": "OpenWrt",
"version": "19.07.5",
"revision": "r11257-5090152ae3",
"target": "ramips/mt7621",
"description": "OpenWrt 19.07.5 r11257-5090152ae3"
}
}
-ash: uci: not found
package wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
option htmode 'HT20'
option disabled '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
config wifi-device 'radio1'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option disabled '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
-ash: uci: not found
package firewall
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wan6 WANB WANC'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config include
option path '/etc/firewall.user'
config forwarding
option dest 'lan'
option src 'wan'
-ash: head: not found
-ash: uci: not found
-ash: ip: not found
default via 192.168.29.1 dev eth0.2 table 1 metric 10
192.168.0.0/24 dev br-lan table 1 proto kernel scope link src 192.168.0.1
192.168.1.0/24 dev eth0.4 table 1 proto static scope link metric 30
192.168.4.0/24 dev eth0.3 table 1 proto static scope link metric 20
192.168.29.0/24 dev eth0.2 table 1 proto static scope link metric 10
default via 192.168.29.1 dev eth0.2 proto static src 192.168.29.13 metric 10
default via 192.168.4.1 dev eth0.3 proto static src 192.168.4.8 metric 20
default via 192.168.1.1 dev eth0.4 proto static src 192.168.1.2 metric 30
192.168.0.0/24 dev br-lan proto kernel scope link src 192.168.0.1
192.168.1.0/24 dev eth0.4 proto static scope link metric 30
192.168.4.0/24 dev eth0.3 proto static scope link metric 20
192.168.29.0/24 dev eth0.2 proto static scope link metric 10
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast 192.168.0.0 dev br-lan table local proto kernel scope link src 192.168.0.1
local 192.168.0.1 dev br-lan table local proto kernel scope host src 192.168.0.1
broadcast 192.168.0.255 dev br-lan table local proto kernel scope link src 192.168.0.1
broadcast 192.168.1.0 dev eth0.4 table local proto kernel scope link src 192.168.1.2
local 192.168.1.2 dev eth0.4 table local proto kernel scope host src 192.168.1.2
broadcast 192.168.1.255 dev eth0.4 table local proto kernel scope link src 192.168.1.2
broadcast 192.168.4.0 dev eth0.3 table local proto kernel scope link src 192.168.4.8
local 192.168.4.8 dev eth0.3 table local proto kernel scope host src 192.168.4.8
broadcast 192.168.4.255 dev eth0.3 table local proto kernel scope link src 192.168.4.8
broadcast 192.168.29.0 dev eth0.2 table local proto kernel scope link src 192.168.29.13
local 192.168.29.13 dev eth0.2 table local proto kernel scope host src 192.168.29.13
broadcast 192.168.29.255 dev eth0.2 table local proto kernel scope link src 192.168.29.13
0: from all lookup local
1001: from all iif eth0.2 lookup 1
2001: from all fwmark 0x100/0x3f00 lookup 1
2061: from all fwmark 0x3d00/0x3f00 blackhole
2062: from all fwmark 0x3e00/0x3f00 unreachable
32766: from all lookup main
32767: from all lookup default
-ash: ip: not found
default from 2405:201:300f:77::/64 via fe80::6a14:1ff:fe58:9f8b dev eth0.2 proto static metric 384 pref medium
2405:201:300f:77::/64 dev eth0.2 proto static metric 256 pref medium
fd4e:2271:c462::/64 dev br-lan proto static metric 1024 pref medium
unreachable fd4e:2271:c462::/48 dev lo proto static metric 2147483647 error 4294967148 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev eth0.3 proto kernel metric 256 pref medium
fe80::/64 dev eth0.4 proto kernel metric 256 pref medium
fe80::/64 dev eth0.2 proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev wlan0 proto kernel metric 256 pref medium
fe80::/64 dev wlan1 proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast 2405:201:300f:77:: dev eth0.2 table local proto kernel metric 0 pref medium
local 2405:201:300f:77:a02:xx:xx:xx:xxdev eth0.2 table local proto kernel metric 0 pref medium
anycast fd4e:2271:c462:: dev br-lan table local proto kernel metric 0 pref medium
local fd4e:2271:c462::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.4 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.2 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.3 table local proto kernel metric 0 pref medium
anycast fe80:: dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan0 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1 table local proto kernel metric 0 pref medium
local fe80::a xx:xx:xx:xxdev eth0.4 table local proto kernel metric 0 pref medium
local xx:xx:xx:xxd dev eth0 table local proto kernel metric 0 pref medium
local fe80::xx:xx:xx:xxdev br-lan table local proto kernel metric 0 pref medium
local fe80:::xx:xx:xx:xxdev wlan0 table local proto kernel metric 0 pref medium
local fe80:: xx:xx:xx:xxdev eth0.2 table local proto kernel metric 0 pref medium
local fe80:: xx:xx:xx:xx eth0.3 table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43ec dev wlan1 table local proto kernel metric 0 pref medium
ff00::/8 dev eth0 table local metric 256 pref medium
ff00::/8 dev br-lan table local metric 256 pref medium
ff00::/8 dev eth0.3 table local metric 256 pref medium
ff00::/8 dev eth0.4 table local metric 256 pref medium
ff00::/8 dev eth0.2 table local metric 256 pref medium
ff00::/8 dev wlan0 table local metric 256 pref medium
ff00::/8 dev wlan1 table local metric 256 pref medium
0: from all lookup local
2061: from all fwmark 0x3d00/0x3f00 blackhole
2062: from all fwmark 0x3e00/0x3f00 unreachable
32766: from all lookup main
4200000001: from all iif lo failed_policy
4200000005: from all iif br-lan failed_policy
4200000007: from all iif eth0.3 failed_policy
4200000008: from all iif eth0.4 failed_policy
4200000009: from all iif eth0.2 failed_policy
4200000009: from all iif eth0.2 failed_policy
-ash: ls: not found
==> /etc/resolv.conf
search lan
nameserver 127.0.0.1
==> /tmp/resolv.conf
search lan
nameserver 127.0.0.1
==> /tmp/resolv.conf.auto
Interface wan6
nameserver 2405:201:300f:77::c0a8:1d01
Interface wan
nameserver 192.168.29.1
Interface WANB
nameserver 192.168.4.1
Interface WANC
nameserver 218.248.114.1
nameserver 218.248.114.65
head: /tmp/resolv./: No such file or directory
root@OpenWrt:~#
Please use the "Preformatted text </>
" button for logs, scripts, configs and general console output.
Please edit your post accordingly. Thank you!
"kernel": "4.14.209",
"hostname": "OpenWrt",
"system": "MediaTek MT7621 ver:1 eco:3",
"model": "Netgear R6220",
"board_name": "r6220",
"release": {
"distribution": "OpenWrt",
"version": "19.07.5",
"revision": "r11257-5090152ae3",
"target": "ramips/mt7621",
"description": "OpenWrt 19.07.5 r11257-5090152ae3"
}
}
package network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd4e:2271:c462::/48'
config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.0.1'
config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr 'x:x:x:x:x:x'
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option metric '10'
config device 'wan_eth0_2_dev'
option name 'eth0.2'
option macaddr 'x:x:x:x:x:x'
config interface 'wan6'
option ifname 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0 1 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '4 6t'
config switch_vlan
option device 'switch0'
option vlan '3'
option vid '3'
option ports '3 6t'
config switch_vlan
option device 'switch0'
option vlan '4'
option vid '4'
option ports '2 6t'
config interface 'WANB'
option ifname 'eth0.3'
option proto 'dhcp'
option metric '20'
option macaddr 'x:x:x:x:x:x'
config interface 'WANC'
option ifname 'eth0.4'
option proto 'dhcp'
option metric '30'
option macaddr 'x:x:x:x:x:x'
package wireless
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option hwmode '11g'
option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
option htmode 'HT20'
option disabled '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
config wifi-device 'radio1'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option disabled '0'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
package dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option ra_management '1'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
package firewall
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
option network 'wan wan6 WANB WANC'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config include
option path '/etc/firewall.user'
config forwarding
option dest 'lan'
option src 'wan'
# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.
# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
package mwan3
config globals 'globals'
option mmx_mask '0x3F00'
option rtmon_interval '5'
config interface 'wan'
option enabled '1'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'
option family 'ipv4'
option reliability '2'
option count '1'
option timeout '2'
option failure_latency '1000'
option recovery_latency '500'
option failure_loss '20'
option recovery_loss '5'
option interval '5'
option down '3'
option up '8'
config interface 'wan6'
option enabled '0'
list track_ip '2001:4860:4860::8844'
list track_ip '2001:4860:4860::8888'
list track_ip '2620:0:ccd::2'
list track_ip '2620:0:ccc::2'
option family 'ipv6'
option reliability '2'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'
config interface 'wanb'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'
option family 'ipv4'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'
option enabled '1'
option initial_state 'online'
option track_method 'ping'
option size '56'
option max_ttl '60'
option check_quality '0'
option failure_interval '5'
option recovery_interval '5'
option reliability '2'
config interface 'wanb6'
option enabled '0'
list track_ip '2001:4860:4860::8844'
list track_ip '2001:4860:4860::8888'
list track_ip '2620:0:ccd::2'
list track_ip '2620:0:ccc::2'
option family 'ipv6'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'
config member 'wan_m1_w3'
option interface 'wan'
option metric '1'
option weight '3'
config member 'wan_m2_w3'
option interface 'wan'
option metric '2'
option weight '3'
config member 'wanb_m1_w2'
option interface 'wanb'
option metric '1'
option weight '2'
config member 'wanb_m2_w2'
option interface 'wanb'
option metric '2'
option weight '2'
config member 'wan6_m1_w3'
option interface 'wan6'
option metric '1'
option weight '3'
config member 'wan6_m2_w3'
option interface 'wan6'
option metric '2'
option weight '3'
config member 'wanb6_m1_w2'
option interface 'wanb6'
option metric '1'
option weight '2'
config member 'wanb6_m2_w2'
option interface 'wanb6'
option metric '2'
option weight '2'
config policy 'wan_only'
list use_member 'wan_m1_w3'
list use_member 'wan6_m1_w3'
config policy 'wanb_only'
list use_member 'wanb_m1_w2'
list use_member 'wanb6_m1_w2'
config policy 'balanced'
list use_member 'wan_m1_w3'
list use_member 'wanb_m1_w2'
list use_member 'wan6_m1_w3'
list use_member 'wanb6_m1_w2'
config policy 'wan_wanb'
list use_member 'wan_m1_w3'
list use_member 'wanb_m2_w2'
list use_member 'wan6_m1_w3'
list use_member 'wanb6_m2_w2'
config policy 'wanb_wan'
list use_member 'wan_m2_w3'
list use_member 'wanb_m1_w2'
list use_member 'wan6_m2_w3'
list use_member 'wanb6_m1_w2'
config rule 'https'
option sticky '1'
option dest_port '443'
option proto 'tcp'
option use_policy 'balanced'
config rule 'default_rule_v4'
option dest_ip '0.0.0.0/0'
option use_policy 'balanced'
option family 'ipv4'
config rule 'default_rule_v6'
option dest_ip '::/0'
option use_policy 'balanced'
option family 'ipv6'
config interface 'wanc'
option enabled '1'
option initial_state 'online'
option family 'ipv4'
option track_method 'ping'
option reliability '1'
option count '1'
option size '56'
option max_ttl '60'
option check_quality '0'
option timeout '2'
option interval '5'
option failure_interval '5'
option recovery_interval '5'
option down '3'
option up '3'
list track_ip '8.8.4.4'
list track_ip '8.8.8.8'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
inet 192.168.0.1/24 brd 192.168.0.255 scope global br-lan
valid_lft forever preferred_lft forever
7: eth0.3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
inet 192.168.4.9/24 brd 192.168.4.255 scope global eth0.3
valid_lft forever preferred_lft forever
8: eth0.4@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
inet 192.168.1.2/24 brd 192.168.1.255 scope global eth0.4
valid_lft forever preferred_lft forever
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
inet 192.168.29.13/24 brd 192.168.29.255 scope global eth0.2
valid_lft forever preferred_lft forever
default via 192.168.29.1 dev eth0.2 table 1 metric 10
192.168.0.0/24 dev br-lan table 1 proto kernel scope link src 192.168.0.1
192.168.1.0/24 dev eth0.4 table 1 proto static scope link metric 30
192.168.4.0/24 dev eth0.3 table 1 proto static scope link metric 20
192.168.29.0/24 dev eth0.2 table 1 proto static scope link metric 10
default via 192.168.29.1 dev eth0.2 proto static src 192.168.29.13 metric 10
default via 192.168.4.1 dev eth0.3 proto static src 192.168.4.9 metric 20
default via 192.168.1.1 dev eth0.4 proto static src 192.168.1.2 metric 30
192.168.0.0/24 dev br-lan proto kernel scope link src 192.168.0.1
192.168.1.0/24 dev eth0.4 proto static scope link metric 30
192.168.4.0/24 dev eth0.3 proto static scope link metric 20
192.168.29.0/24 dev eth0.2 proto static scope link metric 10
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast 192.168.0.0 dev br-lan table local proto kernel scope link src 192.168.0.1
local 192.168.0.1 dev br-lan table local proto kernel scope host src 192.168.0.1
broadcast 192.168.0.255 dev br-lan table local proto kernel scope link src 192.168.0.1
broadcast 192.168.1.0 dev eth0.4 table local proto kernel scope link src 192.168.1.2
local 192.168.1.2 dev eth0.4 table local proto kernel scope host src 192.168.1.2
broadcast 192.168.1.255 dev eth0.4 table local proto kernel scope link src 192.168.1.2
broadcast 192.168.4.0 dev eth0.3 table local proto kernel scope link src 192.168.4.9
local 192.168.4.9 dev eth0.3 table local proto kernel scope host src 192.168.4.9
broadcast 192.168.4.255 dev eth0.3 table local proto kernel scope link src 192.168.4.9
broadcast 192.168.29.0 dev eth0.2 table local proto kernel scope link src 192.168.29.13
local 192.168.29.13 dev eth0.2 table local proto kernel scope host src 192.168.29.13
broadcast 192.168.29.255 dev eth0.2 table local proto kernel scope link src 192.168.29.13
0: from all lookup local
1001: from all iif eth0.2 lookup 1
2001: from all fwmark 0x100/0x3f00 lookup 1
2061: from all fwmark 0x3d00/0x3f00 blackhole
2062: from all fwmark 0x3e00/0x3f00 unreachable
32766: from all lookup main
32767: from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
inet6 fe80::a02:8eff:fee6:43e8/64 scope link
valid_lft forever preferred_lft forever
5: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fd4e:2271:c462::1/60 scope global noprefixroute
valid_lft forever preferred_lft forever
inet6 fe80::a02:8eff:fee6:43e8/64 scope link
valid_lft forever preferred_lft forever
7: eth0.3@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::a02:8eff:fee6:43e6/64 scope link
valid_lft forever preferred_lft forever
8: eth0.4@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::a02:8eff:fee6:43e7/64 scope link
valid_lft forever preferred_lft forever
9: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 2405:201:300f:77:a02:8eff:fee6:43e9/64 scope global dynamic noprefixroute
valid_lft 3587sec preferred_lft 3587sec
inet6 fe80::a02:8eff:fee6:43e9/64 scope link
valid_lft forever preferred_lft forever
10: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::a02:8eff:fee6:43e8/64 scope link
valid_lft forever preferred_lft forever
11: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
inet6 fe80::a02:8eff:fee6:43ec/64 scope link
valid_lft forever preferred_lft forever
default from 2405:201:300f:77::/64 via fe80::6a14:1ff:fe58:9f8b dev eth0.2 proto static metric 384 pref medium
2405:201:300f:77::/64 dev eth0.2 proto static metric 256 pref medium
fd4e:2271:c462::/64 dev br-lan proto static metric 1024 pref medium
unreachable fd4e:2271:c462::/48 dev lo proto static metric 2147483647 error 4294967148 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev eth0.3 proto kernel metric 256 pref medium
fe80::/64 dev eth0.4 proto kernel metric 256 pref medium
fe80::/64 dev eth0.2 proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev wlan0 proto kernel metric 256 pref medium
fe80::/64 dev wlan1 proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast 2405:201:300f:77:: dev eth0.2 table local proto kernel metric 0 pref medium
local 2405:201:300f:77:a02:8eff:fee6:43e9 dev eth0.2 table local proto kernel metric 0 pref medium
anycast fd4e:2271:c462:: dev br-lan table local proto kernel metric 0 pref medium
local fd4e:2271:c462::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.4 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.2 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.3 table local proto kernel metric 0 pref medium
anycast fe80:: dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan0 table local proto kernel metric 0 pref medium
anycast fe80:: dev wlan1 table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43e6 dev eth0.3 table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43e7 dev eth0.4 table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43e8 dev eth0 table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43e8 dev br-lan table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43e8 dev wlan0 table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43e9 dev eth0.2 table local proto kernel metric 0 pref medium
local fe80::a02:8eff:fee6:43ec dev wlan1 table local proto kernel metric 0 pref medium
ff00::/8 dev eth0 table local metric 256 pref medium
ff00::/8 dev br-lan table local metric 256 pref medium
ff00::/8 dev eth0.3 table local metric 256 pref medium
ff00::/8 dev eth0.4 table local metric 256 pref medium
ff00::/8 dev eth0.2 table local metric 256 pref medium
ff00::/8 dev wlan0 table local metric 256 pref medium
ff00::/8 dev wlan1 table local metric 256 pref medium
0: from all lookup local
2061: from all fwmark 0x3d00/0x3f00 blackhole
2062: from all fwmark 0x3e00/0x3f00 unreachable
32766: from all lookup main
4200000001: from all iif lo failed_policy
4200000005: from all iif br-lan failed_policy
4200000007: from all iif eth0.3 failed_policy
4200000008: from all iif eth0.4 failed_policy
4200000009: from all iif eth0.2 failed_policy
4200000009: from all iif eth0.2 failed_policy
ls: /tmp/resolv.*/*: No such file or directory
lrwxrwxrwx 1 root root 16 Dec 6 07:31 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r-- 1 root root 0 Jan 23 02:04 /tmp/resolv.conf
-rw-r--r-- 1 root root 204 Jan 23 02:04 /tmp/resolv.conf.auto
==> /etc/resolv.conf <==
==> /tmp/resolv.conf <==
==> /tmp/resolv.conf.auto <==
# Interface wan6
nameserver 2405:201:300f:77::c0a8:1d01
# Interface wan
nameserver 192.168.29.1
# Interface WANB
nameserver 192.168.4.1
# Interface WANC
nameserver 218.248.114.1
nameserver 218.248.114.65
head: /tmp/resolv.*/*: No such file or directory
Hello @trendy. I just posted the output as you had asked for.
Thanks.
Linux, and OpenWrt as a derivative of the first, is case sensitive OS. So when you define the interfaces WANB
and WANC
in network, but wanb
and wanc
in mwan3, they are not considered the same interfaces. Run the following to fix it:
sed -i 's/WAN/wan/g' /etc/config/network /etc/config/firewall; service network restart; service firewall restart; service mwan3 restart
Thanks a lot @trendy for your advice. It's working now.
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.