Mwan3 - LTE recovery doesn't work

I am running a PC Engines APU1 board with OpenWrt 21.02.2. My board has three network RJ45 network interfaces, a Qualcomm Atheros QCA9880 802.11nac WiFi interface and a Quectel EC25-E LTE modem which runs as a QMI device.

LAN connections
eth0 & eth2 are assigned to br-lan
wlan0 is its own LAN interface

WAN connections
eth1 is configured as wan device with metric 10, wan6 with metric 20
wwan0 is configured as 4G device with metric 30

So far so good, internet is accessible wired and wireless.
For auto-failover and more monitoring and configuration I installed mwan3 (2.10.13-1) and configured it to failover to LTE when wired WAN fails and go back to wired WAN when it returns. I tested it by pulling the WAN cable. Tested the LTE connection by disabling the interface and enabling it again. This also works good.

Now to the problem:
Once a day, mostly at night the LTE connecting drops, you see tracking score going down and eventually wwan0 goes offline. But it will not recover the logging shows no tracking anymore on the offline interface. When I use the diagnose function in Luci to ping the tracking addresses all of them react within a 20-30 ms, when I give an ifup on the wwan0 interface everything is OK again. I tried flushing conntrack but that doesn't make a difference. The connections stays offline until I restart the connection.
What I don't exactly understand is what happens at night with the connection, it looks lik that it start with the ending of the lease time for DHCP address and then it maybe takes longer before it has an internet connection again. It isn't only the IP's lease time because it gets renewed every 2 hours and during the day that works fine. It could be that it is caused by the ISP forcing my connection to another subnet, that could take longer which would cause mwan3 to detect a loss of connection. However that doesn't explain why it wouldn't automatically recover.
To diagnose it a step further I added the virtual DHCP client interface from the wwan0 interface to the mwan3 configuration. What I saw is that both of them lose the connection around the same time, but the virtual adapter recovers and the interface itself doesn't. Unfortunately only the real interface exists in the firewall so you don't have any connection over it...

What can I do to let mwan3 recover the LTE connection automatically. Is my only option to add an ifup for the wwan0 interface when the connection get lost in the mwan3.user script?
Did a make a configuration error, do I miss something else?

I searched the forum and the worldwide web several times but it doesn't show topics outside the flush conntrack solutions.

/etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3b:3e30:3f67::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.127.1.1'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option metric '10'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option metric '20'

config interface '4G'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option apn 'internet.tele2.nl'
        option pincode '****'
        option metric '30'
        option auth 'none'
        option pdptype 'ipv4'

config interface 'WiFi'
        option proto 'static'
        option ipaddr '10.127.2.1'
        option netmask '255.255.255.0'
        option device 'radio0.network1'

/etc/config/mwan3:

config policy 'wan_only'                    
        list use_member 'wan_m1_w3'         
        list use_member 'wan6_m1_w3'        
                                            
config policy 'wan_4G'                      
        option last_resort 'unreachable'    
        list use_member 'wan_m1_w3'         
        list use_member '4G_m3_w2'          
                                            
config policy 'balanced'                    
        option last_resort 'unreachable'    
        list use_member 'wan_m1_w3'         
        list use_member 'wan6_m1_w3'        
        list use_member '4G_m1_w1'          
                                            
config policy '4G_only'                     
        option last_resort 'unreachable'    
        list use_member '4G_m2_w2'          
                                            
config member 'wan_m1_w3'                   
        option interface 'wan'              
        option metric '1'                   
        option weight '3'                   
                                            
config member 'wan_m2_w3'                   
        option interface 'wan'              
        option metric '2'                   
        option weight '3'                   
                                            
config member '4G_m1_w2'                    
        option interface '4G'               
        option metric '1'                   
        option weight '2'                   
                                            
config member '4G_m2_w2'                    
        option metric '2'                   
        option weight '2'                   
        option interface '4G'               
                                            
config member 'wan6_m1_w3'                  
        option interface 'wan6'             
        option metric '1'                   
        option weight '3'                   
                                            
config member 'wan6_m2_w3'                  
        option interface 'wan6'             
        option metric '2'                   
        option weight '3'                   
                                            
config globals 'globals'                    
        option mmx_mask '0x3F00'            
                                            
config interface 'wan'                      
        option enabled '1'                  
        list track_ip '8.8.4.4'             
        list track_ip '8.8.8.8'     
        list track_ip '208.67.222.222'      
        list track_ip '208.67.220.220'      
        option family 'ipv4'                
        option reliability '2'              
        option initial_state 'online'       
        option track_method 'ping'          
        option count '1'                    
        option size '56'                    
        option max_ttl '60'                 
        option check_quality '0'            
        option timeout '4'                  
        option interval '10'                
        option failure_interval '5'         
        option recovery_interval '5'        
        option down '5'                     
        option up '3'                       
                                            
config interface 'wan6'                     
        option enabled '0'                  
        list track_ip '2001:4860:4860::8844'
        list track_ip '2001:4860:4860::8888'
        list track_ip '2620:0:ccd::2'       
        list track_ip '2620:0:ccc::2'       
        option family 'ipv6'                
        option reliability '2'              
        option initial_state 'online'       
        option track_method 'ping'          
        option count '1'                    
        option size '56'                    
        option max_ttl '60'                 
        option check_quality '0'            
        option timeout '4'                  
        option interval '10'                
        option failure_interval '5'         
        option recovery_interval '5'        
        option down '5'                     
        option up '3'                       
                                            
config rule 'default_rule_v4'               
        option dest_ip '0.0.0.0/0'          
        option family 'ipv4'                
        option proto 'all'                  
        option sticky '0'                   
        option use_policy 'wan_4G'          
                                            
config rule 'default_rule_v6'               
        option dest_ip '::/0'               
        option family 'ipv6'                
        option proto 'all'                  
        option sticky '0'                   
        option use_policy 'wan_only'        
                                            
config interface '4G'                       
        option enabled '1'                  
        option initial_state 'online'       
        option family 'ipv4'                      
        option track_method 'ping'          
        option count '1'                    
        option size '56'                    
        option max_ttl '60'                 
        option check_quality '0'            
        option timeout '4'                  
        option failure_interval '5'         
        option recovery_interval '5'        
        option down '5'                     
        option reliability '2'              
        option up '3'                       
        option interval '10'                
        list track_ip '8.8.8.8'             
        list track_ip '208.67.222.222'      
        list track_ip '208.67.220.220'      
        list track_ip '1.1.1.1'             
        list flush_conntrack 'ifup'         
        list flush_conntrack 'ifdown'       
        list flush_conntrack 'connected'    
        list flush_conntrack 'disconnected' 
                                            
config interface '4G_4'                     
        option enabled '1'                  
        option initial_state 'online'       
        option family 'ipv4'                
        option track_method 'ping'          
        option reliability '2'              
        option count '1'                    
        option size '56'                    
        option max_ttl '60'                 
        option check_quality '0'            
        option timeout '4'                  
        option interval '10'                
        option failure_interval '5'         
        option recovery_interval '5'        
        option down '5'                     
        option up '5'                       
        list track_ip '1.1.1.1'             
        list track_ip '8.8.8.8'             
        list track_ip '208.67.220.220'      
        list flush_conntrack 'ifup'         
        list flush_conntrack 'ifdown'       
        list flush_conntrack 'connected'    
        list flush_conntrack 'disconnected' 
                                            
config member '4G4_m1_w2'                   
        option interface '4G_4'             
        option metric '1'                   
        option weight '2'                   
                                            
config member '4G4_m2_w2'                   
        option interface '4G_4'             
        option metric '2'                   
        option weight '2'    
                                                           
config member '4G4_m3_w2'                   
        option interface '4G_4'             
        option metric '3'                   
        option weight '2'                   
                                            
config member '4G_m3_w2'                    
        option interface '4G'               
        option metric '3'                   
        option weight '2'                   
                                            
config member '4G_m1_w1'                    
        option interface '4G'               
        option metric '1'                   
        option weight '1'                   
                                            
config member '4G4_m1_w1'                   
        option interface '4G_4'             
        option metric '1'                   
        option weight '1'                                                    

Kept monitoring the log file after every time it happened, learned not to do manual diagnostics on the interface because the logfile will get polluted with a missing routing table issue. Then I noticed something which looks like a chicken and an egg problem:
The LTE modem (4G interface) loses connection, probably due to something the ISP is pushing. However the IP part of the network is done by a virtual network interface (4G_4). The address lease is still valid so is isn't renewed until a few hours later, but this isn't possible because the wwan0 interface is already down. The virtual device will go down as well but the hotplug event isn't called because the wwan0 interface is down. Conntrack isn't flushed for the same reason. Giving an ifup on the 4G interface will let it recover in a second.

So I don't think there is any other way to resolve this then let mwan3.user give the 4G interface an ifup when mwan3 gives a "disconnected" on the 4G interface:

if [ "${ACTION}" = "disconnected" ] && [ "${INTERFACE}" = "4G" ] ; then
  (/bin/sleep 1; ifup 4G)
fi

Logfile output:

Tue Apr  5 11:39:09 2022 user.info mwan3track[3002]: Check (ping) failed for target "1.1.1.1" on interface 4G (wwan0). Current score: 8
Tue Apr  5 11:39:09 2022 user.notice mwan3track[3002]: Interface 4G (wwan0) is disconnecting
Tue Apr  5 11:39:19 2022 user.info mwan3track[3002]: Check (ping) failed for target "8.8.8.8" on interface 4G (wwan0). Current score: 7
Tue Apr  5 11:39:23 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.222.222" on interface 4G (wwan0). Current score: 7
Tue Apr  5 11:39:27 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.220.220" on interface 4G (wwan0). Current score: 7
Tue Apr  5 11:39:31 2022 user.info mwan3track[3002]: Check (ping) failed for target "1.1.1.1" on interface 4G (wwan0). Current score: 7
Tue Apr  5 11:39:40 2022 user.info mwan3track[3002]: Check (ping) failed for target "8.8.8.8" on interface 4G (wwan0). Current score: 6
Tue Apr  5 11:39:44 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.222.222" on interface 4G (wwan0). Current score: 6
Tue Apr  5 11:39:48 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.220.220" on interface 4G (wwan0). Current score: 6
Tue Apr  5 11:39:52 2022 user.info mwan3track[3002]: Check (ping) failed for target "1.1.1.1" on interface 4G (wwan0). Current score: 6
Tue Apr  5 11:40:01 2022 user.info mwan3track[3002]: Check (ping) failed for target "8.8.8.8" on interface 4G (wwan0). Current score: 5
Tue Apr  5 11:40:05 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.222.222" on interface 4G (wwan0). Current score: 5
Tue Apr  5 11:40:09 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.220.220" on interface 4G (wwan0). Current score: 5
Tue Apr  5 11:40:13 2022 user.info mwan3track[3002]: Check (ping) failed for target "1.1.1.1" on interface 4G (wwan0). Current score: 5
Tue Apr  5 11:40:22 2022 user.info mwan3track[3002]: Check (ping) failed for target "8.8.8.8" on interface 4G (wwan0). Current score: 4
Tue Apr  5 11:40:26 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.222.222" on interface 4G (wwan0). Current score: 4
Tue Apr  5 11:40:30 2022 user.info mwan3track[3002]: Check (ping) failed for target "208.67.220.220" on interface 4G (wwan0). Current score: 4
Tue Apr  5 11:40:34 2022 user.info mwan3track[3002]: Check (ping) failed for target "1.1.1.1" on interface 4G (wwan0). Current score: 4
Tue Apr  5 11:40:34 2022 user.notice mwan3track[3002]: Interface 4G (wwan0) is offline
Tue Apr  5 11:40:34 2022 user.notice mwan3-hotplug[3798]: Execute disconnected event on interface 4G (wwan0)
Tue Apr  5 11:40:34 2022 user.info mwan3-hotplug[3798]: Connection tracking flushed for interface '4G' on action 'disconnected'
Tue Apr  5 12:16:13 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.29.54.109
Tue Apr  5 12:46:13 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.29.54.109
Tue Apr  5 13:01:13 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.29.54.109
Tue Apr  5 13:08:43 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.29.54.109
Tue Apr  5 13:12:28 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.29.54.109
Tue Apr  5 13:14:20 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.29.54.109
Tue Apr  5 13:15:16 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 0.0.0.0
Tue Apr  5 13:15:44 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 0.0.0.0
Tue Apr  5 13:15:58 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 0.0.0.0
Tue Apr  5 13:16:05 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 0.0.0.0
Tue Apr  5 13:16:09 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 0.0.0.0
Tue Apr  5 13:16:10 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 0.0.0.0
Tue Apr  5 13:16:10 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: lease lost, entering init state
Tue Apr  5 13:16:10 2022 daemon.notice netifd: Interface '4G_4' has lost the connection
Tue Apr  5 13:16:10 2022 daemon.info avahi-daemon[3753]: Withdrawing address record for 10.29.54.110 on wwan0.
Tue Apr  5 13:16:10 2022 daemon.info avahi-daemon[3753]: Leaving mDNS multicast group on interface wwan0.IPv4 with address 10.29.54.110.
Tue Apr  5 13:16:10 2022 daemon.info avahi-daemon[3753]: Interface wwan0.IPv4 no longer relevant for mDNS.
Tue Apr  5 13:16:10 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending discover
Tue Apr  5 13:16:10 2022 user.notice mwan3-hotplug[10510]: mwan3 hotplug on 4G_4 not called because interface disabled
Tue Apr  5 13:16:13 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending discover
Tue Apr  5 13:17:01 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending select for 10.30.45.176
Tue Apr  5 13:17:01 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: lease of 10.30.45.176 obtained, lease time 7200
Tue Apr  5 13:17:01 2022 daemon.info avahi-daemon[3753]: Joining mDNS multicast group on interface wwan0.IPv4 with address 10.30.45.176.
Tue Apr  5 13:17:01 2022 daemon.info avahi-daemon[3753]: New relevant interface wwan0.IPv4 for mDNS.
Tue Apr  5 13:17:01 2022 daemon.info avahi-daemon[3753]: Registering new address record for 10.30.45.176 on wwan0.IPv4.
Tue Apr  5 13:17:01 2022 daemon.notice netifd: Interface '4G_4' is now up
Tue Apr  5 13:17:02 2022 user.notice mwan3-hotplug[10734]: mwan3 hotplug on 4G_4 not called because interface disabled
Tue Apr  5 15:17:02 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.30.45.177
Tue Apr  5 15:17:02 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: lease of 10.30.45.176 obtained, lease time 7200
Tue Apr  5 16:17:02 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending renew to 10.30.45.177
Tue Apr  5 16:17:02 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: lease of 10.30.45.176 obtained, lease time 7200
...
Wed Apr  6 12:02:33 2022 daemon.notice netifd: 4G (3243): Stopping network 4G
Wed Apr  6 12:02:33 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: received SIGTERM
Wed Apr  6 12:02:33 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: unicasting a release of 10.30.45.176 to 10.30.45.177
Wed Apr  6 12:02:33 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: sending release
Wed Apr  6 12:02:33 2022 daemon.notice netifd: 4G_4 (31205): udhcpc: entering released state
Wed Apr  6 12:02:33 2022 daemon.notice netifd: 4G_4 (31205): Command failed: Permission denied
Wed Apr  6 12:02:33 2022 daemon.notice netifd: Interface '4G_4' is now down
Wed Apr  6 12:02:33 2022 daemon.notice netifd: Network alias '' link is down
Wed Apr  6 12:02:33 2022 daemon.notice netifd: Interface '4G_4' has link connectivity loss
Wed Apr  6 12:02:33 2022 daemon.notice netifd: Interface '4G_4' is disabled
Wed Apr  6 12:02:33 2022 daemon.info avahi-daemon[3753]: Withdrawing address record for 10.30.45.176 on wwan0.
Wed Apr  6 12:02:33 2022 daemon.info avahi-daemon[3753]: Leaving mDNS multicast group on interface wwan0.IPv4 with address 10.30.45.176.
Wed Apr  6 12:02:33 2022 daemon.info avahi-daemon[3753]: Interface wwan0.IPv4 no longer relevant for mDNS.
Wed Apr  6 12:02:34 2022 user.notice mwan3-hotplug[3241]: Execute ifdown event on interface 4G (unknown)
Wed Apr  6 12:02:34 2022 user.info mwan3track[3002]: Detect ifdown event on interface 4G (wwan0)
Wed Apr  6 12:02:34 2022 user.notice mwan3track[3002]: Interface 4G (wwan0) is offline
Wed Apr  6 12:02:34 2022 user.info mwan3-hotplug[3241]: Connection tracking flushed for interface '4G' on action 'ifdown'
Wed Apr  6 12:02:34 2022 user.notice mwan3-hotplug[3335]: Execute disconnected event on interface 4G (wwan0)
Wed Apr  6 12:02:34 2022 user.info mwan3-hotplug[3335]: Connection tracking flushed for interface '4G' on action 'disconnected'
Wed Apr  6 12:02:36 2022 daemon.notice netifd: 4G (3243): Command failed: Permission denied
Wed Apr  6 12:02:36 2022 daemon.notice netifd: Interface '4G' is now down
Wed Apr  6 12:02:36 2022 daemon.info avahi-daemon[3753]: Interface wwan0.IPv6 no longer relevant for mDNS.
Wed Apr  6 12:02:36 2022 daemon.info avahi-daemon[3753]: Leaving mDNS multicast group on interface wwan0.IPv6 with address fe80::7015:301c:3152:b7bb.
Wed Apr  6 12:02:36 2022 daemon.notice netifd: Interface '4G' is setting up now
Wed Apr  6 12:02:36 2022 daemon.info avahi-daemon[3753]: Withdrawing address record for fe80::7015:301c:3152:b7bb on wwan0.
Wed Apr  6 12:02:36 2022 daemon.notice netifd: 4G (3721): Waiting for SIM initialization
Wed Apr  6 12:02:36 2022 user.notice mwan3-hotplug[3716]: Execute ifdown event on interface 4G (unknown)
Wed Apr  6 12:02:36 2022 user.info mwan3track[3002]: Detect ifdown event on interface 4G (wwan0)
Wed Apr  6 12:02:36 2022 user.notice mwan3track[3002]: Interface 4G (wwan0) is offline
Wed Apr  6 12:02:36 2022 user.info mwan3-hotplug[3716]: Connection tracking flushed for interface '4G' on action 'ifdown'
Wed Apr  6 12:02:37 2022 user.notice mwan3-hotplug[3834]: Execute disconnected event on interface 4G (wwan0)
Wed Apr  6 12:02:37 2022 daemon.notice netifd: 4G (3721): Device does not support 802.3 mode. Informing driver of raw-ip only for wwan0 ..
Wed Apr  6 12:02:37 2022 user.info mwan3-hotplug[3834]: Connection tracking flushed for interface '4G' on action 'disconnected'
Wed Apr  6 12:02:37 2022 daemon.notice netifd: 4G (3721): Waiting for network registration
Wed Apr  6 12:02:38 2022 daemon.notice netifd: 4G (3721): Starting network 4G
Wed Apr  6 12:02:38 2022 daemon.notice netifd: 4G (3721): Setting up wwan0
Wed Apr  6 12:02:38 2022 daemon.info avahi-daemon[3753]: Joining mDNS multicast group on interface wwan0.IPv6 with address fe80::7015:301c:3152:b7bb.
Wed Apr  6 12:02:38 2022 daemon.info avahi-daemon[3753]: New relevant interface wwan0.IPv6 for mDNS.
Wed Apr  6 12:02:38 2022 daemon.info avahi-daemon[3753]: Registering new address record for fe80::7015:301c:3152:b7bb on wwan0.*.
Wed Apr  6 12:02:38 2022 daemon.notice netifd: Interface '4G' is now up
Wed Apr  6 12:02:38 2022 daemon.notice netifd: Network device 'wwan0' link is up
Wed Apr  6 12:02:38 2022 daemon.notice netifd: Network alias 'wwan0' link is up
Wed Apr  6 12:02:38 2022 daemon.notice netifd: Interface '4G_4' is enabled
Wed Apr  6 12:02:38 2022 daemon.notice netifd: Interface '4G_4' has link connectivity
Wed Apr  6 12:02:38 2022 daemon.notice netifd: Interface '4G_4' is setting up now
Wed Apr  6 12:02:38 2022 daemon.notice netifd: 4G_4 (4258): udhcpc: started, v1.33.2
Wed Apr  6 12:02:38 2022 daemon.notice netifd: 4G_4 (4258): udhcpc: sending discover
Wed Apr  6 12:02:38 2022 daemon.notice netifd: 4G_4 (4258): udhcpc: sending select for 100.107.250.230
Wed Apr  6 12:02:38 2022 daemon.notice netifd: 4G_4 (4258): udhcpc: lease of 100.107.250.230 obtained, lease time 7200
Wed Apr  6 12:02:39 2022 user.notice mwan3-hotplug[4224]: Execute ifup event on interface 4G (wwan0)
Wed Apr  6 12:02:39 2022 daemon.info avahi-daemon[3753]: Joining mDNS multicast group on interface wwan0.IPv4 with address 100.107.250.230.
Wed Apr  6 12:02:39 2022 daemon.info avahi-daemon[3753]: New relevant interface wwan0.IPv4 for mDNS.
Wed Apr  6 12:02:39 2022 daemon.info avahi-daemon[3753]: Registering new address record for 100.107.250.230 on wwan0.IPv4.
Wed Apr  6 12:02:39 2022 daemon.notice netifd: Interface '4G_4' is now up
Wed Apr  6 12:02:39 2022 user.info mwan3track[3002]: Detect ifup event on interface 4G (wwan0)
Wed Apr  6 12:02:39 2022 user.info mwan3-hotplug[4224]: Connection tracking flushed for interface '4G' on action 'ifup'
Wed Apr  6 12:02:39 2022 user.notice mwan3track[3002]: Interface 4G (wwan0) is online
Wed Apr  6 12:02:39 2022 user.notice firewall: Reloading firewall due to ifup of 4G (wwan0)
Wed Apr  6 12:02:39 2022 user.info mwan3track[3002]: Check (ping) success for target "8.8.8.8" on interface 4G (wwan0). Current score: 0
Wed Apr  6 12:02:39 2022 user.info mwan3track[3002]: Check (ping) success for target "208.67.222.222" on interface 4G (wwan0). Current score: 0
Wed Apr  6 12:02:39 2022 user.notice mwan3track[3002]: Interface 4G (wwan0) is connecting
Wed Apr  6 12:02:39 2022 user.notice nlbwmon: Reloading nlbwmon due to ifup of 4G (wwan0)
Wed Apr  6 12:02:40 2022 user.notice mwan3-hotplug[4785]: mwan3 hotplug on 4G_4 not called because interface disabled
Wed Apr  6 12:02:40 2022 user.notice firewall: Reloading firewall due to ifup of 4G_4 (wwan0)
Wed Apr  6 12:02:40 2022 user.notice nlbwmon: Reloading nlbwmon due to ifup of 4G_4 (wwan0)
Wed Apr  6 12:02:45 2022 user.info mwan3track[3002]: Check (ping) success for target "8.8.8.8" on interface 4G (wwan0). Current score: 1
Wed Apr  6 12:02:45 2022 user.info mwan3track[3002]: Check (ping) success for target "208.67.222.222" on interface 4G (wwan0). Current score: 1
Wed Apr  6 12:02:50 2022 user.info mwan3track[3002]: Check (ping) success for target "8.8.8.8" on interface 4G (wwan0). Current score: 2
Wed Apr  6 12:02:50 2022 user.info mwan3track[3002]: Check (ping) success for target "208.67.222.222" on interface 4G (wwan0). Current score: 2
Wed Apr  6 12:02:50 2022 user.notice mwan3track[3002]: Interface 4G (wwan0) is online
Wed Apr  6 12:02:50 2022 user.notice mwan3-hotplug[5109]: Execute connected event on interface 4G (wwan0)
Wed Apr  6 12:02:50 2022 user.info mwan3-hotplug[5109]: Connection tracking flushed for interface '4G' on action 'connected'
Wed Apr  6 12:02:55 2022 user.info mwan3track[3002]: Check (ping) success for target "8.8.8.8" on interface 4G (wwan0). Current score: 3
Wed Apr  6 12:02:55 2022 user.info mwan3track[3002]: Check (ping) success for target "208.67.222.222" on interface 4G (wwan0). Current score: 3

OK, the script in mwan3.user seems to loop indefinitely. Resulting in the web interface being very laggy in the end even unresponsive. Ended up removing my entry over the cli and rebooted the system.

I think I'll wait for 22.03 and start over and test if Failover works better on only the metrics without mwan3.