Mwan3 interfaces always down

Hi,
I have a TP-Link TL-MR3420 v1 with OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530).

I configure two wans (wan and wan2). The two wans work fine, I have internet with each of them.

I install mwan3 1.5-10 and luci-app-mwan3 1.3-5.

The wan iterfaces in MWAN live status are always Offline though it are online and working good.

This is the /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb2:3b21:5553::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option _orig_ifname 'eth0 radio0.network1'
	option _orig_bridge 'true'
	option ipaddr '192.168.2.1'
	option dns '8.8.8.8 8.8.4.4'
	option gateway '192.168.2.1'
	option ifname 'eth0.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 1 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t 3'

config interface 'wan'
	option ifname 'eth0.2'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr '192.168.1.86'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option metric '10'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t 2'

config interface 'wan2'
	option ifname 'eth0.3'
	option _orig_ifname 'eth0.3'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr '192.168.0.5'
	option netmask '255.255.255.0'
	option metric '20'
	option gateway '192.168.0.1'

and this is the /etc/config/mwan3

config interface 'wan'
	option enabled '1'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	list track_ip '208.67.222.222'
	list track_ip '208.67.220.220'
	option count '1'
	option timeout '2'
	option interval '5'
	option down '3'
	option up '8'
	option reliability '2'

config interface 'wan2'
	option count '1'
	option timeout '2'
	option interval '5'
	option down '3'
	option up '8'
	option enabled '1'
	list track_ip '10.29.184.169'
	list track_ip '10.14.224.113'
	option reliability '1'

config member 'wan_m1_w3'
	option interface 'wan'
	option metric '1'
	option weight '3'

config member 'wan_m2_w3'
	option interface 'wan'
	option metric '2'
	option weight '3'

config member 'wan2_m1_w2'
	option interface 'wan2'
	option metric '1'
	option weight '2'

config member 'wan2_m2_w2'
	option interface 'wan2'
	option metric '2'
	option weight '2'

config policy 'wan_only'
	list use_member 'wan_m1_w3'

config policy 'wan2_only'
	list use_member 'wan2_m1_w2'

config policy 'balanced'
	list use_member 'wan_m1_w3'
	list use_member 'wan2_m1_w2'

config policy 'wan_wan2'
	list use_member 'wan_m1_w3'
	list use_member 'wan2_m2_w2'

config policy 'wan2_wan'
	list use_member 'wan_m2_w3'
	list use_member 'wan2_m1_w2'

config rule 'default_rule'
	option dest_ip '0.0.0.0/0'
	option use_policy 'balanced'
	option proto 'all'

Can you help me to understand why mwan not recognize the interface status.

The MQAN Interface Systemlog show me this errors:

Last 50 MWAN systemlog entries. Newest entries sorted at the top :

Tue May 21 06:34:10 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Tue May 21 06:33:59 2019 user.notice mwan3: ifdown interface wan2 (unknown)
Tue May 21 06:33:29 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Tue May 21 00:01:03 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Tue May 21 00:00:52 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 23:39:53 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 23:39:41 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 23:39:13 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 23:39:01 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 23:38:32 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 23:38:21 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 22:41:26 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 22:41:14 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 22:40:44 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 22:40:32 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 22:20:01 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 22:19:49 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 22:08:30 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 22:08:19 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 22:06:17 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 22:06:03 2019 user.notice mwan3: ifdown interface wan2 (unknown)
Mon May 20 22:03:44 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 22:03:32 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 22:00:56 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 21:59:03 2019 user.warn mwan3: Could not find gateway for interface wan2 (eth0.3)
Mon May 20 21:58:51 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 21:56:12 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)
Mon May 20 21:53:44 2019 user.warn mwan3: Could not find gateway for interface wan (eth0.2)

And if I go to diagnostic I can ping default gateway and tracking IP but Check Ip rules returns

Missing both of the required interface IP rules

and Check routing table returns

Missing required interface routing table 1

Please help me.

Thanks

Try remove gateway on lan interface

config interface 'lan'
	option gateway '192.168.2.1'

I do it

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option _orig_ifname 'eth0 radio0.network1'
	option _orig_bridge 'true'
	option ipaddr '192.168.2.1'
	option ifname 'eth0.1'

but interface still offline....

Does you reboot router ? Why don't you upgrade it to Openwrt 15.05 ? BB 14.07 is no longer supported.

Ok yes I will try to update OpenWrt, I find on official page the 17.01.5 version for my router.
I try and then tell you.

Thanks

I think 17.01 is not recommend for 4MB flash 32MB ram router, it not enough space for install mwan.
See this warning: https://openwrt.org/supported_devices/432_warning

So what do you advise to do?

Try with 15.05 or change another router with more ram/flash.

Ok I will try 15.05 but where I can find the upgrade firmware for my router. In this page https://openwrt.org/toh/tp-link/tl-mr3420 I find just the 17.01.5...

http://archive.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/

here: http://archive.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/

Ok thanks.
I will flash and start all again.
Please can you indicate me a good tutorial to setup a multiwan with 2 wan.

Pls see official guide here: https://openwrt.org/docs/guide-user/network/wan/multiwan/mwan3
If you have any other problems, just ask questions.

Ok thanks.
I will try with 15.05 and official guide. I hope it works.
So in case I have problems with this router do you think this one (https://it.aliexpress.com/item/Cioswi-Senza-Fili-WiFi-Router-300-Mbps-802-11b-g-n-MT7620N-Chipset-Usb-wifi-ripetitore/32933932628.html) can be a good one?

This router has many versions, i'm not sure it is bad or good.
See device page: https://openwrt.org/toh/zbt/wr8305rt
I suggest you use this site to find the right router for you: https://openwrt.org/toh/views/toh_available_864

The one I post is 8/32. Do you think is good memory and flash or I must choose 16/32?

Recommend > 8/64 for future use.

Ok so I will search for a better one.

In the mwan3 official guide I read

IMPORTANT: :!: Before doing anything with mwan3 (installing or configuring), ensure that each WAN interface is working and that the default routing table is correctly configured for each WAN connection. Test each interface with a manual ping before installing mwan3! There have been multiple reports of mwan3 problems on the forum when the problem is actually at the OS level and visible before mwan3 is even installed.

What means default routing table? And how can I check if is correctly configured?

In that guide, Verify the routing table example:

root@OpenWrt:~# ip route show
default via 10.0.3.2 dev eth1  proto static  src 10.0.3.15  metric 10 
default via 10.0.4.2 dev eth2  proto static  src 10.0.4.15  metric 20

Verify outbound traffic on each WAN interface, example:
root@openwrt:~# ping -c 1 -I eth0.1 www.google.com

Ok I not have yet upgrade to 15.05 because I'm not phisically near the router (i'm connect remote to it) but on actual firmware (BB) if I run ip route show nothing is show.
Can be this the problem of interface always down?