MWAN3 failover not working, LUCI and CLI showing different things

I got a prioritized pool set up with mwan3 via luci. If i play around with metric, I see it properly use the interface with lowest metric. The issue comes when failover is supposed to happen. After I rebooted my modem, if I keep hitting refresh on the status page in LUCI, I see that eventually the interface for my modem is "disabled" in a yellow box and not green. But if I go to the "detail" page or run "mwan3 status" in cli. It never shows that the interface is disabled. It just continues to show that interface is active. I'm guessing as a result, never falls back to the secondary interface I have.

This is what it shows (ignore wan), the only two members in the pool are xfiwg and altwan. Altwan is my primary and it should be down and failover to xfiwg. This is when altwan SHOULD be down and I'd expected the 100% would be assigned to xfiwg.

Interface status:
 interface wan is disabled and tracking is down
 interface xfiwg is online 00h:06m:40s, uptime 00h:12m:52s and tracking is active
 interface altwan is online 00h:06m:41s, uptime 00h:12m:49s and tracking is active

Current ipv4 policies:
load_balanced:
 altwan (100%)

Current ipv6 policies:
load_balanced:
 unreachable

Directly connected ipv4 networks:
224.0.0.0/3
192.168.10.0/24
10.253.3.0/24
192.168.6.0/24
24.16.152.0/21
127.0.0.0/8
192.168.3.0/24

Directly connected ipv6 networks:
fde3:da1e:f280::/64
2601:603:f7f:aedf::/64
fe80::/64

Here is my config (again, ignore WAN):

config globals 'globals'
	option mmx_mask '0x3F00'

config interface 'wan'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	list track_ip '208.67.222.222'
	list track_ip '208.67.220.220'
	option family 'ipv4'
	option reliability '2'
	option enabled '0'
	option initial_state 'online'
	option track_method 'ping'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '4'
	option interval '10'
	option failure_interval '5'
	option recovery_interval '5'
	option down '5'
	option up '5'

config rule 'https'
	option sticky '1'
	option dest_port '443'
	option proto 'tcp'
	option use_policy 'load_balanced'

config rule 'default_rule_v4'
	option dest_ip '0.0.0.0/0'
	option family 'ipv4'
	option proto 'all'
	option sticky '0'
	option use_policy 'load_balanced'

config rule 'default_rule_v6'
	option dest_ip '::/0'
	option family 'ipv6'
	option proto 'all'
	option sticky '0'
	option use_policy 'load_balanced'

config interface 'xfiwg'
	option initial_state 'online'
	option family 'ipv4'
	option track_method 'ping'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '4'
	option interval '10'
	option failure_interval '5'
	option recovery_interval '5'
	option down '5'
	option up '5'
	option enabled '1'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	list track_ip '208.67.222.222'
	list track_ip '208.67.220.220'
	option reliability '1'

config interface 'altwan'
	option initial_state 'online'
	option family 'ipv4'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	list track_ip '208.67.222.222'
	list track_ip '208.67.220.220'
	option track_method 'ping'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '4'
	option interval '10'
	option failure_interval '5'
	option recovery_interval '5'
	option down '5'
	option up '5'
	option enabled '1'
	option reliability '1'
	list flush_conntrack 'ifup'
	list flush_conntrack 'ifdown'
	list flush_conntrack 'connected'
	list flush_conntrack 'disconnected'

config member 'altwan_member'
	option interface 'altwan'
	option weight '1'
	option metric '1'

config member 'wan_member'
	option interface 'wan'
	option metric '1'
	option weight '1'

config member 'xfiwg_member'
	option interface 'xfiwg'
	option weight '1'
	option metric '5'

config policy 'load_balanced'
	option last_resort 'unreachable'
	list use_member 'altwan_member'
	list use_member 'xfiwg_member'