Mwan3 can't add second member

So I have Mwan3 setup but I can't load balance, when ever I add a second member to a policy it does not show it in the detail panel under status. Each of my load balancing rules just have the first adapter in the member list set to 100%

image

Edit: To clarify failover kind of works, it works for ping, but not for websites, and yes i know about the sticky timeout, if I do a failover test and go to one site, cut the line and then go to a completly random website, it will not load, but if I ping everything works. I have attached the tracert screen below to show the fail over.

Here are the members

Also my rules, incase it is needed.

Tracert Fail over.

(You can edit your posts so that you don’t run into the new-user or three-consecutive limits)

(Yeah, but as a new member i can only post one image per post...)

2 Likes

Use preformatted text </> and paste here the output of /etc/config/mwan3 and mwan3 status rather than uploading photos.

2 Likes

Here you go.

root@OpenWrt:~# cat /etc/config/mwan3

config rule 'https'
        option sticky '1'
        option proto 'tcp'
        option dest_port '443'
        option use_policy 'LoadBalT0'

config rule 'default_rule'
        option proto 'all'
        option sticky '0'
        option use_policy 'LoadBalT0'

config policy 'LoadBalT0'
        option last_resort 'unreachable'
        list use_member 'wan_p0'
        list use_member 'wan_p1'

config policy 'Wan1_only'
        list use_member 'wan_p0'
        option last_resort 'unreachable'

config policy 'Wan2_only'
        list use_member 'wan_p1'
        option last_resort 'unreachable'

config policy 'LoadBalT1'
        option last_resort 'unreachable'
        list use_member 'wan_p1'
        list use_member 'wan_p0'

config globals 'globals'
        option mmx_mask '0x3F00'
        option local_source 'lan'

config interface 'WAN2'
        option enabled '1'
        option initial_state 'online'
        option family 'ipv4'
        option track_method 'ping'
        option count '1'
        option size '56'
        option check_quality '0'
        option timeout '2'
        option interval '5'
        option failure_interval '5'
        option recovery_interval '5'
        option down '3'
        option flush_conntrack 'never'
        option up '8'
        list track_ip '8.8.8.8'
        list track_ip '8.8.4.4'
        option reliability '2'

config member 'wan_p0'
        option metric '10'
        option interface 'wan'
        option weight '1'

config member 'wan_p1'
        option interface 'WAN2'
        option metric '20'
        option weight '2'

config interface 'wan'
        option enabled '1'
        option initial_state 'online'
        option family 'ipv4'
        option track_method 'ping'
        option count '1'
        option size '56'
        option check_quality '0'
        option timeout '2'
        option interval '5'
        option failure_interval '5'
        option recovery_interval '5'
        option down '3'
        option up '8'
        option flush_conntrack 'never'
        list track_ip '8.8.8.8'
        list track_ip '8.8.4.4'
        option reliability '2'

config member 'wan_buckeye'
        option interface 'wan'
        option metric '10'
        option weight '1'

config member 'wan_att'
        option interface 'WAN2'
        option metric '20'
        option weight '2'

config policy 'LoadBal_BA'
        list use_member 'wan_buckeye'
        list use_member 'wan_att'
        option last_resort 'unreachable'



Interface status:
 interface WAN2 is online and tracking is active
 interface wan is online and tracking is active

Current ipv4 policies:
LoadBalT0:
 wan (100%)

LoadBalT1:
 wan (100%)

LoadBal_BA:
 wan (100%)

Wan1_only:
 wan (100%)

Wan2_only:
 WAN2 (100%)


Current ipv6 policies:
LoadBalT0:
 unreachable

LoadBalT1:
 unreachable

LoadBal_BA:
 unreachable

Wan1_only:
 unreachable

Wan2_only:
 unreachable


Directly connected ipv4 networks:
##hidden##

Directly connected ipv6 networks:
##hidden##

Active ipv4 user rules:
   32  1760 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443
   59  6281 - LoadBalT0  all  --  *      *       0.0.0.0/0            0.0.0.0/0 

Active ipv6 user rules:
    0     0 S https  tcp      *      *       ::/0                 ::/0                 multiport sports 0:65535 multiport dports 443
    5   474 - LoadBalT0  all      *      *       ::/0                 ::/0

First of all fix the post above and use preformatted text </>
Second add the output of ip route show also in preformatted text.

1 Like
root@OpenWrt:~# ip route show
default via 192.168.0.1 dev lo
default via 72.x.x.1 dev eth1.2 proto static src 72.x.x.110 metric 10
default via 107.x.124.1 dev eth1.3 proto static src 107.x.x.205 metric 20
72.x.x.0/21 dev eth1.2 proto static scope link metric 10
107.x.x.0/22 dev eth1.3 proto static scope link metric 20
192.168.0.0/24 dev br-lan proto kernel scope link src 192.168.0.1

Sorry, I could no longer edit the post so here is the edit plus what you requested (Above)

root@OpenWrt:~# cat /etc/config/mwan3

config rule 'https'
        option sticky '1'
        option proto 'tcp'
        option dest_port '443'
        option use_policy 'LoadBalT0'

config rule 'default_rule'
        option proto 'all'
        option sticky '0'
        option use_policy 'LoadBalT0'

config policy 'LoadBalT0'
        option last_resort 'unreachable'
        list use_member 'wan_p0'
        list use_member 'wan_p1'

config policy 'Wan1_only'
        list use_member 'wan_p0'
        option last_resort 'unreachable'

config policy 'Wan2_only'
        list use_member 'wan_p1'
        option last_resort 'unreachable'

config policy 'LoadBalT1'
        option last_resort 'unreachable'
        list use_member 'wan_p1'
        list use_member 'wan_p0'

config globals 'globals'
        option mmx_mask '0x3F00'
        option local_source 'lan'

config interface 'WAN2'
        option enabled '1'
        option initial_state 'online'
        option family 'ipv4'
        option track_method 'ping'
        option count '1'
        option size '56'
        option check_quality '0'
        option timeout '2'
        option interval '5'
        option failure_interval '5'
        option recovery_interval '5'
        option down '3'
        option flush_conntrack 'never'
        option up '8'
        list track_ip '8.8.8.8'
        list track_ip '8.8.4.4'
        option reliability '2'

config member 'wan_p0'
        option metric '10'
        option interface 'wan'
        option weight '1'

config member 'wan_p1'
        option interface 'WAN2'
        option metric '20'
        option weight '2'

config interface 'wan'
        option enabled '1'
        option initial_state 'online'
        option family 'ipv4'
        option track_method 'ping'
        option count '1'
        option size '56'
        option check_quality '0'
        option timeout '2'
        option interval '5'
        option failure_interval '5'
        option recovery_interval '5'
        option down '3'
        option up '8'
        option flush_conntrack 'never'
        list track_ip '8.8.8.8'
        list track_ip '8.8.4.4'
        option reliability '2'

config member 'wan_buckeye'
        option interface 'wan'
        option metric '10'
        option weight '1'

config member 'wan_att'
        option interface 'WAN2'
        option metric '20'
        option weight '2'

config policy 'LoadBal_BA'
        list use_member 'wan_buckeye'
        list use_member 'wan_att'
        option last_resort 'unreachable'


AND

root@OpenWrt:~# mwan3 status
Interface status:
 interface WAN2 is online and tracking is active
 interface wan is online and tracking is active

Current ipv4 policies:
LoadBalT0:
 wan (100%)

LoadBalT1:
 wan (100%)

LoadBal_BA:
 wan (100%)

Wan1_only:
 wan (100%)

Wan2_only:
 WAN2 (100%)


Current ipv6 policies:
LoadBalT0:
 unreachable

LoadBalT1:
 unreachable

LoadBal_BA:
 unreachable

Wan1_only:
 unreachable

Wan2_only:
 unreachable


Directly connected ipv4 networks:
 107.195.124.0
 72.x.x.255
 192.168.0.0
 72.x.x.110
 192.168.0.0/24
 192.168.0.1
 107.x.x.0/22
 72.x.x.0
 127.x.x.255
 72.x.x.0/21
 192.168.0.255
 107.x.x.205
 224.0.0.0/3
 107.x.x.255
 127.0.0.0
 127.0.0.0/8
 127.0.0.1

Directly connected ipv6 networks:
##hidden##

Active ipv4 user rules:
   31  1761 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443
  121  8142 - LoadBalT0  all  --  *      *       0.0.0.0/0            0.0.0.0/0 

Active ipv6 user rules:
    0     0 S https  tcp      *      *       ::/0                 ::/0                 multiport sports 0:65535 multiport dports 443
    5   716 - LoadBalT0  all      *      *       ::/0                 ::/0      


wan_p0 and wan_p1 have different metric so they can't be used for load balancing. Use the names and values from the wiki page in order to get the desired results.

thank you, I will need to modify my rules, but I updated my testing load balancing policy Loadbal_BA and it is now showing 50/50. That should be enough to get me started.

Just remember that equal metric is for load balancing, otherwise lower metric gets priority in a failover scenario.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.