Mwan3 2nd wan not working

I followed a tutorial on youtube trying to install 2 wan at my linksys wrt 1900AC the configuration went smooth. and i added the 2nd wan and it has an ip as dhpc from another isp ,
the problem if the main wan go down and 2nd is up i have no traffic it seems like 2nd wan doesn't work.
actually i don't need balance i just need if first network go down i want the 2nd network replace it .
note am very new using openwrt
please anyone can help
thanks

Maybe the config file help
root@OpenWrt:~# cat /etc/config/mwan3

config member 'wanb_m1_w3'
	option interface 'wanb'
	option metric '1'
	option weight '3'

config member 'wan_m1_w3'
	option interface 'wan'
	option metric '1'
	option weight '2'

config member 'wan6_m1_w3'
	option interface 'wan6'
	option metric '1'
	option weight '1'

config policy 'balanced'
	list use_member 'wanb_m1_w3'
	list use_member 'wan_m1_w3'
	list use_member 'wan6_m1_w3'
	option last_resort 'unreachable'

config globals 'globals'
	option mmx_mask '0x3F00'

config interface 'wan'
	option enabled '1'
	option family 'ipv4'
	option reliability '2'
	option initial_state 'online'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	option track_method 'ping'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '4'
	option interval '10'
	option failure_interval '5'
	option recovery_interval '5'
	option down '5'
	option up '5'

config interface 'wan6'
	option family 'ipv6'
	option reliability '2'
	option enabled '1'
	option initial_state 'online'
	option track_method 'ping'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '4'
	option interval '10'
	option failure_interval '5'
	option recovery_interval '5'
	option down '5'
	option up '5'
	list track_ip '2001:4860:4860::8844'
	list track_ip '2001:4860:4860::8888'

config interface 'wanb'
	option family 'ipv4'
	option reliability '1'
	option enabled '1'
	option initial_state 'online'
	list track_ip '8.8.4.4'
	list track_ip '8.8.8.8'
	option track_method 'ping'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '4'
	option interval '10'
	option failure_interval '5'
	option recovery_interval '5'
	option down '5'
	option up '5'

config interface 'wanb6'
	option family 'ipv6'
	option reliability '1'
	option enabled '1'
	option initial_state 'online'
	option track_method 'ping'
	option count '1'
	option size '56'
	option max_ttl '60'
	option check_quality '0'
	option timeout '4'
	option interval '10'
	option failure_interval '5'
	option recovery_interval '5'
	option down '5'
	option up '5'
	list track_ip '2001:4860:4860::8844'
	list track_ip '2001:4860:4860::8888'

config rule 'https'
	option sticky '1'
	option dest_port '443'
	option proto 'tcp'
	option use_policy 'balanced'

config rule 'default_rule_v4'
	option dest_ip '0.0.0.0/0'
	option use_policy 'balanced'
	option family 'ipv4'

config rule 'default_rule_v6'
	option dest_ip '::/0'
	option use_policy 'balanced'
	option family 'ipv6'

I would follow a fail over configuration in https://openwrt.org/docs/guide-user/network/wan/multiwan/mwan3.
Your mwan3 config file is missing the wan / wanb only configuration for that purpose.

1 Like

I suggest you remove wan6, since it is not working anyway, as well as the rule for v6.

1 Like

thanks everyone , but it worked after i upgraded LuCi version
thanks

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.