MultiWAN (mwan3) Install Breaks 6in4 (IPv6 stops working)

I have verified with 18.06 on a Netgear R7800 that installing mwan3 (never installed before, so clean config) breaks 6in4 (not even the router itself can ping an IPv6 only address). Removing mwan3 restores 6in4 to working state (router and clients have IPv6 connectivity)

I understand a tunnel update must occur if I have two working WANs in a configured mwan environment.

I don't plan on making the 2nd WAN available to the router 100% of the time, but I need IPv6 100% of the time.

How could I make an untouched mwan config with only one WAN plugged in not disturb 6in4? At least, how could I put mwan3 in a configured but inactive state so that it doesn't break 6in4?

I went back to 17.01.5 because I could never make everything I wanted work properly with mwan3 in 18 (IPv6 and VPN). In your case I think it will be fixed if you download and replace this file on the router (/lib/mwan3/

It's this commit that fixes it:

In addition you may have to do some configuring. I think I got IPv6 working by adding and enabling an IPv6 device, and disabling the ping testing, or maybe I just disabled the device. I'm not sure because I tried lots of variations.

Ouch, it looks like mwan3 + IPv6 is really broken:✓&q=is%3Aissue+mwan3+ipv6+is%3Aopen

I'm going to wait. I can't afford downtime (really). If a fix doesn't come along I will revert to 17.01.5. The reason my IPv6 didn't work in that version was mwan3, but I only realized it after I moved to 18.

1 Like

I don't have IPv6 on my failover connection so I don't know if that works with 18.06.0 and the file I linked. In 17.01.5 I can make it work by editing the same file and setting the variable IPT6="/bin/true" instead of what it is originally. I suspect that the IPv6 bugs in that list are fixed in the newest version.

If IPv6 is via HE, do I even need mwan3 to be enabled for IPv6? Wouldn't the 6in4 packets travel thru the currently available WAN IPv4 interface any way?

I'm apparently having the same problem, question is how to disable mwan3 ip6tables rules which it is still adding even if all defined interfaces are set to ipv4 ( family key) and all rules are IPV4 only. Still a catch all rule (::/0) gets added to ip6tables and mwan3 status reports

Active ipv6 user rules:
    4   384 - wan_lte_backup  all      *      *       ::/0                 ::/0

Nowhere in the whole mwan3 config is a single reference to ::/0, only

But my precious IPv6 packets get marked and then dropped cause neither of the two failover interfaces have IPv6 connectivity (hence the tunnel)

Is there some way to fix this via configuration rather than having to wait for an update?
TBH the voodoo that happens after marking the packets is not well understood