MultiWAN Manager interaction with passwall

Hi.
I'm using MultiWAN and Passwall on my OpenWrt. I set up the passwall and it works perfectly. Also, I set up MultiWAN. both of them work well separately but when I enabled them at the same time, I noticed that traffic didn't go through MultiWAN and it missed rules! I set a source IP address to my MultiWAN rule (for example my phone IP address) and I think that is the problem.
What should I do to work well?

ubus call system board

Thanks. What does it do?

It shows us the device information so that we can understand what system is running.

Please run the command and then paste the output here.

{
"kernel": "5.10.176",
"hostname": "Aliv",
"system": "Feroceon 88FR131 rev 1 (v5l)",
"model": "Linksys EA4500 (Viper)",
"board_name": "linksys,ea4500",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "22.03.4",
"revision": "r20123-38ccc47687",
"target": "kirkwood/generic",
"description": "OpenWrt 22.03.4 r20123-38ccc47687"
}
}

This version is EOL and unsupported. You should upgrade to 23.05.

https://firmware-selector.openwrt.org/?version=23.05.3&target=kirkwood%2Fgeneric&id=linksys_ea4500

Thanks. actually, my router is Linksys E4200 v2, and when I installed OpenWRT the first time. I saw a model that was Linksys EA4500 (Viper) in the Luci interface. now I should install the EA4500 sysupgrade file or the E4200 sysupgrade file?
when I upload the E4200 sysupgrade file it shows an error message and needs force to install but when I upload EA4500 I don't see any error message.
what should I do?
EA4500 sysupgrade:


E4200 sysupgrade:

It seems your device is currently running an EA4500 build and it seems to be working, so I'd say upgrade to using that.

According to the device page in the table of hardware, the two version are identical in their hardware, so it shouldn't matter, in theory... but stick with the EA4500 build for now.
https://openwrt.org/toh/linksys/ea4500

Meanwhile, I'd recommend not keeping settings during the upgrade (make a backup first, though). Then, setup your general configuration, add mwan3 and test. If all goes well there, add passwall. Since passwall isn't actually part of the OpenWrt repo, you'll need to reach out to the maintainers of that package if there are odd interactions with mwan3.

I tried some scenarios with the current version of OpenWRT. the mistake was when I specified the source IP address to MultiWAN Manager - Rules.
but I should use IP address to declare how and when using internet providers.
Can you help me to assign IP address correctly?

Also, I upgraded my openwrt version and installed MultiWAN (didn't give any source IP), and it worked well then installed Passwall also it worked. when I assigned source IP to rule, it didn't work.
I have a WAN connection and also a hotspot connection from another phone. I'd like to use two internet connections on a specific IP and make rule for others to use only one internet. now I don't know how to set up MultiWAN-rule to reach my goal.

I don’t use those packages, so I can’t help you with any specifics there. Sorry.

Hopefully someone else will see this who uses both packages together.