Multiple WAN interfaces, only 1 of them receive prefix delegation

I have 3 Internet connections from the same ISP. I do not know why I only receive IPv6-PD from only 1 of them. It is random: sometimes it is wan1_6, sometimes wan2_ipv6, sometimes wan3_6 -- but only 1 at a time.


(I do not care about revealing the IP addresses, they are all dynamic and will be changed on next boot)

The configurations are nothing out of ordinary:

config interface 'wan1'
        option device 'lan4'
        option proto 'pppoe'
        option username '<pppoe_account>'
        option password '<pppoe_password>'
        option ipv6 'auto'
        option metric '100'

config device
        option name 'lan3'
        option macaddr '20:76:93:6d:9d:3b'

config interface 'wan2'
        option device 'lan3'
        option proto 'pppoe'
        option username '<pppoe_account>'
        option password '<pppoe_password>'
        option ipv6 '0'
        option metric '200'

config interface 'wan2_ipv6'
        option device '@wan2'
        option proto 'dhcpv6'

config device
        option name 'lan2'
        option macaddr '20:76:93:49:a5:03'

config interface 'wan3'
        option device 'lan2'
        option proto 'pppoe'
        option username '<pppoe_account>'
        option password '<pppoe_password>'
        option ipv6 'auto'
        option metric '300'

What could be the cause of the issue?