Multiple SSID wireless bridge

Hi all,

I am trying to get my openWRT router working as a wireless bridge. I've got it working for one SSID but would like to add another one. I tried doing so but then I lose connection and the ipadress in wwan doesn't show.

My setup:
Main router: Zyxel T56 (provided by internet comp) without openwrt.
Wireless AP: Cudy WR3000 with openwrt

I've used relayd to configure the wireless bridge for one SSID on one radio.

Question 1:
Should I repeat the very same process for the other radio/antenna? Ie create a new relay bridge and lan?

Question 2:
Should I repeat the same process for a second SSID? Or is the relay bridge like a path all SSID can use?

Kind regards,
Mcv

wouldn't connecting two SSIDs create a loop ?

2 Likes

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp

No and yes

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.150",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Cudy WR3000 v1",
        "board_name": "cudy,wr3000-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "mediatek/filogic",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd9:11fc:4283::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.68.1'
        list dns '8.8.8.8'

config interface 'wwan'
        option proto 'dhcp'

config interface 'Relay_bridge'
        option proto 'relay'
        list network 'lan'
        list network 'wwan'
config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/18000000.wifi'
        option channel '6'
        option band '2g'
        option htmode 'HE20'
        option cell_density '0'
        option country 'NL'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'
        option disabled '1'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'wifi 1'
        option encryption 'psk2'
        option key 'password 1'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Wifi 1'
        option encryption 'psk2'
        option key 'password 1'
        option disabled '1'

config wifi-iface 'wifinet3'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Wifi 2'
        option encryption 'sae'
        option key 'password 2'
        option disabled '1'

config wifi-iface 'wifinet4'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'Wifi 2'
        option encryption 'sae'
        option key 'password 2'
        option disabled '1'
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

With only one SSID I am able to get it working.

Adding another one is disconnecting me from the Wi-Fi and I need to use a LAN-cable to enter the router at its factory 192.168.1.1.

No.
If you have more then one radio you can connect to multiple ssid. Be it 3 times the same or 3 different. It does not matter. You may encounter layer-3 conflicts if two different AP are using the same subnet[1]. But if you connect 2 times to the same said it "works"...

@MeanCorpuscularVol I assume you are trying to connect to multiple ssid by using a single radio and this will not work because of hardware and firmware restrictions. You need one radio for each client connection.

Edit: [1] same layer-3 addresses but two different layer-2 of course

I will try this when I am at home.

BTW, the reason I am doing this is mainly to give a neighbour access to internet. As I am typing this it might even be better to create a 'guest SSID' in the second router, instead of in the main router. Would this have any benefit?

Kind regards,
Mcv

Ok, we start from here.
Basics or luci guide from:
https://openwrt.org/docs/guide-user/network/wifi/guestwifi/start

you make a guest bridge without ports, then add access points, exactly same parameters on all radios, and you can even re-assign lan port if they want to drill & run cable.

I will definitely put this to work when I am able to. Thank you.