Multiple Public IPS on 21.02

I was trying to follow this guide

then LUCI advises it wants to redo it... ok, but I cant get it to work... sorry for raw config... luci snips it wont let me post (new users only 1 media item)

My primary WAN (zone wanuplink)

config interface 'wan'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'xx'
        option password 'xx'
        option ipv6 '0'
        option device 'eth1'

Pulls ip xx.xx.xx.97

Then I added this WAN (zone wlan102)

config interface 'Wan102'
        option proto 'static'
        option device 'eth1'
        option ipaddr 'xx.xx.xx.102'
        option netmask '255.255.255.255'
        option gateway 'xx.xx.xx.97'

And a VLAN to push into (zone vlan)

config interface 'Vlan2'
        option proto 'static'
        option device 'eth0.2'
        list ipaddr '10.2.0.1/24'

These are the two rules created by the guide

config redirect
        option name 'dnat3'
        option src 'WAN102'
        option src_dip 'xx.xx.xx.102'
        option dest 'VLAN2'
        option dest_ip '10.2.0.2'
        option proto 'all'
        option target 'DNAT'

config nat
        option name 'snat3'
        option src_ip '10.2.0.2'
        option snat_ip 'xx.xx.xx.102'
        option src 'WAN102'
        option proto 'all'
        option target 'SNAT'

And the current state is that via OpenWRT console
I can SSH to 10.2.0.2
I can from the machine Ping -I 10.2.0.2 8.8.8.8
I can not SSH to xx.xx.xx.102

This bit i find most confusing and have tried many permutations

Advise on the error of my config is appreciated.

The plain text configuration is actually easier to work with than screenshots (not to mention searchability when someone bumps into a problem like yours later on).

Am I understanding correctly that you're trying to force two IP addresses onto one physical interface? Because that won't work. You can have multiple IP addresses just fine but you'll need to use a virtual interface for all other addresses. So something like eth1.1 or something.

The /29 IP all arrive as inbound traffic on WANUplink

I am trying to direct traffic heading for .102 and point at 10.2.0.2 without creating multiple port forwards, which then would need creating for multiple interfaces

The guide suggests this is possible?

Can't you use list ipaddr <addr/mask> multiple times on interface?
That's how I assign multiple addresses on the loopback.
But anyhow you will have to ensure proper routing especially for the default route. You can do that with ip rule but I can not tell you how to do that with UCI.

@vgaetera Would you mind chiming in? I see you wrote (or last modified) the wiki instructions.

You can sure assign multiple IPs, but not sure how/if that works if they're on the same subnet. Guide suggests that should be possibile though. Maybe because OpenWrt works with some kind of abstraction for network configuration.