Multiple PPPOE Single xdsl connection

Hi all, I am trying to create multiple pppoe connections to my ISP, my stock router currently supports 4, with different IP addresses.

My config as per the openwrt wiki

config interface 'wan'
    option ifname 'dsl0.33'
    option proto 'pppoe'
    option username 'xxxxxx'
    option password 'xxxxxx'
    option ipv6 '1'

When I create my second interface

config interface 'wan1'
    option ifname 'dsl0.33'
    option proto 'pppoe'
    option username 'xxxxxx'
    option password 'xxxxxx'
    option ipv6 '1'

They both seem to fight for the same interface of dsl0.33 as 1 wan connects the second wan disconnects a few times. If I don't use ifname dls0.33 it wont connect.

It has a inbuilt modem (tdw9980) there is no device in the switch configuration, it just shows the lan ports.


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd8f:733a:5e89::/48'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'wan'
    option ifname 'dsl0.33'
    option proto 'pppoe'
    option username 'xxxxxx'
    option password 'xxxxxx'
    option ipv6 '1' 

config device 'wan_dev'
	option name 'dsl0'
	option macaddr '18:a6:f7:84:c7:xx'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 2 4 5 6t'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1'
	option ipaddr '192.168.10.1'




Try forcing a different macaddr on each of the interfaces. The phone company generally will not allow multiple connections from the same mac. My experience was using two modems (and two phone lines, and two monthly payments) to load balance higher bandwidth. When the second one connected the first one would get disconnected from their end. The answer was to use different MACs.

Are you sure you don't use different VLANs for this? pppoe generally means Point to Point.


This is a copy of my current device. (Not Openwrt)

The device ifname dsl0.33 seems to be the same device for both connections, if I change it to any other ifname the isp wont connect. It would have been easier to make dsl0.1 dsl0.2 as virtual devices but doesnt connect.

do you mean change the macs like this? or do I use dsl0?

config device 'wan_dev'
	option name 'dsl0.33'
	option macaddr '18:a6:f7:84:c7:aa'

config device 'wan1_dev'
	option name 'dsl0.33'
	option macaddr '18:a6:f7:84:c7:bb'

hi , as mk24 wrote each dsl pppoe connection need an own vlan.
Because the are different networks.

Im wondering how it works now because you didn't set vlan 33 in switch.

There isnt no option for dsl0 in the switch from the luci interface!

This is a copy of my routers config (the non openwrt) It lets me clone this setup 4 times to get the 4 different IPs, each one has the vlan ID33 and 802.1p as 0.

Ok , I ignored the point that you wrote each of them uses vlan 33.

If it won't shown in the switch then the vlans settings will proceed by the dsl modem i guess.

Did you tried it with different mac addresses?

I have tried using 2 different macs as well as using the same. The result is the same it switches between the two connections, connecting and disconnecting until 1 dies.

At the moment I haven't an idea what could be done.

May you have a look at the syslog and post the snippets where the change between the 2 connections appear and when 1 PPPoE connection dies

I have to wonder if the kernel is even designed for multiple instances of ppp on one interface. That's something that is typically not done.

A little searching about this shows that most ISPs use one PPP tunnel with multiple static IPs routed through it.

Thanks for your help guys! That could be a possibility, as soon as one connection is up the second connection disconnects and tries its to establish its own connection. Do you have any suggestions if I were to recompile the kernel? The oem modem from the pics is a Huawei the router I am working on is a lantiq tdw9980.

Hello @stevie7303215 sorry for bumping an an old post, but if someone else is searching for it, this configuration is possible with mikrotik, just have to translate the configuration to openwrt

Here's an Indian video on how to set it up in a Mikrotik device: https://www.youtube.com/watch?v=NRwd9_0GHQ8 in summary, it involves creating an arbitrary VLAN on your WAN port and another for LAN interface and bridging those VLANs (WAN VLAN and LAN VLAN) together, then dial PPPoE on that bridge, the bridge should have different MAC addresses, as what @stupidkiller posted, ISP doesn't allow the same MAC for a single DSL connection, this is how you configure it.

The ONT/DSL Modem should already forward an untagged VLAN, if not, you will create another VLAN on top of the bridge.