Multiple Networks: DHCPv6 Assignment

Hi

I am using x86 router and I tried to create 2 lan interface. After creating 2 interfaces I am not getting IPv6 assigned. I created one for home and another for gaming. Earlier with one interface I was able to get IPv6 address but after changing to 2 interface I am not getting IPv6 assigned to any devices eg;- xbox.

I am not sure what is the mistake I am making.

I appreciate your help.

Thanks
Badri M

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; ip -6 addr ; ip -6 ro li tab all ; ip -6 ru;
2 Likes

Hi

Below attached the complete output.

package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd13:4a9d:114e::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth2'
        list ports 'eth3'
        list ports 'eth4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan'
        option device 'eth0.6'
        option proto 'pppoe'
        option username ''
        option password ''
        option ipv6 'auto'
        option peerdns '0'
        list dns '1.1.1.1'
        list dns '1.0.0.1'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option device '@wan'

config device
        option type 'bridge'
        option name 'br-game'
        list ports 'eth1'
        option bridge_empty '1'

config interface 'game'
        option proto 'static'
        option device 'br-game'
        option ipaddr '192.168.13.1'
        option netmask '255.255.255.0'
        option ip6assign '64'

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
11: br-game: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.13.1/24 brd 192.168.13.255 scope global br-game
       valid_lft forever preferred_lft forever
12: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
14: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc fq_codel state UNKNOWN group default qlen 3
    inet 86.90.230.194 peer 195.190.228.105/32 scope global pppoe-wan
       valid_lft forever preferred_lft forever
default via 195.190.228.105 dev pppoe-wan proto static
192.168.1.0/24 dev br-lan proto kernel scope link src 192.168.1.1
192.168.13.0/24 dev br-game proto kernel scope link src 192.168.13.1
195.190.228.105 dev pppoe-wan proto kernel scope link src 86.90.230.194
local 86.90.230.194 dev pppoe-wan table local proto kernel scope host src 86.90.230.194
broadcast 127.0.0.0 dev lo table local proto kernel scope link src 127.0.0.1
local 127.0.0.0/8 dev lo table local proto kernel scope host src 127.0.0.1
local 127.0.0.1 dev lo table local proto kernel scope host src 127.0.0.1
broadcast 127.255.255.255 dev lo table local proto kernel scope link src 127.0.0.1
broadcast 192.168.1.0 dev br-lan table local proto kernel scope link src 192.168.1.1
local 192.168.1.1 dev br-lan table local proto kernel scope host src 192.168.1.1
broadcast 192.168.1.255 dev br-lan table local proto kernel scope link src 192.168.1.1
broadcast 192.168.13.0 dev br-game table local proto kernel scope link src 192.168.13.1
local 192.168.13.1 dev br-game table local proto kernel scope host src 192.168.13.1
broadcast 192.168.13.255 dev br-game table local proto kernel scope link src 192.168.13.1
0:      from all lookup local
32766:  from all lookup main
32767:  from all lookup default
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2e0:4cff:fe82:f312/64 scope link
       valid_lft forever preferred_lft forever
11: br-game: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:a442:6466:10::1/64 scope global dynamic noprefixroute
       valid_lft 259147sec preferred_lft 172747sec
    inet6 fd13:4a9d:114e:10::1/64 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::2e0:4cff:fe82:f313/64 scope link
       valid_lft forever preferred_lft forever
12: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:a442:6466::1/60 scope global dynamic noprefixroute
       valid_lft 259147sec preferred_lft 172747sec
    inet6 fd13:4a9d:114e::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::2e0:4cff:fe82:f314/64 scope link
       valid_lft forever preferred_lft forever
13: eth0.6@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::2e0:4cff:fe82:f312/64 scope link
       valid_lft forever preferred_lft forever
14: pppoe-wan: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 state UNKNOWN qlen 3
    inet6 fe80::4598:2258:9364:42cb/128 scope link
       valid_lft forever preferred_lft forever
default from 2a02:a442:6466::/48 via fe80::ae8:4fff:fefc:ffe7 dev pppoe-wan proto static metric 4096 pref medium
2a02:a442:6466::/64 dev br-lan proto static metric 1024 pref medium
2a02:a442:6466:10::/64 dev br-game proto static metric 1024 pref medium
unreachable 2a02:a442:6466::/48 dev lo proto static metric 2147483647 pref medium
fd13:4a9d:114e::/64 dev br-lan proto static metric 1024 pref medium
fd13:4a9d:114e:10::/64 dev br-game proto static metric 1024 pref medium
unreachable fd13:4a9d:114e::/48 dev lo proto static metric 2147483647 pref medium
fe80::ae8:4fff:fefc:ffe7 dev pppoe-wan metric 1 pref medium
fe80::4598:2258:9364:42cb dev pppoe-wan proto kernel metric 256 pref medium
fe80::/64 dev br-lan proto kernel metric 256 pref medium
fe80::/64 dev br-game proto kernel metric 256 pref medium
fe80::/64 dev eth0 proto kernel metric 256 pref medium
fe80::/64 dev eth0.6 proto kernel metric 256 pref medium
local ::1 dev lo table local proto kernel metric 0 pref medium
anycast 2a02:a442:6466:: dev br-lan table local proto kernel metric 0 pref medium
local 2a02:a442:6466::1 dev br-lan table local proto kernel metric 0 pref medium
anycast 2a02:a442:6466:10:: dev br-game table local proto kernel metric 0 pref medium
local 2a02:a442:6466:10::1 dev br-game table local proto kernel metric 0 pref medium
anycast fd13:4a9d:114e:: dev br-lan table local proto kernel metric 0 pref medium
local fd13:4a9d:114e::1 dev br-lan table local proto kernel metric 0 pref medium
anycast fd13:4a9d:114e:10:: dev br-game table local proto kernel metric 0 pref medium
local fd13:4a9d:114e:10::1 dev br-game table local proto kernel metric 0 pref medium
anycast fe80:: dev br-lan table local proto kernel metric 0 pref medium
anycast fe80:: dev br-game table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0.6 table local proto kernel metric 0 pref medium
anycast fe80:: dev eth0 table local proto kernel metric 0 pref medium
local fe80::2e0:4cff:fe82:f312 dev eth0.6 table local proto kernel metric 0 pref medium
local fe80::2e0:4cff:fe82:f312 dev eth0 table local proto kernel metric 0 pref medium
local fe80::2e0:4cff:fe82:f313 dev br-game table local proto kernel metric 0 pref medium
local fe80::2e0:4cff:fe82:f314 dev br-lan table local proto kernel metric 0 pref medium
local fe80::4598:2258:9364:42cb dev pppoe-wan table local proto kernel metric 0 pref medium
multicast ff00::/8 dev br-game table local proto kernel metric 256 pref medium
multicast ff00::/8 dev br-lan table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth0 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev eth0.6 table local proto kernel metric 256 pref medium
multicast ff00::/8 dev pppoe-wan table local proto kernel metric 256 pref medium
0:      from all lookup local
32766:  from all lookup main
4200000000:     from 2a02:a442:6466::1/60 iif br-lan unreachable
4200000000:     from 2a02:a442:6466:10::1/64 iif br-game unreachable
4200000001:     from all iif lo failed_policy
4200000011:     from all iif br-game failed_policy
4200000012:     from all iif br-lan failed_policy
4200000014:     from all iif pppoe-wan failed_policy
4200000014:     from all iif pppoe-wan failed_policy

Thanks
Badri M

Hi

I have fixed this issue. It turns out I have to set DHCP server similar to LAN DHCP configuration. After that I started getting IPV6 addresses. Thanks for the help.

Regards
Badri M

1 Like

Hi

Though issue has been fixed I find a strange behaviour in game. I play call of duty: cold war in Xbox sx and in game I see 0 Bandwidth

My configuration, I have created a separate interface for gaming machine and assigned a new IP.

config device
        option type 'bridge'
        option name 'br-game'
        list ports 'eth1'

config interface 'game'
        option device 'br-game'
        option proto 'static'
        option ipaddr '192.168.13.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

Is there any mistake I am making?

I am still able to play without any issues but I find a split second delay from my side. I appreciate your help.

Thanks
Badri M

How's your firewall configured?

1 Like

Hi

You are right. Its firewall issue. I created new zone and assigned it in firewall. After that it started working. Thanks for your constant input and support.

Regards
Badri M

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.