Multiple defined hot spots

I'm using a GLmt300nv2 router with the latest OpenWrt that I'm using to stand in for my DSL modem when the DSL is down. I've got the LAN IP/Subnet set to match my DSL modem, and I just swap the ethernet cable to the main router. The Wireless interface is connected to a cellphone's hotspot.

It works as desired but there's a mystery that puzzles me.

If I define two wifi connections (both to Samsung S7 phones), it will auto-connect to whichever ones hotspot is enabled. But the "Host" field in the connection status display is a "?" unless I hit the "disable" button in the upper screen of the one whose hotspot is not on, at which time the "Host" field populates with my carrier's gateway. It doesn't provide a connection unless the Host field is populated. I've confirmed this behavior for both hotspots. In this experiment, both potential hotspots connect to the same carrier network/gateway although that might change if I can define more candidates.

I'd like to define multiple hotspot candidates since I never know who will be in the office when there's a failure. I can live with the handicap, but since I'm not in the office very often, logging into the router to make changes will be onerous.

The Travelmate package is designed for this use case of multiple wifi WAN uplinks. It will automatically disable the STA interfaces when their AP (the cell phone) is not present.

Also you may be able to use USB tethering instead of hotspot mode on the phone.


Is the Travelmate Package an OpenWrt version or some other product? I tried tethering under the original firmware that came with the device, and it didn't want to work with either my version of Android or my phone. I realized a hotspot was a better solution since it kept the phone in play for normal use.

As @mk24 noted, it's an installable package.

1 Like

Thanks. I'll have to work up my courage to try it, as I'm a old geezer with few intact braincells.

Well, I bought a second router (something about "one-in-the-hand...") and when I tried to install travelmate, I got some gibberish about missing prerequisites, one which was "curl". I searched for "curl" and got a deep dive into stuff I hope I don't need to know. I know I'm asking a lot for instructions to be simple, but as a non-linux person just trying to accomplish a single mission, I'm thinking about asking college for my money back, although the statute of limitations is way past.

if you make sure you've updated the package lists, you should be able to just install travelmate and it will pull in the curl package. If you had issues with updating the package list, it might not know the package yet.

Sorry, but "updating the package list" is something I'll have to research. All the packages are fresh downloads, so I obviously don't understand the mechanisms.

opkg update && opkg install luci-app-travelmate

Lately I've had problems with incomplete updates and installs. If you get an error message especially wget timeout, try again.

Nothing makes any sense to me. "opkg update " is meaningless. If the whole sentence is a command line, someone needs to steer me to a console.

On the LUCI interface there's a button... this is a slightly older version but same concept in the up to date ones:


I had pushed that button, but after 20 minutes I gave up. It only loaded packages beginning with "a" so maybe I need more patience.

I think there are some issues with the servers that they're a bit intermittent. I also had some issues a few weeks back. Mainly try again until no errors. without a full package list you can't really install packages.

Does the "Executing package manager" banner eventually go away? Too bad it doesn't have a progress bar or even a spinning indicator.

Within about a minute the "executing package manager; waiting for opkg update to complete" should change to a large window with text showing the success or failure of each download. The last line should be "Signature check passed." If you see errors, dismiss the window and try again.

Of course, the router needs to be connected to the Internet for package list to be downloaded. Go to network--diagnostics and try a ping test. The box at the left should be pre-loaded with "". Click the button underneath for IPv4 Ping. After 5 seconds you should see a report "5 packets sent, 5 packets, received, 0% packet loss."

I'm typing on my laptop, which is connected only by the router and a 4G hotspot. Ping works, although it's really slow.

When I push Update Lists I get the popup including a spinning wheel, but after o minute or so, the second line disappears, and the popup banner remains.

The laptop should be connected to the hotspot through the router. Connecting the laptop's wifi directly to the hotspot will not give the router Internet access.

OK, i aborted the update for a third time, and it seems to have downloaded all the packages., it just never finished neatly. I installed travelmate and luci-travelmate, and will see what seems to happen.

I had very similar results when I was setting up a RPi4 in ... January or so? it kept bailing out after getting "most" of the stuff... I'm not sure why.