Multicast forwarding for bridged WiFi and LAN (Solved)

In the process of setting up my Roku boxes to connect to my Plex server I've discovered that my router is not forwarding multicast packets between the wifi and lan switch ports. I'm using a slimmed down version of 17.0.2 on banana pi r1. (plex is wired and Roku is wireless, Though a wired Roku couldn't find plex either)

I don't have upnpd running - I don't want my devices to request an open port to the internet....
echo "0" > /sys/devices/virtual/net/br-lan/bridge/multicast_snooping is set. But no other IGMP or other settings.

There have been some other conversations and issues around this, but some seem related to switch capabilities or vlan setups . like Configuring "dumb AP" (disable multicast snooping and IPv6)

Is there an extra daemon I need to be running for this to work?

I think other home video sharing/serving apps like chrome cast must use multcasts to interconnect devices.


1 Like

Ok Turns out that Multicast forwarding IS working fine on the router.

From a Linux Wifi connection tcpdump show multicast packets just fine.
localhost ~]$ sudo tcpdump ether multicast
20:24:08.706960 IP plex.lan.57617 > UDP, length 21
20:24:08.707966 IP plex.lan.49773 > UDP, length 21
20:24:13.706963 IP plex.lan.57617 > UDP, length 21
20:24:13.707934 IP plex.lan.49773 > UDP, length 21

SO the RoKu forms indicated that the default security settings between the Plex server and Roku need to match.

So on the plex server -> Settings -> Network
LAN Networks, and List of IP addresses and networks that are allowed without auth
Then Secure connections - needs to be preferred or disabled.

On the Roku box - The Plex app on RoKu settings - Advanced change. "Allow insecured connections" = from never to "only on local lan" This should be fine over a home network. If the plex is serving outside the home network secure connection needs to be configured.