MUD supporting router


Trying to research the MUD protocol to test IoT security. One MUD implementation is osMUD:

which requires a router with openWRT. Which openWRT supporting router would you best recommend for testing MUD?

Thanks and best regards,


VM running x86, unless you need wireless AP capabilities (even there, a "good old" ath9k USB dongle should at least be functional). as one example.

Reasoning is that it's "cheap" for most people, and has relatively unlimited resources, compared to all-in-one routers.


Thanks for the tip.

Tried multiple versions of images but they all just showed a blank screen after the grub boot loader and don't progress. Tried increasing memory and CPU etc but still same result. What would you advise?

OpenWrt on avirtual machine works for most of us... perhaps you should explain which images you used and how you configured the environment.

Thanks for the reply,

it worked after changing to Linux for Type , and Linux 2.6 / 3.x / 4.x (64-bit) for Version.

currently using 18.06.1.

Best regards