MTU setting on Bridge interface not setting MTU on member interfaces

Hi Folks,

I have a LAN bridge over 4 switch ports, a couple that carry trunks to the downstream switches (eth4, eth6) and a couple that serve local hosts (eth5, eth7). I have the MTU setting on all the bridges to 9000. Config snippet:

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'
        option type 'bridge'
        option mtu '9000'
        option ifname 'eth4.10 eth5 eth6.10 eth7'

config interface 'mgmt'
        option ifname 'eth4.100 eth6.100'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option mtu '9000'

config interface 'guest'
        option proto 'static'
        option netmask '255.255.255.0'
        option ifname 'eth4.200 eth6.200'
        option ipaddr '192.168.101.1'
        option type 'bridge'
        option mtu '9000'

config interface 'iot'
        option ifname 'eth4.300 eth6.300'
        option proto 'static'
        option ipaddr '10.10.10.1'
        option netmask '255.255.255.0'
        option type 'bridge'
        option mtu '9000'

However after a router reboot the interfaces do not get the MTU set correctly - the bridge and phyical interfaces default to 1500. Here is post-reboot status (truncated):

br-guest  Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

br-iot    Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

br-lan    Link encap:Ethernet  HWaddr 0C:C4:7A:AB:39:3D
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

br-mgmt   Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth4      Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth4.10   Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth4.100  Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth4.200  Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth4.300  Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:50
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth5      Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:51
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

eth6      Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:52
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

eth6.10   Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:52
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

eth6.100  Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:52
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

eth6.200  Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:52
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

eth6.300  Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:52
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

eth7      Link encap:Ethernet  HWaddr 3C:FD:FE:BB:01:53
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

Is this expected behavior?

From here I have to then manually then set the MTU of interfaces to 9000 using ifconfig:

ifconfig eth4 mtu 9000
ifconfig eth5 mtu 9000
ifconfig eth6 mtu 9000
ifconfig eth7 mtu 9000

This fixes the physical interfaces, but the VLAN and Bridge interfaces still report MTU 1500. To get everything fully working I then have to restart the networking with the init.d script. Only after this will all interfaces and bridges report MTU 9000.

Is this a bug? If not, how do I get the interfaces to MTU 9000 on startup?

Thanks.