MTU Override Question

Hello,

I would like to understand why when i set for exemple : 1400 mtu on the wan interface, i can still send 1500 bytes packets without fragmenting, with the command below on win10

ping -f -l 1472 8.8.8.8.

same thing if i override on LAN + WAN interface, bigger packets still can be transmitted without framenting.

thanks in advance. Nico

What is the output of ip -s link ?

Hi,

Can you explain a bit more, i'm new to the thing =)

Use ssh to connect to the device, run this command and paste here the output in preformatted text. (the </> button).

like this ? Thanks


root@OpenWrt:~# ip -s link
BusyBox v1.30.1 () multi-call binary.

Usage: ip [OPTIONS] address|route|link|neigh|rule [ARGS]

OPTIONS := -f[amily] inet|inet6|link | -o[neline]

ip addr add|del IFADDR dev IFACE | show|flush [dev IFACE] [to PREFIX]
ip route list|flush|add|del|change|append|replace|test ROUTE
ip link set IFACE [up|down] [arp on|off] [multicast on|off]
        [promisc on|off] [mtu NUM] [name NAME] [qlen NUM] [address MAC]
        [master IFACE | nomaster]
ip neigh show|flush [to PREFIX] [dev DEV] [nud STATE]
ip rule [list] | add|del SELECTOR ACTION
root@OpenWrt:~#

You are running different "ip" version.
Try it without '-s'

root@OpenWrt:~# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    link/ether 10:7b:44:95:e2:68 brd ff:ff:ff:ff:ff:ff
3: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN qlen 32
    link/ether 86:34:91:dc:8d:3b brd ff:ff:ff:ff:ff:ff
4: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN qlen 32
    link/ether 7e:87:66:ca:98:0c brd ff:ff:ff:ff:ff:ff
5: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 10:7b:44:95:e2:6c brd ff:ff:ff:ff:ff:ff
15: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether 10:7b:44:95:e2:68 brd ff:ff:ff:ff:ff:ff
88: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1400 qdisc noqueue state UP qlen 1000
    link/ether 10:7b:44:95:e2:68 brd ff:ff:ff:ff:ff:ff
89: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether 10:7b:44:95:e2:68 brd ff:ff:ff:ff:ff:ff
90: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc cake state UP qlen 1000
    link/ether 10:7b:44:95:e2:69 brd ff:ff:ff:ff:ff:ff
93: ifb4eth0.1: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc cake state UNKNOWN qlen 32
    link/ether 2e:bb:83:d7:2d:df brd ff:ff:ff:ff:ff:ff

any ideas ? :cry:

there is no such interface on your router according to the information you posted

As it shows, only br-lan has a smaller mtu of 1400. I believe wan is eth0.2 which has 1500.

1 Like

Thank for the answers.

Actually i only see 3 interfaces on Luci : VPN (tun0), LAN (br-lan) and WAN(eth0.1) and the override MTU is properly set on 1400 there. maybe there's another way to force it ?

Mind if I ask why do you want to create problems to your connection by messing with the mtu?

2 Likes

For testing purposes. Fact is the override MTU box on Luci doesnt seem to work, at least for me, i need a workaround..

Well i'll post the solution i've found by myself since nobody wanna help me on this one

login by ssh :

ip link
//find the interface you want to adjust the mtu on, for me "eth0.1"

ip link set dev eth0.1 mtu 1400
service network reload

you're done. i'm sure this will be usefull for somebody.

Thanks for not helping <3

Or in UCI syntax:

# in /etc/config/network

config device
	option name 'eth0.1'
	option mtu '1400'

From your first post I didn't realize you wanted to know how. I thought you just wanted to know why.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.