Mtu override on master?

is MTU override (in /etc/config/network) working in master? i'm on a fairly recent snapshot build on an R7800 and i've noticed that the usual

config interface 'eth0'
        option ifname 'eth0'
        option proto 'none'
        option mtu '1508'

and similar changes to 'wan' are not working.

ifconfig shows both eth0 and eth0.2 have MTU 1500.

EDIT: trying to change it on eth0 through ifconfig/ip link just results in a Resource busy error.

# in /etc/config/network

config device
	option name 'eth0'
	option mtu '1508'

i tried that too, doesn't seem to do anything.

To be clear... eth0 is not usually an interface used directly on most devices (it's usually eth0.1 and eth0.2)...what equipment do you have?

R7800. but afaik you have to set it on the underlying interface (which is eth0). in any case i have it on every eth0 and eth0.x in sight and it does nothing.

this used to work (say a year ago, the last time i bothered to check it).

The method documented since 2014 no longer works on master builds from around February 2020 onwards.

Your options:

  • Use an older build
  • Wait for DSA support
  • Use a different device that already supports DSA

why? or rather, what changed?

EDIT: i guess it's the change to Kernel 5.4? seems perhaps it might be fixed in Kernel 5.7.

1 Like

How do you change MTU in DSA? I didn't found that info. If I change MTU in Luci it doesn't work.

thanks for the pointer, i patched my build to use DSA and fixed a bug in the qca8k driver, now it works again.

@facboy, can you share what have you done to be able to adjust MTU? Thank you in advance.

i had to patch the qca8k driver and change the DTSI to use DSA.

this is the patch for kernel 5.4 for the qca8k driver:

the DSA changes are in my tree somewhere, it's not very tidy. nobody seemed very interested in fixing the issue for openwrt as it may or may not be fixed in kernel 5.7+, so i have not bothered to tidy it up any further as this is my personal build tree.