[MTk 7632n] BPI-R2 + Openwrt 18.06.1 = Only have 0kb available on filesystem

I flash to boad OpenWrt 18.06.1, r7258-5eb055306f from https://downloads.openwrt.org/releases/18.06.1/targets/mediatek/mt7623/
and when I tried to install the package I got the error: Verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg nano needs 63
I assume that you need to increase the amount of free space in the firmware or include resize2fs in it by default.
But I can only test image and report.
Is it possible to solve the problem myself, or do I need to wait for the release of the update from the OpenWRT team?

root@OpenWrt:/# mount
rootfs on / type rootfs (rw)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                   504.2M    648.0K    503.6M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

For some people nano is bloadware, try out vi, its very good! Don't take me seriously! Nano is fine.
I wonder why mtk7623 should'nt use overlayfs..
Try out a older build..
MTK7623 or 7632?
BPI-R2 is 7623 so should be the correct image.

Greetings Elias

What old image can I try? And how can I find a person who understands how Openwrt is compiling and ready to spend a couple of hours to talk with me(I not understanding either programming or English) :grinning:

Did you use the initramfs or squashfs version? I don't think the initramfs image will be able to store anything permanently. Did you put it on a completely empty storage device with no existing partitions?

here are the different releases for download:
openwrt releases
Direct link to 18.06.0 build for BPI-r2:
for 18.06.1
18.06.1 sqashfs

gl elias

I used the initramfs version. The device memory is divided as follows:

:/# fdisk -l /dev/mmcblk0
Disk /dev/mmcblk0: 7.3 GiB, 7818182656 bytes, 15269888 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xffffffff

Device         Boot  Start      End  Sectors  Size Id Type
/dev/mmcblk0p1        2048    12287    10240    5M 83 Linux
/dev/mmcblk0p2      135168 15269887 15134720  7.2G 83 Linux

other images contain a similar structure, when I view a hexview, I do not see the file system.
For example: The release of the x86 platform contains a file structure in a separate file https://downloads.openwrt.org/releases/18.06.1/targets/x86/generic/rootfs-ext4.img.gz

In the releases of LEDE compiled by the Chinese manufacturer, the file system is visible in the images.

When you compile you can choose which images you like to generate at the end. Dig yourself through the menuconfig, you'll need the knowledge when you like to use openwrt seriously on such a device . Then you can configure the Image size and so many more
I would recomment to use squashfs with a overlay. you will be more fault tolerant with overlayfs.
greetings Elias

unfortunately , cross-compilation in buildroot is too difficult task for me

Use the squashfs version. As you can see the flash disk does not get mounted when you use initramfs, and I don't know if there is an easy way to do it.

If the squashfs version doesn't mount anything either you may be better off making your own image and select ext4. It's easy if you have Linux: https://openwrt.org/docs/guide-developer/quickstart-build-images
and not very difficult using Windows or another OS that supports Virtualbox: https://openwrt.org/docs/guide-user/additional-software/beginners-build-guide

From this study, I learned the difference between the versions of initramfs and squashfs.
Because first 2 megabytes is occupied preloader and Uboot, I flashed a squashfs corresponding shift:
dd if = openwrt-18.06.1-mediatek-mt7623-7623n-bananapi-bpi-r2-squashfs-sysupgrade.bin of = / dev / mmcblk0 bs = 1M seek = 2

I received the following error when loading:

[    1.510376] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    1.517797] Please append a correct "root=" boot option; here are the available partitions:
[    1.526118] b300         7634944 mmcblk0
[    1.526122]  driver: mmcblk
[    1.532898]   b301            5120 mmcblk0p1 ffffffff-01
[    1.532900]
[    1.539649]   b302         7567360 mmcblk0p2 ffffffff-02
[    1.539652]
[    1.546388] b318             512 mmcblk0rpmb
[    1.546391]  (driver?)
[    1.553070] b310            4096 mmcblk0boot1
[    1.553073]  (driver?)
[    1.559824] b308            4096 mmcblk0boot0
[    1.559827]  (driver?)
[    1.566562] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

if I'm not mistaken, the root-filesystem should be on the squashfs section. but neither in initramfs nor in squashfs contains the signature "hsqs" denoting the beginning of the squashfs section. So in both images does not exist the root-filesystem ? Is that enough to open the issue?

I would very much like to get a working image from the openwrt site to facilitate future updates and ensure the compatibility of the opkg repository

I suspect the R2 isn't properly supported. Everything about the images seems very generic compared to the other banana pi releases. https://openwrt.org/toh/start?dataflt[Model*~]=banana&dataflt[Brand*~]=

I am compiling a ext4 version and send you a link for the dwonload!
Openwrt has the easiest Buildsystem i ever used .I recommend to use it! It is more difficult to compile your own linux kernel for debian or to install a debia from scratch with a minimal-iso!
Ill post the link soon !
It will be a 18.06.1 stable release if you want a master as well.,.
These files will be deleted in 7 days

1 Like

The config :

# CONFIG_TARGET_ar71xx_generic is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_A60 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALFAAP120C is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALFAAP96 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALFANX is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALL0258N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALL0305 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALL0315N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP121_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP121_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP132 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP135 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP136_010 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP136_020 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP143_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP143_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP147_010 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP152_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP96 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_BXU2000N2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_CAP4200AG is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DB120 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DGL5500A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DHP1565A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR505A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR825B1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR825C1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR835A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DLRTDEV01 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EAP300V2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EAP7660D is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EPG5000 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ESR1750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ESR900 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_F9K1115V2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_HORNETUB is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_HORNETUBx2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_JA76PF is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_JA76PF2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_JWAP003 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MR1750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MR600 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MR900 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MYNETREXT is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MZKW04NU is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MZKW300NH is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_NBG6616 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_OM2P is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_OM5P is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_OM5PAC is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_PB42 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_PB44 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW673GRU is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW732BR is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW823DRU is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TUBE2H16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TUBE2H8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WNDAP360 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WNR2200 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WP543_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WP543_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPE72_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPE72_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WRT160NL is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WRT400N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZR450HP2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZR600DHP is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPAG300H is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPG300NH is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPG300NH2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPG450H is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ZCN1523H28 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ZCN1523H516 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_antminer-s1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_antminer-s3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_antrouter-r1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ap121f is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ap531b0 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ap90q is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ap91-5g is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c25-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c5-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c58-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c59-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c60-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c60-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v2-il is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_arduino-yun is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_bhr-4grv2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_bsb is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_c-55 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cap324 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cap324-nocloud is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_carambola2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e316n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e320n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e355ac-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e355ac-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e375ac is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e380ac-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e380ac-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e385ac is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e520n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e530n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe210-220-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe210-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe505n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe510-520-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe830 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe870 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr3000 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr3000-nocloud is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr5000 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr5000-nocloud is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dLAN_Hotspot is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dLAN_pro_1200_ac is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dLAN_pro_500_wp is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dap-1330-a1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dap-2695-a1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dir-869-a1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dr342 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dr531 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dragino2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e1700ac-v2-16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e1700ac-v2-8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e558-v2-16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e558-v2-8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e600g-v2-16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e600g-v2-8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e600gac-v2-16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e600gac-v2-8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e750a-v4-16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e750a-v4-8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e750g-v8-16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_e750g-v8-8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_eap120-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_el-m150 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_el-mini is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ens202ext is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ew-balin is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ew-dorin is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ew-dorin-router is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_fritz300e is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_fritz4020 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_fritz450e is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-ar150 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-ar300 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-ar300m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-ar750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-domino is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-inet-6408A-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-inet-6416A-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-mifi is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-usb150 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_hiwifi-hc6361 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_jwap230 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_koala is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_lan-turtle is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_lima is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mc-mac1200r is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_minibox-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mr12 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mr16 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mw4530r-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mynet-n600 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mynet-n750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_n5q is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_omy-g1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_omy-x1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_onion-omega is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_oolite-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_oolite-v5.2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_oolite-v5.2-dev is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_packet-squirrel is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_pqi-air-pen is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_qihoo-c301 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_r36a is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_r602n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_re355-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_re450-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_rme-eg200 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_rut900 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_rw2458n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_sc1750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_sc300m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_sc450 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_smart-300 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_som9331 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_sr3200 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_t830 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tellstick-znet-lite is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr6400-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr3500-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr3600-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4300-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4300-v1-il is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4310-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4900-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr6500-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr7500-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wpa8630-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043n-v5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043nd-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043nd-v4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr2543-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr710n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr710n-v2.1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr810n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr810n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr842n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr842n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr842n-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr902ac-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr942n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ts-d084 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubdev01 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-air-gateway is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-air-gateway-pro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-airrouter is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-bullet-m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-lbe-m5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-loco-m-xw is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-ls-sr71 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-nano-m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-nano-m-xw is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rocket-m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rocket-m-ti is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rocket-m-xw is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rs is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rspro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-uap-pro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifi is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifi-outdoor is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifi-outdoor-plus is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifiac-lite is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifiac-mesh is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifiac-pro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wam250 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wbs210-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wbs510-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_weio is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wifi-pineapple-nano is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wlr8100 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3700 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3700v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3800 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3800ch is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndrmac is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndrmacv2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wpj342 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wpj344 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wpj531 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wpj558 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wpj563 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wrtnode2q is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_xd3200 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_zbt-we1526 is not set
# CONFIG_TARGET_ar71xx_generic_Default is not set
# CONFIG_TARGET_ar71xx_mikrotik is not set
# CONFIG_TARGET_ar71xx_nand is not set
# CONFIG_TARGET_ar71xx_tiny is not set
# CONFIG_TARGET_mediatek_mt7622_DEVICE_MTK-RFB1 is not set
# CONFIG_TARGET_mediatek_mt7622_Default is not set

1 Like

Thank you very much for the help! But either I do something wrong, or the problem is a bit more complicated:

BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt-tonyich tonyich_01, tonyich_0001
=== WARNING! =====================================
There is no root password defined on this device!
Use the "passwd" command to set up a new password
in order to prevent unauthorized SSH logins.
root@OpenWrt:/# mount_root
root@OpenWrt:/# mount
rootfs on / type rootfs (rw)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)

It seems to me that initramfs contains a minimal filesystem in itself, to run the kernel. And that the external file system is mounted, after boot kernel, need to fix / etc / fstab inside the initramfs.

Ok i did something wrong will compile a new one!!
I was kinda stupid not to read about the bpi-r2 first..
Do you boot from emmc flash chip? or micro sd?
i need to know in the openwrt buildroot is a script for generating the emmc image, i can create that. Could be still a problem without the bootlaoder. I see that bpi-r2 is not ported to openwrt, it is ported to lede. I never mess around with lede i sticked to openwrt, but i could port it to openwrt in a fork. ATM i have not the time to do so. I will generate a emmc flash image for you and go on with my labour. Sry for my english

Thank you very much for your work! My English exist only through Google.
I'm loading from emmc. so as not to damage the loader, I'm skipping 2 MB

So, here i am again..
I tried to understand the original bpi-r2- lede repository and tried to port their work to openwrt, kinda stupid what i did but i made two images hopefully working ones.

The images are with uboot..
I recomment to try the SD-Card version first, when you know how to write a new bootloader to the rpi-r2 emmc try the emmc one
gluck i realy dont know if this works..
You see they are both equal so there should be a difference i think. But give it a try they are both with preloader, uboot, kernel, rootfs...
in KB

SHA256(mtk-bpi-r2-SD.img)= 76b084ed5ba6ee1f3b45cf25def90f9c3e50a23d2fdd1a634cebd04ab0e90a79

i try to write emmc,

root@OpenWrt:/# dd bs=1M if=mtk-bpi-r2-EMMC.img of=/dev/mmcblk0
67+1 records in
67+1 records out

Uboot is load, but have crc error..

 bootloader load uboot ,the address of uboot is 81E00000
[PART]partition name UBOOT
[PART]partition start block 0x200
[PART]partition size 0x80000
[PART]partition blks 0x400
[PART]partition flags 0x0
[PART]partition name 0x8
[bean] part->startblk(0x200) bdev->blksz(0x200) part->part_id(8) hdr(0xFFB50000)
[BlkDev.c 101 ]partition block size 0x200 ,blks:0xE90000
[BlkDev.c 101 ]partition block erase size 0x200

[PART] load "UBOOT" from 0x0000000000050000 (dev) to 0x81E00000 (mem) [SUCCESS]
[PART] load speed: 10462KB/s, 300000 bytes, 28ms
[BT_SD_PG] device info 0x8590 0x8A00 0xCB01 0x102
[PLFM] md_type[0] = 0
[PLFM] md_type[1] = 0

[PLFM] boot reason: 4
[PLFM] boot mode: 0
[PLFM] <0xFFB7CC10>: 0x0
[PLFM] boot time: 2033ms
[PLFM] DDR reserve mode: enable = 0, success = 0

[BLDR] jump to 0x81E00000
[BLDR] <0x81E00000>=0xEA00000F
[BLDR] <0x81E00004>=0xE59FF014

U-Boot 2014.04-rc1 (Sep 25 2018 - 12:32:40)

g_nr_bank = 1.
g_total_rank_size = 0x80000000
DRAM:  2 GiB
WARNING: Caches not enabled
MMC:     emmc: 0,  sdcard: 1
dev_num = 0
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
bootargs = board=bpi-r2 earlyprintk console=tty1 fbcon=map:0 console=ttyS0,115200 vmalloc=496M debug=7 initcall_debug=0 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait
Net:   Eth0
Uip activated
Hit any key to stop autoboot:  0
Unknown command 'No' - try 'help'

i see a command prompt in your post pls enter printenv if possible and send me output..
perhaps entering boot is enough.. to boot

from http://forum.banana-pi.org/t/topic/3878/42

1. Copy EMMC image to a running system which is on SD card
2. Program EMMC image to User Data Area of EMMC: dd if=mtk-bpi-r2-EMMC.img of=/dev/mmcblk0
3. Unlock EMMC boot0 block: echo 0 > /sys/block/mmcblk0boot0/force_ro
4. Program preloader to EMMC boot0 block:
     dd if=mtk-bpi-r2-EMMC.img of=/dev/mmcblk0boot0 bs=1M count=1
5. Change the Partition configurion of EMMC is 48h: reboot the system which is running SD, and enter the U-boot command line, run command
    emmc pconf 48
6. Power off, remove SD card, and then power on R2 board.