MT7916 concurrent 2.4GHz & 6GHz results in capped bandwidth on 6GHZ

EDIT: disabling 2.4GHz allows max throughput to be realised on 6GHz with snapdragon chipset device (Quest3) but none of the intel AX210 devices can see the 6GHz SSID now wihtout 2.4GHz also enabled.

With everyones help I finally managed to complete my build of openwrt 23.05.3 on x86-64 (Prodesk 600 G4 intel i5 8500) with RTL8125 4 port NIC and MT7916 AP module

How do I go about investigating to determine what the cause of the following is (I dont even know where to start)?

If I only enable the 6GHz radio, all my intel AX210 equipped devices fail to see the MT7916 6GHZ AP. However if I enable the 2.4GHz radio at the same time the intel ax210s will finally see the 6GHz SSID.

The problem with that is I wanted the 6GHz radio specifically for the Quest 3 (qualcom snapdragon XR2) but the max throughput on the Quest 3 seems to be restrcited for some reason to around 400mbps down and 20mbps up. Whereas on the Intel devices (when they can see the 6GHZ SSID) I can reach almost 1500mbps up and down.

I have no idea where to start to figure this one out, please advise

Please post output of

ubus call system board

According to published specs Quest3 supports 2.4GHz, if it does not that should be resolved with whomever sold it to you.

Im a little usure how to use ubus.

If I just enter the the comand as you have quoted it only returns

{
"kernel": "5.15.150",
"hostname": "OpenWrt",
"system": "Intel(R) Core(TM) i5-8500 CPU @ 3.00GHz",
"model": "HP HP ProDesk 600 G4 SFF",
"board_name": "hp-hp-prodesk-600-g4-sff",
"rootfs_type": "ext4",
"release": {
"distribution": "OpenWrt",
"version": "23.05.3",
"revision": "r23809-234f1a2efa",
"target": "x86/64",
"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
}
}


Im readig the documentation on ubus and Im not sure how to pull other relevant info from the system.

If I do 'ubus list' it does show me: 'hostapd.phy1-ap0' which is related to my wifi AP

Im not sure how to get other info from that.

You can have multiple accesspoints on each band.

I do have the suspicion the issue lies with the the drivers in the Quest3 firmware, its been getting progresively worse with every mandatory Meta firmware update.

However I dont know enough to really dig down and investigate in openwrt to confirm there is nothing askew in there.

My idea is simple - Set up one access point name on both bands for AX210 and other clients and set up other access point name in 5-6GHz band exclusively for quest.

1 Like

usb list shows

hostapd.phy0-ap0
hostapd.phy1-ap0

Which is all expected and seems normal to my untrained eye

as phy0-ap0 is associated with the 2.4GHz band

and phy1-ap0 is assocaaited with my 6GHz band.

What I have noticed is that with other devices when looking at the throughput test curve, 'usually' there is an intial ramp up of speed and then a sudden jump up to max speed.

All devices seem to do the intial ramp up then jump. but the Q3 stays at the lower level of the intial rampup. Is there a way to see what is going on inside openwrt and the hardware that correlates with the initial ramp up to the full speed jump.

The config file /etc/config/wireless to review for obvious mistakes :wink:

1 Like

aaaah now i understand what you mean.! I didnt twig that I could have two SSID on one band. So for example on the 6GHz band can have 6GHZAX210AP and MTQT6GHZAP Thats a new one on me. Thanks

iw list (long output) twll each radios capability.

1 Like

Thank you @brada4. These tidbits are really helping me to expand my knowledge and understading

Attach wifi config and iw list to look at. Maybe you break something general.

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:1c.0/0000:08:00.0'
        option channel '6'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'
        option country 'GB'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'MTQT24GHZ'
        option encryption 'psk2' 
        option encryption 'psk2'
        option key 'examplepasswd1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:1c.0/0000:08:00.0+1'
        option channel '1'
        option band '6g'
        option htmode 'HE160'
        option country 'GB'
        option cell_density '0'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid 'MTQT6GHZ'
        option encryption 'sae'
        option key 'examplepasswd2'
        option network 'lan'
        option disassoc_low_ack '0'


iw list is massive so Ill link a text document:

Or is there a better way to share?

Seems quite capable programmatically....

valid interface combinations:
                 * #{ IBSS } <= 1, #{ AP, mesh point } <= 16, #{ managed } <= 19,
                   total <= 19, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz, 160 MHz }

You can attach files here in forum without expanding too.

No performance limiting settings present.

sorry if this is a stupid question but can you step by step how you did the code box. When I tried pasting in the iw list output I was informed I was massively over the character limit. I am just using windows terminal to ssh in and just copy pasting from there

From your response to the outptus of iw list and /etc/config/wireless is it possible to conclude that there dont seem to be any issues with openwrt and the MT7916 driver and firmware and therefore the issue has to be in the Q3 firmware? ie ditching the MT7916 for a U7 Pro wont make any difference?

No performance limiting settings present.

much appreciated. that gives me some peace of mind, knowing I havent borked my openwrt somehow.

If you read Quest3 around their forums - for some it works, for some do not, for some even with ac router or in plain 2.4ghz.

Hi Brada4, I got back home after work and had a thought. To eliminate the openwrt router/MT7916 card as the source of probem

I switched my old Virgin media ISP router out of modem mode and used it as the gaetway router and then used the old Asus AX58U as my 5GHz access point

The throughput test on Quest 3 I got no issues with acheiving max throughput of 970mbps up and down consistently (AX58u only has gigbabit ethernet).

Also when I ran the AX58u as the 5GHz AP but this time through my openwrt gateway router instead of the ISP router I also get max throughput of 970mbps up and down.

Its only when I swtich to the 6GHz band in the MT7916 that the Quest 3 tanks. But also rather alarmingly, having demonstrated the 5GHZ band from the AX58u performing at maximum through either router, I swtiched the MT7916 card inside the openwrt box to 5GHz band :- and Q3 performance tanks again back down to 300-400mbps down 20mbps up.

So its not the openwrt box as the ax58u would suffer when connected to the openwrt box. Which means it must be the MT7916 card???

How do I dig into whats happening with the MT7916 and data packets during transmission?