MT7623NI Bananapi R2 Router SCP file transfer performance problem

Hi,
I am curently working on Banana Pi R2 MT7623N router.
I have established point to point Wireguard between router and my ubuntu pc.
When i started 10gb file transfer from my pc to router over wireguard using scp
it starts with bit rate 10MB/s

scp 10g.bin root@15.15.15.2:/tmp/.
10g.bin                                         0%   40MB  10.0MB/s   15:06 ETA^

and i started 3 paralel scp transfer at total with using below command

bit rate decreased up to 7.4Mbits

scp 10g.bin root@15.15.15.2:/tmp/.
10g.bin 2% 267MB 7.6MB/s 19:27 ETA^
scp 10g.bin root@15.15.15.2:/tmp/.
10g.bin 2% 267MB 7.4MB/s 19:27 ETA^
scp 10g.bin root@15.15.15.2:/tmp/.
10g.bin 2% 267MB 7.4MB/s 19:27 ETA^

Here is htop while 3 scp file transferring

I also tested this scenerio on Armbian installed BananaPi R2 it started 13.1Mbits

scp 10g.bin root@15.15.15.2:/tmp/.
10g.bin                                         0%   40MB  13.1MB/s   14:00 ETA^

when i did same paralel work bitrate performance not decreased like above

I tried this scenerio on 21.01.1,2,3 and 22.03.0-rc1 version all are same results
So What it can cause . How can i increase OpenWRT's performance? Thanks for any help?

my network conf

root@OpenWrt:~# cat /etc/config/network 
nterface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fddd:99e7:d28b::/48'


config interface 'wan'
	option device 'wan'
	option proto 'static'
	option ipaddr '192.168.20.216'
	option netmask '255.255.255.0'
	option gateway '192.168.20.1'

config interface 'wg0'
	option proto 'wireguard'
	option private_key 'secret'
	list addresses '15.15.15.2/24'
	option mtu '1600'

config wireguard_wg0
	option description 'opir1'
	option public_key 'secret
	list allowed_ips '15.15.15.1/32'
	option route_allowed_ips '1'
	option endpoint_host '192.168.20.232'
	option endpoint_port '62000'
	option persistent_keepalive '25'

and if you skip the wireguard, and use scp only ?

You are (probably) comparing dropbear vs. openssh (armbian), performance differences wouldn't quite surprise me for that; dropbear is foremost small, performance secondary.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.