MT7621 - LAN interfaces not working

Hi,

Building my firmware for ER605v2 (from master), using the same parameters as ever, after flashing new firmware lan ports are not working (wan port working like a charm, tested via OpenVPN with my mobile).

Going back to previous build (from about 1 month ago), working again with no issues.

Anyone having problems with MT7621 + lans ports?

Thanks,

I cannot peak to the possibility of a bug having crept into the latest snapshots, but it would be a good idea to review your configuration to make sure that there's nothing wrong with the configuration you are currently using.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/dhcp
cat /etc/config/firewall

Hi @psherman I think is not related to my config.

The same config files work in stable release 23.05.2, work with kernel 6.1.83 and work with kernel 6.6.30.

root@ER605:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd7f:7cbf:181c::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        option ipv6 '0'
        list ports 'eth1'
        list ports 'eth2'
        list ports 'eth3'

config bridge-vlan
        option device 'br-lan'
        option vlan '10'
        list ports 'eth1:t'
        list ports 'eth3'

config device
        option name 'eth1'
        option macaddr '9C:A2:F4:40:21:BF'

config device
        option name 'eth2'
        option macaddr '9C:A2:F4:40:21:BF'

config device
        option name 'eth3'
        option macaddr '9C:A2:F4:40:21:BF'

config device
        option name 'eth4'
        option macaddr '9C:A2:F4:40:21:BF'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option delegate '0'

config interface 'iots'
        option device 'br-lan.10'
        option proto 'static'
        option ipaddr '192.168.10.1'
        option netmask '255.255.255.0'
        option delegate '0'

config device
        option name 'eth0'
        option macaddr '9C:A2:F4:40:21:c0'

config device
        option type '8021q'
        option ifname 'eth0'
        option vid '6'
        option name 'eth0.6'
        option ipv6 '0'

config interface 'Internet'
        option proto 'pppoe'
        option device 'eth0.6'
        option username 'xxxxxxx@xxxxxxxx'
        option password 'xxxxxx'
        option ipv6 '0'
        option mtu '1492'
        option delegate '0'
        option ip4table 'default'
        option ip6table 'default'
        option sourcefilter '0'

config device
        option name 'br-lan.10'
        option type '8021q'
        option ifname 'br-lan'
        option vid '10'
        option ipv6 '0'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'eth1:u*'
        list ports 'eth2:u*'

config device
        option name 'dsa'
        option ipv6 '0'

config device
        option name 'br-lan.1'
        option type '8021q'
        option ifname 'br-lan'
        option vid '1'
        option ipv6 '0'

config device
        option name 'tun0'
        option ipv6 '0'

root@ER605:~#root@ER605:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'
        option drop_invalid '1'

config zone 'lan'
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'
        list device 'tun+'

config zone
        option name 'iots'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'iots'

config zone 'wan'
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'Internet'

config forwarding
        option src 'lan'
        option dest 'wan'

config forwarding
        option src 'iots'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule 'ovpn'
        option name 'Allow-OpenVPN'
        option src 'wan'
        option dest_port '1194'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'LAN-a-IOTs'
        list proto 'all'
        option src 'lan'
        option dest 'iots'
        option target 'ACCEPT'
        option enabled '0'

config include 'bcp38'
        option type 'script'
        option path '/usr/lib/bcp38/run.sh'

root@ER605:~#

I see a bunch of things that should be adjusted:

Explicitly specify that port eth3 should be untagged by adding :u* to this:

Remove the 802.1q stanzas:

and this:

and then this:

and then you can also remove these two stanzas:

It is recommended that the input rule be set to REJECT. Also, consider removing drop_invalid:

Try those fixes, reboot and test again.

If it doesn't fix the issues, post the updated config, and also be sure to post the dhcp file (which was missing above).

Thanks @psherman I'll try it.

No luck @psherman

root@ER605:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 9C:A2:F4:40:21:BF
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

br-lan.1  Link encap:Ethernet  HWaddr 9C:A2:F4:40:21:BF
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

br-lan.10 Link encap:Ethernet  HWaddr 9C:A2:F4:40:21:BF
          inet addr:192.168.10.1  Bcast:192.168.10.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

dsa       Link encap:Ethernet  HWaddr 5E:0C:69:C3:75:BA
          inet6 addr: fe80::5c0c:69ff:fec3:75ba/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1504  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:854 (854.0 B)
          Interrupt:19

eth0      Link encap:Ethernet  HWaddr 9C:A2:F4:40:21:C0
          inet6 addr: fe80::9ea2:f4ff:fe40:21c0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2962 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3122 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1156490 (1.1 MiB)  TX bytes:1277202 (1.2 MiB)
          Interrupt:19

eth0.6    Link encap:Ethernet  HWaddr 9C:A2:F4:40:21:C0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2563 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3115 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:908349 (887.0 KiB)  TX bytes:1250629 (1.1 MiB)

eth2      Link encap:Ethernet  HWaddr 9C:A2:F4:40:21:BF
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth3      Link encap:Ethernet  HWaddr 9C:A2:F4:40:21:BF
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:171 errors:0 dropped:0 overruns:0 frame:0
          TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:17927 (17.5 KiB)  TX bytes:17927 (17.5 KiB)

pppoe-Internet Link encap:Point-to-Point Protocol
          inet addr:xx.xx.xx.xx P-t-P:192.168.144.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:2537 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3091 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:886875 (866.0 KiB)  TX bytes:1181824 (1.1 MiB)

tun0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:192.168.8.1  P-t-P:192.168.8.1  Mask:255.255.255.0
          inet6 addr: fe80::baa9:fa2e:770:1ba4/64 Scope:Link
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:1542 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2018 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500
          RX bytes:193478 (188.9 KiB)  TX bytes:940433 (918.3 KiB)

root@ER605:~#
root@ER605:~# uname -a
Linux ER605 6.6.34 #0 SMP Thu Jun 20 00:11:09 2024 mips GNU/Linux
root@ER605:~# ubus call system board
{
        "kernel": "6.6.34",
        "hostname": "ER605",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link ER605 v2",
        "board_name": "tplink,er605-v2",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r26718-5e7955171c",
                "target": "ramips/mt7621",
                "description": "OpenWrt SNAPSHOT r26718-5e7955171c"
        }
}
root@ER605:~#

Eth1 is connected to a switch.

Going back to 23.05.3, working again (same config as before, changing what you pointed me).

Thanks for you help @psherman

No one is having problems with MT7621 in lan ports (in snapshots)? :sweat_smile:

Tested today (again) and the same problem, no lan ports working with snapshots.

Thanks for your help,

Have you tried 23.05-SNAPSHOT?

This compile from yesterday works on my CUDY WR1300, will compile a new one from current to test again

OpenWrt SNAPSHOT, r0-0a07a3a13
root@cudy:~# uname -a
Linux cudy 6.6.34 #0 SMP Thu Jun 20 03:55:08 2024 mips GNU/Linux

Yes, I ran auc -b 23.05.3 and after rebooting worked fine.

In my case, yesterday snapshot was not working.

It seems the problem is only affecting my config/device.
I'll do a factory reset, and re-config from scratch.

Many thanks @stragies and @hecatae for your time and help!!!

the newer compile from todays master seems to have problems on my end too. Can check into it more after work later tonight.

Don't worry my friend!!! Take your time for relax after work.
I'm almost happy not to be alone with snaphots problems for MT7621😂

During weekend I'll do some test too.

I saw, that I was getting LLDP broadcasts from the CUDY, so tried and
managed to login via IPv6 on a LinkLocal address via LAN2. Also my mesh/batman device did not come up, so device was not reachable from Wifi.

Which means (in my case) that DHCP is not working on the LAN-ports, because Upstream (mesh5g/batman) did not come up. With a static IP set on the LAN-client, it would seem that the LAN-ports are functional.

I'll test more tomorrow. Maybe try reverting recent wifi/ucode changes.

Update: Todays merged patch https://github.com/openwrt/openwrt/commit/d648ee4c580fbd18f3c29ccfb39284a1a9929bed fixes my mesh-wifi issue (iw-update had broken something). Your issue may also be related?

My device ER605v2 has no wifi :sweat_smile:

1 Like

See: https://github.com/openwrt/openwrt/issues/15643

eth0 or eth1 labels in DSA switch conflict with autogenerated eth%d gmac device names. Seen because we removed that ethernet driver label hack: https://github.com/openwrt/openwrt/commit/2a25c6ace8d833cf491a66846a0b9e7c5387b8f0
We were trying to find a solution acceptable to upstream, but that is taking some time, so maybe we hack together a workaround in the meantime.

2 Likes

Thanks for the info!!!

I'll wait for the "solution"

Hi @johnth just a kyndly reminder if we have any news about it :grinning:

Temporary solution is commit https://github.com/openwrt/openwrt/commit/dff534e43713f302d959337b3c8a33f2b709d4c5

1 Like