MT7620A Wifi still very slow

My Archer C20 v1 (22.03.2) has slow wifi.
2.4GHz (40Mhz) is 14 MBit/s, while 5.8GHz (by another router chip) ok.
Old TL-WR740N is ok too (~90 MBit/s 2.4 GHz).
Original firmware, as i remember, was ok too.
The only significant 2.4 wifi errors in log:

Sat Dec 17 10:41:13 2022 kern.err kernel: [   48.998741] rt2880-pinmux pinctrl: pa is already enabled
Sat Dec 17 10:56:45 2022 kern.err kernel: [   51.495537] ieee80211 phy1: rt2800_wait_bbp_rf_ready: Error - BBP/RF register access failed, aborting
Sat Dec 17 10:56:45 2022 kern.warn kernel: [   51.504984] ieee80211 phy1: rt2800_loft_iq_calibration: Warning - RF RX busy in LOFT IQ calibration
Sat Dec 17 10:56:45 2022 kern.err kernel: [   51.687605] ieee80211 phy1: rt2800_wait_bbp_rf_ready: Error - BBP/RF register access failed, aborting
Sat Dec 17 10:56:45 2022 kern.warn kernel: [   51.697054] ieee80211 phy1: rt2800_loft_iq_calibration: Warning - RF RX busy in LOFT IQ calibration
Sat Dec 17 10:56:45 2022 kern.err kernel: [   51.825633] ieee80211 phy1: rt2800_wait_bbp_rf_ready: Error - BBP/RF register access failed, aborting
Sat Dec 17 10:56:45 2022 kern.warn kernel: [   51.835081] ieee80211 phy1: rt2800_rxiq_calibration: Warning - Timeout waiting for MAC status in RXIQ calibration
Sat Dec 17 10:56:45 2022 kern.warn kernel: [   51.896097] ieee80211 phy1: rt2800_rxiq_calibration: Warning - RXIQ calibration FAIL

Is this a driver error or bad settings?

Are you in a remote, country or rural location?

Have you altered other partitions on the device?

Please provide your settings. Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless

I'm in a big apartment building in the city. There are a lot of neighbors APs here, but almost all of them are 40 MHz, and they don't interfere with my old router, if that's what you're talking about. I can send a screenshot of LinSSID if you are interested. If i changes the channel width to 20 MHz, the speed does not change at all.(PS: but i could see that my laptop was connected by 40MHz channel when AP was 40 MHz) I didn't have any problems with interfere at all with the old router.

No, but Archer C20v 1 has an unusual procedure for flashing the OpenWRT firmware. However, I think that the errors in the log mention special-purpose registers of some router chip that's do not relate to Flash.

root@varda:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'f***:****:****::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0.2'
	option proto 'pppoe'
	option username '****'
	option password '****'
	option ipv6 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

config route6
	option interface 'wan_6'
	option target '::/0'
	option source '****:****:***:***::/64'
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option country '**'
	option channel '149'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid '*****_5G'
	option encryption 'sae-mixed'
	option key '********'
	option disabled '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/10180000.wmac'
	option band '2g'
	option htmode 'HT40'
	option cell_density '0'
	option channel 'auto'
	option txpower '14'
	option country '**'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid '*****'
	option encryption 'sae-mixed'
	option key '********'