MT7620 Xiaomi miwifi mini 40MHz Wi-Fi Bug (18.06.4)

Hi guys!

When i set my 2.4hz wifi to force 40mhz, the wifi speed becomes very bad.

For example, i end up having 333KBs to copy a file storing on the router (samba). At 20hz, the speed is between 4 and 6MBs copying the same file.

For comparison, using alternative firmware (Pandorabox) OpenWrt-based, at 20hz the speed is between 5 and 8MBs, with 40Hz is between 9 and 11MBs.

NOTE: Test with 5cm distance beetwen Router and Laptop
Sorry my english...


config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10180000.wmac'
	option legacy_rates '0'
	option channel 'auto'
	option htmode 'HT40'
	option noscan '1'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key '12345678'

I think the setting is correct.

Driver for mt7620 unstable? Any solution?

Try not using auto channel? 1,6,9 options for manual

this option is for Wireless encryption method. Possible values are: none , wep , psk , psk2 .
https://openwrt.org/docs/guide-user/network/wifi/basic

No effect.

Any forced device that connects at 40hz will slow down (devices that only support 20Hz remain unreduced).

Disabling noscan (Force 40MHz mode) only has effect (regardless of whether htmode is at 20hz or 40Hz).

Note: Openwrt with basic configuration, i only add samba and ext4 packages;

ok, I edited the post

Any solution to fix this?

Please try 19.07 or snapshot build
Ref: https://github.com/openwrt/mt76/issues/302