Mt76 driver - replacement [for test]

kmod-cfg80211 already installed
i have installed libnl and so i don't think i need libnl-tiny , now i don't get the nl80211 not found warning, but still not working.

ifconfig -a 
ra0       Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@OpenWrt:~# iw phy

also only ra0 is present

Sad news, I wish it prints something.

At this point nothing more to test :frowning:


any news on that?

managed to port the driver to linux-5.4.
So far it works with its own incorporated ap-solution. Maybe we could give it another try to get it working with cfg8021. I guess that after kernel 3.x a lot has changed in the cfg8021 related stuff and that's why its not working out of the box. If you are interested I am happy to share the patches ...

yes if you can share it will be great

works on my Xiaomi R3P, there is a short instructions file included.

The fastest way to start is use mt7615 driver, it needs a little modification to compile with cfg80211. Anyway I didn't checked why is the crash

May I ask did you tested it with MT7603? Mt7603 is basically not working on 5.x kernel :slight_smile: you must know in AC2100.

nope only mt7615. I sold my AC2100, therefore no need for mt7603 any longer ...

I think the mt7615 is more stable than older generations.

After a couple of days of trying the driver I have to say that it works just so much better than the mt76. Higher speeds, better reach and smooth roaming between the 5 and 2.4 ghz bands when using the same SSID for both cards.

wait...the proprietary drivers have proper roaming support :slight_smile: ?
I know you've only tested with the 7615 driver, but in theory could we have mt7603, mt7612, mt7615 proprietary drivers with working 802.11r ?
I guess I can stop thinking about selling my mtk routers then...

Did you use the latest version from master? I think the peak throughput should be better than proprietary driver.

For me the Roaming works quite reliable between 5ghz and 2.4 on the same machine. No idea if roaming between multiple routers works and how to set it up ...
Regarding the peak throughput: on current master I get max 35 MB/s from my synology with mt76, but >40 MB/s with the proprietary driver. On linux-4.14 the speeds were better with mt76 compared to the proprietary driver, but only slightly.

I think it’s fantastic what the mt76 people achieved, but I had constant trouble with disconnected devices, unreachable WiFi printers and sound devices (which still persists in the most recent mt76 version). The proprietary driver simply just works in my set up. As soon as the mt76 works reliable for my needs I will happily switch back.


We've fixed that connection problem for mt7615. Maybe you can upgrade to the latest version and give it a try.


I just compile a new master linux-5.4.46 with the most recent mt76. Wifi speed is still lower than with the proprietary driver (most of the time in the range of 25-30 MB/s sometimes it hits 40 MB/s).

I will test it for a couple of days to see whether the disconnect issue is fixed for my network setup.

there is still a lot of interrupt errors:

root@OpenWrt:~# cat /proc/interrupts 
           CPU0       CPU1       CPU2       CPU3       
  8:     140342     140304     140287     140252  MIPS GIC Local   1  timer
  9:      21070          0          0          0  MIPS GIC  63  IPI call
 10:          0      35755          0          0  MIPS GIC  64  IPI call
 11:          0          0      38544          0  MIPS GIC  65  IPI call
 12:          0          0          0      45419  MIPS GIC  66  IPI call
 13:       5363          0          0          0  MIPS GIC  67  IPI resched
 14:          0      41900          0          0  MIPS GIC  68  IPI resched
 15:          0          0      26500          0  MIPS GIC  69  IPI resched
 16:          0          0          0      24704  MIPS GIC  70  IPI resched
 17:          0          0          0          0  MIPS GIC  19  1e000600.gpio-bank0, 1e000600.gpio-bank1, 1e000600.gpio-bank2
 19:         12          0          0          0  MIPS GIC  33  ttyS0
 21:     313662          0          0          0  MIPS GIC  10  1e100000.ethernet
 23:     106765          0          0          0  MIPS GIC  11  mt7615e
 24:     248869          0          0          0  MIPS GIC  31  mt7615e
 26:          0          0          0          0  1e000600.gpio  18  keys
ERR:       58591

while the proprietary drivers shows no errors at all, even after a week of heavy usage ..

Are these errors of any relevance for us, or just a cometic issue?

Which platform are you using? I did not see this error on my MT7622.

BTW can you revert these two patches to check if interrupt errors happen again?

Tried to revert them, but apparently a lot of the code has changed since and I can't simply revert the patches.

I have an tplink archer c2 and netgear r6220 with this family of chipset. Both of them are showing odd behavior (the tplink has unreliable wifi, the netgear keeps dropping connection and becomes unstable). I am willing/available to do some testing with the official driver if its still necessary.

Going a bit off-topic here, but… no message-signaled interrupts (yet?), @ryderlee1110…? I've been thinking of getting an MT7615 card, but I guess I'll wait. :thinking: