MT6000 custom build with LuCi and some optimization - kernel 6.6.x

Is this wired or wireless?

I think that your partition is wrong, so please flash original firmware from gl.inet and let us know the result.

The original uboot web interface is still available?

So please try also to flash original firmware from that.

yeah i ubooted to gl firmware was way worse and im back on snapshot but my device is screwed. been so many issues dont want to double post i explained and gave details here:

the issues are beyond me, its semi functioning and i took advice to contact support hoping theyll ship me a new one. ill live with a partial functioning device for now =/ thanks for help

:frowning: Hoping you didn't mention to support that you had tried to put a third-party firmware onto it. The last thing we need is for GL.iNet to start finding ways to tighten down their bootloader and such to prevent breakage of the devices they produce. This is what has caused a lot of headaches in the past for us hobbyists when manufacturers start finding ways to protect themselves from losing money, which absolutely makes business sense, but then makes it hard[er] (and in some cases impossible) for us to continue to load alternate firmware.

5 Likes

That was wired. This is wireless https://www.speedtest.net/result/i/6180893536

1 Like

nah i didnt i told them gl firmware completely broken and was debating trying to openwrt. either way ill shut up i guess no point in opening a thread over this if on one else has issue similar or knows whats wrong thx was trying to avoid another pointless thread thoguht itd be better on device thread

Great build! Strong performance and very stable. Results below are over wifi. SQM Cake provides best results rather than any of the AQL tweaks I tried myself. I'm finding with this target that throwing more work at the CPU seems to provide the best results.

Also, I'm really liking this speedtest: Internet Speed Test - Measure Network Performance | Cloudflare

6 Likes

Dear all,
My source on github 2.9.9 and 3.0.0.mtk are work in progress for latest updates on mac 6.9.9 and latest mt76.

So please use latest stable which is 2.9.2.mtk or 2.9.3.mtk

Thanks.

Now I'm abroad for 3 days as soon as I come back and I finish I let you know.

Thanks and enjoy

8 Likes

Question... any reason to run HT160 with your AQL's set where they are? 2500/2500 eats up so much bandwidth that a 2x2 AX HT80 client could achieve those speeds equally as well. Now if it's an AC client, then I see why HT160 would be beneficial.

Very nice! Thanks for sharing that speed test. It's pretty cool :+1:t2:

Here's from a run of that test just now over WiFi:

2 Likes

Excellent results on your end as well! Which settings are you using if you don't mind sharing?

In terms of wireless settings or AQL settings?

For AQL, I'm using a low/high value of 1500. I very much favor lower latency to higher throughput, so 1500 seems to perform nicely for me.

Wireless Config
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi'
	option band '2g'
	option htmode 'HE20'
	option country 'US'
	option cell_density '0'
	option channel '11'
	option txpower '6'
	option vendor_vht '1'
	option itxbfen '1'
	option he_twt_responder '1'
	option log_level '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wifi+1'
	option band '5g'
	option country 'US'
	option cell_density '0'
	option he_bss_color '30'
	option htmode 'HE160'
	option channel 'auto'
	option txpower '20'
	option itxbfen '1'
	option he_twt_responder '1'
	option log_level '1'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option key '<redacted>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option ssid '<redacted>'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option iw_qos_map_set '1,1,18,3,20,3,22,3,24,4,26,4,28,4,30,4,32,4,34,4,36,4,38,4,40,5,44,5,46,6,48,7,56,7,0,63,255,255,255,255,255,255,255,255,255,255,255,255,255,255'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key '<redacted>'
	option ssid '<redacted>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option iw_qos_map_set '1,1,18,3,20,3,22,3,24,4,26,4,28,4,30,4,32,4,34,4,36,4,38,4,40,5,44,5,46,6,48,7,56,7,0,63,255,255,255,255,255,255,255,255,255,255,255,255,255,255'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option network 'GUEST'
	option mode 'ap'
	option key '<redacted>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option ssid '<redacted>'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option iw_qos_map_set '1,1,18,3,20,3,22,3,24,4,26,4,28,4,30,4,32,4,34,4,36,4,38,4,40,5,44,5,46,6,48,7,56,7,0,63,255,255,255,255,255,255,255,255,255,255,255,255,255,255'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option network 'GUEST'
	option mode 'ap'
	option key '<redacted>'
	option ssid '<redacted>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'sae'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option ieee80211w '2'
	option na_mcast_to_ucast '1'
	option iw_qos_map_set '1,1,18,3,20,3,22,3,24,4,26,4,28,4,30,4,32,4,34,4,36,4,38,4,40,5,44,5,46,6,48,7,56,7,0,63,255,255,255,255,255,255,255,255,255,255,255,255,255,255'

config wifi-iface 'wifinet5'
	option device 'radio0'
	option mode 'ap'
	option ssid '<redacted>'
	option key '<redacted>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option network 'IOT'
	option reassociation_deadline '20000'
	option ieee80211k '1'
	option time_advertisement '2'
	option wnm_sleep_mode '1'
	option bss_transition '1'
	option encryption 'psk2+ccmp'
	option time_zone 'EST5EDT,M3.2.0,M11.1.0'
	option ieee80211w '0'
	option wnm_sleep_mode_no_keys '1'
	option proxy_arp '1'
	option na_mcast_to_ucast '1'
	option pmk_r1_push '1'
	option iw_qos_map_set '1,1,18,3,20,3,22,3,24,4,26,4,28,4,30,4,32,4,34,4,36,4,38,4,40,5,44,5,46,6,48,7,56,7,0,63,255,255,255,255,255,255,255,255,255,255,255,255,255,255'
2 Likes

Are you talking about setting an MT6000 at VHT160 vs HE160? Wouldn't a 2x2 AX client be HE80--so you would want to run the MT6000 at either HE80 or HE160?

Perhaps I'm just not clear on the question, I apologize :slight_smile:

Apologies if I was confusing. I see you’re running your 5GHZ network at HE160, but with your AQL setting at 1500/1500 is there a benefit over HE80 since it cuts into bandwidth so significantly? Do clients actually benefit? HE160 (in my experience) causes more power drain on battery clients… and involves DFS… so just wondering if the value is still there.

Hi guys, I have a quick one that I'm sure it doesn't depend on pesa's build specific, but your wireless knowledge is too precious :wink:

Yesterday I finally tested the router in "production" by switching the WiFi's name to my regular one and I noticed that many IoT/Smart devices did not connect to the 2.4 Ghz, which is mainly used by them.

It was set to WPA3, so I changed it to a mixed WPA2+WPA3. This allowed almost all devices to connect, except a couple of those (in total are 12). They all connected correctly only when I set the 2.4g network to a pure WPA2. I can grab some logs, because some WiFi errors did show up.

Is there anything else that I can do to have WPA3 enabled or should I surrender and just use WPA2?

(post deleted by author)

Mixed mode should work, but iot devices are pretty dumb and get confused by all sorts of things. If you've not already tried, the below two options in /etc/config/wireless might help. First setting make management frame protection (mfp) optional which should help with older devices. I don't think the 2nd setting is exposed via luci, but it forces mfp to enabled for SAE/WAP3, apple devices seem to have issues with WPA3 otherwise (Probably because mfp is a requirement)

  •    option ieee80211w '1'
    
  •    option sae_require_mfp ='1'
    

All my IOT devices were working with those two options and an otherwise pretty basic setup, however enabling ieee80211r (fast roaming) caused problems, so ultimately I ended up creating a new SSID for the IOT devices thats WPA2 only with no fancy features enabled, although at some point, I'll probably create a dedicated vlan and segregate them from the rest of my network...

2 Likes

@auanasgheps
This. I had an IoT device that seemed to never play with anything higher than pure WPA2. Even WPA2+WPA3 mixed mode was a mixed bag, no pun intended. In fact, the problematic device was an OLD Android phone. If it weren't a device of medical necessity for one of my loved ones, I would have just chucked it out the door and kept WPA2+WPA3 mixed.

I do have my IoT devices segregated to their own VLAN, as I also have for a Guest VLAN. The MT6000 itself has no problem with multiple SSIDs, but that's not to say there isn't a downside to having multiple SSIDs in general. Those downsides are probably outside the spirit of this thread, so I'll not delve into them here.

But with five SSIDs (2.4/5Ghz "LAN", 2.4/5Ghz Guest, and 2.4Ghz IoT) I notice no appreciable degradation.

2 Likes

Hello im using this new build 2024.07.10_r27039_6.6.36_next-r2.9.2.mtk.v1.2 with the builder add but i get kernel error.

1 Like

Greetings @pesa1234 - I see this latest build changelog does not include mwan3. Are you still planning, or interested in including that in your next (or a future) build? TIA.