I recently got an MT-6000 and I got everything all set up how I wanted besides being unable to remap the "eth1" WAN 2.5Gbe port to the lan bridge and using "lan 5" as my WAN port. I would like 2x2.5Gbe ports if possible.
These are the steps I took (config attached too)
- Changed the WAN and WAN6 interfaces to LAN5
- Removed LAN5 from the br-lan and added eth1
- Save and apply.
It applies fine but I cannot get my ISP to give it an IP address. There is no MAC address restriction or anything but even after rebooting the router and modem multiple times, letting it sit for about 20 min the other night etc... It just refuses to connect. The only thing I can think of is that the eth1 port is handled differently by openwrt (the second 2.5Gbe port is called lan1) but I am just spitballing on that one.
I have talked to someone who had the stock firmware/openwrt install and was able to do it so it doesn't appear to be a hardware limitation but I am clearly not configuring something properly.
Appreciate the help in advance, network config is below:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdea:dc29:6e61::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth1'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr '94:83:c4:a4:7e:72'
config device
option name 'lan2'
option macaddr '94:83:c4:a4:7e:72'
config device
option name 'lan3'
option macaddr '94:83:c4:a4:7e:72'
config device
option name 'lan4'
option macaddr '94:83:c4:a4:7e:72'
config device
option name 'lan5'
option macaddr '94:83:c4:a4:7e:72'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
list dns '192.168.1.151'
list dns '8.8.8.8'
config device
option name 'eth1'
option macaddr '94:83:c4:a4:7e:70'
config interface 'wan'
option device 'lan5'
option proto 'dhcp'
config interface 'wan6'
option device 'lan5'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'