MR8300 Device is not active - Qualcomm Atheros QCA9886 802.11nac

A novice here so please go easy on me.
I've just got OpenWrt 21.02.0 r16279-5cc0535800 on my Linksys MR8300 and one iface does not seem to work.
This if a fresh, first install of OpenWrt.
In syslog I see:

Mon Sep 13 16:44:50 2021 kern.warn kernel: [ 1087.281082] ath10k_pci 0000:01:00.0: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Mon Sep 13 16:44:50 2021 kernel: [ 1087.300958] br-lan: port 4(wlan0) entered blocking state
Mon Sep 13 16:44:50 2021 kernel: [ 1087.301000] br-lan: port 4(wlan0) entered disabled state
Mon Sep 13 16:44:50 2021 daemon.notice hostapd: ACS: Automatic channel selection started, this may take a bit
Mon Sep 13 16:44:50 2021 daemon.err hostapd: ACS: No available channels found
Mon Sep 13 16:44:50 2021 daemon.warn hostapd: wlan0: IEEE 802.11 Configured channel (0) or frequency (0) not found from the channel list of the current mode (2) IEEE 802.11a
Mon Sep 13 16:44:50 2021 daemon.warn hostapd: wlan0: IEEE 802.11 Hardware does not support configured channel
Mon Sep 13 16:44:50 2021 daemon.err hostapd: Could not select hw_mode and channel. (-3)
Mon Sep 13 16:44:50 2021 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->DISABLED
Mon Sep 13 16:44:50 2021 daemon.notice hostapd: wlan0: AP-DISABLED
Mon Sep 13 16:44:50 2021 daemon.err hostapd: wlan0: Unable to setup interface.
Mon Sep 13 16:44:50 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Mon Sep 13 16:44:50 2021 kernel: [ 1087.305900] device wlan0 entered promiscuous mode
Mon Sep 13 16:44:50 2021 kernel: [ 1087.357183] device wlan0 left promiscuous mode
Mon Sep 13 16:44:50 2021 kernel: [ 1087.358523] br-lan: port 4(wlan0) entered disabled state
Mon Sep 13 16:44:50 2021 kern.warn kernel: [ 1087.417358] ath10k_pci 0000:01:00.0: peer-unmap-event: unknown peer id 0
Mon Sep 13 16:44:50 2021 daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
Mon Sep 13 16:44:50 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan0 wasn't started
Mon Sep 13 16:44:50 2021 daemon.notice netifd: radio0 (9227): Command failed: Invalid argument
Mon Sep 13 16:44:50 2021 daemon.notice netifd: radio0 (9227): Device setup failed: HOSTAPD_START_FAILED

Would someone care to share thoughts on what is not working here and possible way to fix it?
many thanks, L.

I faced the same issue last week with this device (out of the box). I was able to fix this.

I tried to flash directly after booting up stock firmware, bypassing setup. It works, by I faced the wlan0 issue in Openwrt. So I switched back to stock firmware, and followed the setup plainfully. Also configure wifi. Than I flashed again Openwrt, and now wlan0 works. Make sure you setup a country and transmit power.

My guess is that the stock firmware setup and wifi configuration write wifi informations on another partition, and these informations are necessary for wifi within OpenWrt. So setting up config and wifi must be done first within stock firmware.

Hi. What exactly do you mean by "switched back"?
Thanks, L.

Okey. I did what you suggested - I rebooted to stock firmware, did reset to factory defaults there, setup all three wifi ifaces, setup time zone and flashed OpenWrt 21.02.0 r16279-5cc0535800.
All that done but I still get on that one "wlan0" fails to initiate, to start, even if it's the only wifi iface/network enabled.

Browse the EA8300 page, both devices are very close.

By "switched back" to stock firmware, I meant the recovery method to change the boot partition.

There is also a plugin for Luci which allow to choose the boot partition: luci-app-advanced-reboot

Did you perform a software or hardware reset to factory ? EA8300 page strongly advices to perform a hardware.

  • Switch and boot to stock partition
  • perform a hardware reset
  • configure completly the stock firmware, including every wifis
  • flash openwrt
  • configure openwrt.

You seem to have already performed these.
What is the stock firmware version ? Mine was 1.1.8. There is 1.1.9 available on linksys website.
I didn't plug the WAN cable in order to avoid the router to self download the new firmware.
Hope this will help ... :confounded:

most if not all radio issues seem to be directly resulting from country codes.

Use CA, no issue here and fixed others users also with similar issues.

Nothing to do with settings moving from OEM to OpenWrt, this just doesn't happen...

The goal is to fix wifi data calibration that are stored in another partition. These are not the settings used to create a wifi interface (SSID, password, etc.). Configuring with OEM fixes that, than OpenWrt find these data for itself.

Nothing to do, in my case, with "coutry code", this was set.
But a good news - in a weird way - I can report that "wlan0" is now up & running.
Nothing to do with going back to stock firmware, there doing setup, etc.. OpenWRT had a day of uptime (with broken wlan0), so next day, I went back to wifi and if I remember correctly, I did:

changed in wifi 'Operating frequency' -> ' Mode' to 'N' which in turn changed 'Width' to '20 Mhz'
'Channel' was already 'auto'
'Maximum transmit power' I had earlier set to '5dBm'

I think that was all when I applied changes and wlan0 came up.
I since fiddled with different 'Width' & different 'Operating frequency' and 'wlan0' seems to be okey with that.

What exactly brought 'wlan0' back to live I cannot programimatically confirm, which is a shame, but can confirm that having "broken" 'wlan0' re/flashing to stock doing bits there then to WRT again, was not the fix in my case.

many thanks, L.

Well, I must confess that at some point, I'm in the same case than you. I have changed and tried a lot of settings, unsucessfully. Than wlan0 went up without exactly knowing what fixed it.

Among what I have done, is going back to stock to setup wifis, and than reflash to openwrt. Ok let's assume that it is not part of the process. If someone has more experience with this device and can enlighten us ? Does stock firmware handles the ART partition for example ?

It was my first Linksys device, and I handled it a short time before giving it to a relative, so my experience is small.
Glad you fixed it, now enjoy.

Because I have two of MR8300 I kept fiddling with it and I think I have a final observations:

a) no need to do setup/config in Linksys firmware prior to re-flashing with oWRT.
b) Qualcomm Atheros IPQ4019 (wlan1 & wlan2) seems to start & operate okey withOUT "Country Code" in "Advance Settings" whereas...
c) Qualcomm Atheros QCA9886 (wlan0) seems "Country Code" is a MUST to set in order to start & run.
d) might be that the fact that "Country Code" was set on one wlanX affects other wlanXs behind the scene in a non-obvious way and only devel/hacker know exactly what goes on there.

I think bit to take out is that - "a", which is tedious part I can confirm is redundant, no need for that.

thanks, L.

1 Like

"a" means that OpenWrt can setup wifi correctly by itself, and the ART partition doesn't need any prior configuration by stock firmware.
"b" : I had no issue with ipq4019 inner wifis, they worked immediatly.
"c" agreed, kept in mind.
"d", yes also possible. As I set country code for ipq4019, there may be an inteference.
Thank you for these testings, I'll keep them in mind.
So far the device seems to work properly.

OpenWrt does not consider any Linksys partition setup, period.

I never had any radio issues and I'm in CA with country code CA.

Agreed - Linksys firmware not required and actually seems a little old.
A note from other routers like the WRT3200: You may need to forcibly set the Country code on ALL wireless adapters to the same code. Network-Wireless, Then edit each adapter, go to Advanced tab on top. The WRT3200 did not work correctly unless you set all 3 interfaces to the same country, then rebooted the router and waited for the DFS spectrum check (about 5 minutes).
FYI - I just bought a MR8300 as a replacement for WRT3200 and set it up with absolutely no issues (US country codes for all 3 wireless adapters). Took a few minutes for it to complete the DFS checks at boot.

Interesting infos. Thank you.