MR70X Fresh CLI install, Internet not working, can't install anything

I have a Mercusys MR70X. For internet, I'm using an ONT. Before I tried to install OpenWRT, I use to configure static IP for WAN with settings provided by ISP.

Today, I had first attempt at installing this firmware. I was out of patience and didn't check what default installation includes or whether or not I can pre install certain packages.

Right now I have a CLI version of installation. I can SSH into it. But I don't know how to make the internet work so that I can proceed installing the GUI. I have already configured WAN, and it looks similar to what it was on the stock router:

sroot@OpenWrt:~# ubus call system board
{
	"kernel": "5.15.150",
	"hostname": "OpenWrt",
	"system": "MediaTek MT7621 ver:1 eco:4",
	"model": "MERCUSYS MR70X v1",
	"board_name": "mercusys,mr70x-v1",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.3",
		"revision": "r23809-234f1a2efa",
		"target": "ramips/mt7621",
		"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
	}
}
root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd56:95c0:747d::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'static'
	option ipaddr '172.24.1.11'
	option netmask '255.255.255.0'
	option gateway '172.24.1.1'
	option dns '8.8.8.8,8.8.4.4'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/firewall 
config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

I also tried to revert back by reflashing it with stock firmware. But I can't download the package as it does not connects to internet. I also tried scp, but the default installation does not have that.

Is there anything missing? Please help.

already comes with the GUI ?

I noted a while after post it that I can access the web UI. But I was not able to access the internet.

I tried reverting back to the factory firmware by downloading bin file from Mercusys for specific router and router version. I used the openwrt web ui to flash the router.

After my attempt to reset the router, now I think router is dead. I spent some more time and found out that I can connect PC to the router and manually set the IP to be in the range of 192.168.1.x.

If I do that, I see this page:

I even see this:

But the router never starts in normal mode.

At this point I just want to use the factory settings. Can you point me in the correct direction?

seems you need serial to do the recovery - Debricking MR70x and reverting to OEM firmware - #20 by canadajones.

setting up openwrt in the right way should be doable though.

1 Like

How do I get firmware console access at the first place?

What is the correct way to setup openwrt though in my case?

take the device apart, and connect to the serial port.

are we talking about the install, or configuration ?

1 Like

are we talking about the install, or configuration ?

Suppose that I got the openwrt installed again. I'll still be in a state without internet as I was before trying to revert back.

I didn't find enough tutorial for this router.

the procedure would be the same for all routers.

but you need to give people some time to reply, it's not paid support with an SLA.

1 Like

Okay. It's time to get back to getting something installed on the router, either openwrt or the stock firmware.

What I already tried is using openwrt as well as the stock firmware on the page I provided screenshot of. None of them works.

I followed the link you provided and it seems I require a TTL to USB converter. I tried googling up, and I got confused because there are different kind of them. As I have very little knowledge of what I'm doing, which options I should go with?

The 1st one to the left should be good enough.

1 Like

While I wait for the interface to be received, I opened up my router to look what's inside.

I think I found out the serial ports we are looking for:

But seems like they are not labelled properly.

I have a multimeter, and I was following this video to gather some information:

While turned off, and multimeter in continuity mode: 3rd pin from the top makes a beep in multimeter.

While turned on, and multimeter in DC V mode: Ironically none of the pins says 3.3V.

  1. Pin 1: 3.21V
  2. Pin 2: 3.27V
  3. Pin 3: 0V
  4. Pin 4: 3.28V

That's confusing, because 3rd pin makes beep means it's ground? While ON, the same pin says 0V, means Rx?

serial pinout is documented in https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=47de2c686291e69afc9f443e27e1dfd11ed5fbe7

Well, can't I connect the router PCB to Raspberry Pi's GPIO pin?

If you got one.
https://elinux.org/RPi_Serial_Connection

For the Raspi update:

  • I enabled the UART from raspi-config.
  • I tried connected jumper cables to specified ports. I don't see any device getting created in /dev directory.

I also received the converter, and connected everything in order. When when I try to do minicom on the ttyUSB0, I get nothing past the initial screen. Should I expect something?

Maybe the cables are not connected on the router side? I have jumper cables going on the converter to the router.

Please suggest next steps.

The post deviated from where it started. I will start another post for this issue.

For the current post, Internet was not starting, and I bricked my router with neither OpenWrt or stock firmware.

I solved this problem by sending my router for repair. And regardless of case being opened, they sent me another router with their factory firmware.

I have installed OpenWrt again on it, and will start fresh post with fresh OpenWrt install.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.