MR33 with new U-Boot 2017.07-RELEASE

Guys, is there any information about flashing method for Cisco Meraki MR33 ?
It seems the old step-by-step doc can not be used due to new U-Boot 2017.07 version...

Check through if you haven't already.

thx, Is there any flash dump available (1G-bit NAND Flash MemoryMX30LF1G18AC) or jtag practice for the Qualcomm Atheros IPQ4029 CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d ?
Working with programmer would be the simplier method.

Yes, working with the Nand directly simpler option.

Refer to
Raspberry Pi 8-bit raw NAND flasher for the 360-Clip

Or the FlashCat

with correct TSOP adapter

1 Like

Is your supposition or you have tried one of this possibilities?

I have used SPI flash method using Raspberry Pi on Aruba AP-105 as described here

I do not have a Nand clip or device to flash at the moment

Thank you, I worked out with full flash dump. I could download wrt installed dump and upload it to the second device,
Happy New Year!

1 Like

Happy 2020 also

What specific gadget did you end up using to read the nand ?

Hi, Guys, after desoldering a nand chip I have used TL866II plus nand programmer with tsop48 socket adapter. Simply read and wrote a dump.



I am new in flash programming. Please advise me where could I download the working OpenWRT flash dump for the MR33? I suppose it is not necessary to touch the bootloader then.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.