MR33 Flashing - Not working anymore


I followed the guide at the google drive.
But, after getting everything configured, the ubootwrite is just stuck on uploading image and nothing ever happens.

Please see the attached bootlog.

I understand it is newer Uboot and firmware but just wondering if anyone has tried to flash this recently? This unit was obtained in december 2018.

1 Like

[ 0.000000] Linux version 3.14.79 ( (gcc version 4.8.3 (GCC) ) #2 SMP PREEMPT Fri Sep 28 17:12:57 PDT 2018

You're still booting Meraki firmware.

Yes, like i said i am unable to get the uboot image uploaded. The prompt is just stuck at the uploading image step and the AP just boots into the meraki image.

there is a slightly different method here: post #43 which worked for me, a couple of months ago.

Did you manage to get it flashed? I can't flash mine on the new U-boot version either.

nope, now trying to figure out the jtag method. Got the header but need to learn about arm-jtag architecture and see what i can do with that.

Did you try the method frtz linked to? I’m not sure what version u-boot was at that time so I’m not sure wherher it is worth me trying or not.

still waiting on a few components. The 1.54mm header presents new challenges as the existing jumper cables are too big to connect to that header, so need different wires etc. and hence taking more time

Awesome, keep me/us updated!

any lock with the Uboot ...?
need help please
"TypeError: unicode strings are not supported, please encode to bytes: 'mw 80500000 0\n'" error

hi,did you flashing you mr33 to openwrt already?

i need run openwrt on my mr33,but i dont know how to do,can you help me?

thank you very much

Nope, I have got all the things now, but I have just moved house 1 week ago and all of my stuff is still in garage. It's going to take a while on my end, so if you find a way, do let me and others know as well.

hi,i had a new New progress about how to flash mr33 to openwrt.

i got a file named "",i think this file can let my mr33 got Root permissions.

but this file report Errors when run in UBUNTU OS

".py"file is python Script,i dont know how to debug it.

could you give your IM contact information,"wechat" or "telegram"or "whatapp",i need to talk with you for falsh mr33.

give me message on forum

Guys, sorry, but where is the jtag header in device (MR33)?

From the pictures on the Wiki page, either J5 or J13, the WIki page doesn't say.

I would surmise J5, given its design and proximity to the CPU.

It sometimes hidden under sticker


Mark is right.
It is under the sticker. Meraki are being sneaky.

1 Like

right, thx

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.