MR16 failing to pass traffic across br-lan

Hi all, first post, though I was at one time an extremely avid user of Openwrt (think WRT54G days)

I've come into possession of an MR16 meraki (Cisco) ap, and flashed it with the 17.01.4 firmware.

Everything is "working" as in I can associate to the wireless, and connect to the web interface either via the wireless, or the lan port.

I have it plugged into my main router which is on IP 192.168.107.1 and when I associate with the wireless I cannot pass traffic to the main router. (Packet captures seem to agree with this statement)

I have tried all sorts of settings and (of course read and tried all of this https://wiki.openwrt.org/doc/recipes/dumbap)

my /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1d:8c1f:d42c::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.107.1'
        option dns '192.168.107.1'
        option stp '1'
        option ipaddr '192.168.107.3'
        option ifname 'eth0'
        option broadcast '192.168.107.255'
        option macaddr '00:18:0A:82:29:C5'

my /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:11.0'
        option htmode 'HT20'
        option country 'US'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid '123479876'
        option encryption 'psk2'
        option key 'code'
        option network 'lan'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:12.0'
        option htmode 'HT20'
        option country 'US'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid '123479876'
        option encryption 'psk2'
        option key 'code'
        option network 'lan'

I'm at a loss as to why it won't pass traffic. I've plugged the ethernet cord directly into my PC, and traffic is passed just fine, so I know the routing and firewall config is functional. There is also another (ancient 10.03.1) AP that I have plugged into the same port and it is also fully functional.

Any idea what else may need to be changed in order to get this to work?

Regards,
Chance

It would seem that ((some)) traffic is making it through the AP as I believe some of these devices are associated to the 2.4Ghz radio.

Here is a 2 second packet capture from the interface of the main router.

23:31:01.776897 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 314
23:31:01.776972 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 314
23:31:01.777851 IP 192.168.107.1.67 > 255.255.255.255.68: UDP, length 300
23:31:01.777860 IP 192.168.107.1.67 > 255.255.255.255.68: UDP, length 300
23:31:01.924395 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 548
23:31:01.924445 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 548
23:31:01.925186 IP 192.168.107.1.67 > 192.168.107.72.68: UDP, length 300
23:31:02.314018 IP 192.168.107.3.80 > 192.168.106.77.58417: tcp 0
23:31:02.314392 IP 192.168.106.77.58417 > 192.168.107.3.80: tcp 0
23:31:02.455895 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 548
23:31:02.455945 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 548
23:31:02.456680 IP 192.168.107.1.67 > 192.168.107.74.68: UDP, length 300
23:31:02.496856 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 308
23:31:02.496884 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 308
23:31:02.644846 IP6 fe80::92e7:c4ff:fedc:6e9b > ff02::2: ICMP6, router solicitation, length 16
23:31:02.644966 IP6 fe80::92e7:c4ff:fedc:6e9b > ff02::2: ICMP6, router solicitation, length 16
23:31:02.690985 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 300
23:31:02.691013 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 300
23:31:02.691639 IP 192.168.107.1.67 > 192.168.107.87.68: UDP, length 300
23:31:02.764051 STP 802.1d, Config, Flags [none], bridge-id 7fff.00:18:0a:82:29:c5.8001, length 43
23:31:02.929731 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 308
23:31:02.929785 IP 0.0.0.0.68 > 255.255.255.255.67: UDP, length 308
23:31:02.936534 ARP, Request who-has 192.168.107.61 tell 192.168.107.1, length 28
23:31:02.936550 ARP, Request who-has 192.168.107.61 tell 192.168.107.1, length 28
23:31:03.314056 IP 192.168.107.3.80 > 192.168.106.77.58417: tcp 0
23:31:03.314525 IP 192.168.106.77.58417 > 192.168.107.3.80: tcp 0
23:31:03.386821 ARP, Request who-has 192.168.107.1 tell 192.168.107.74, length 46
23:31:03.386844 ARP, Request who-has 192.168.107.1 tell 192.168.107.74, length 46
23:31:03.386990 ARP, Reply 192.168.107.1 is-at 02:9f:95:7a:7a:00, length 28
23:31:03.480658 IP 192.168.107.72.51392 > 192.168.107.1.53: UDP, length 40

Though nothing is able to connect to the internet even though the firewall service is disabled on the MR16.

i have had a deployment with 8 mr16's as AP and mesh. great radios.
did you set a mac addfress for the mr16 by writing to the mtd5 partition?
have you tried disabling ipv6, and spanning tree protocol?

To close the loop, the mac was not properly set. After setting it with the instructions in the link below I am all set.

https://wiki.openwrt.org/toh/meraki/mr16