Moving IGMPPROXY to a different VLAN

Hi,
I've got a 5 port Ubiquity Er-x running OpenWRT.
From my understanding the switch in the ER-X doesn't support IGMP Snooping. Hence when I'm watching my BT Sport IPTV, the whole network is flooded with multicast traffic. Not a big problem- but I'd like to put the IPTV into a different VLAN on its own to isolate the multicast traffic.
I've patched the IPTV box straight thru to the ER-X Port 3 (Eth 2). Setup a separate VLAN on that port. Created a new interface call 'laniptv', put that into the LAN Zone with DHCP
The IPTV box picks up its new IP Address in the 192.168.2.x range (Lan is 192.168.1.x).
Internet access is ok.
I've modified the igmpproxy config file (see below). Restarted the IGMPPROXY service. No multicast??
If I put the eth2 back into VLAN 1 (Lan) and change the IGMPPROXY from laniptv to lan all works ok again once I restart the IGMPPROXY service.

Any ideas how to change the VLAN for IGMPPROXY??

config igmpproxy
	option quickleave 1
#	option verbose [0-3](none, minimal[default], more, maximum)

config phyint
	option network iptv
	option zone wan
	option direction upstream
	list altnet 109.159.247.0/24
	list altnet 172.18.0.0/22

config phyint
	option network laniptv
	option zone lan
	option direction downstream

Managed to get it working myself :slight_smile:

  1. I hadn't bridged the laniptv interface
  2. When I created the laniptv interface I used caps- LANIPTV
  3. When I manually edited the /etc/config/network to change the interface to lowercase 'laniptv' ,I lost all the DHCP info - set this back up

So I've now got a working BTTV Youview box on VLAN 4 (aka laniptv), no multicast traffic on the normal Lan.
Remember to restart the IGMPPROXY service each time you make a change to the /etc/config/igmpproxy file.

config igmpproxy
	option quickleave 1
#	option verbose [0-3](none, minimal[default], more, maximum)

config phyint
	option network iptv
	option zone wan
	option direction upstream
	list altnet 109.159.247.0/24
	list altnet 172.18.0.0/22

# config phyint
#	option network lan
#	option zone lan
#	option direction downstream

config phyint
	option network laniptv
	option zone lan
	option direction downstream
config interface 'laniptv'
	option ifname 'eth0.4'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option broadcast '192.168.2.255'
	option netmask '255.255.255.0'
	option type 'bridge'
config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option ports '6t 2'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.