Move from nanoPI r2s to NUC

I am using the nanoPI as my main router. Now I want to move to a Intel NUC with an extra ue300 adapter. LAN is in the NIC from the NUC and WAN in the adapter.
My settings in etc/config/network in the Pi is:

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fdb9:3209:03e7::/48'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'
	option device 'eth1'
	list dns '192.168.1.5'
	list dns '172.30.32.1'

config interface 'wan'
	option proto 'dhcp'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option device 'eth0.300'
	option peerdns '0'

config interface 'wan6'
	option device 'eth0.300'

I've installed Openwrt to the NUC and I am able to boot and with winSCP I see this network file. In LuCi i've made a WAN port. But after copie and paste (where I don't change the name of the device), I don't get internet. I am using a provider where I need to connect with VLAN300. Can anybody help me with the correct network setting?

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth0'
	option force_link '1'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

Under config interface 'wan' change option device 'eth0' to option device 'eth1.300'. Then restart the network (/etc/init.d/network restart).

2 Likes

ifup wan will do too :slight_smile:

2 Likes

Thanks for your quick reply! I've changed it to:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'eth1'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
        option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'
	option device 'eth1'
	list dns '192.168.1.5'
	list dns '172.30.32.1'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth1.300'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

Is this the correct one? Or can you change this for me?

Why did you change option name 'br-lan' to option name 'eth1'?

Why did you change option device 'eth0' to option device 'eth1'

Is your UE300 adapter working within OpenWRT?

I use a custom built in where the kmod-usb-net-rtl8152 is installed. I read the UE300 adapter uses this. How to check if this is really working?

So this is the good config?

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'wan'
	option proto 'dhcp'
	option device 'eth1.300'
	option force_link '1'
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

ip link; ip addr; ip ro
And compare the mac address with the IP it got.

Thanks all, it works!
Is this possible as well?

I now have the router on a NUC and Home Assistant on a PI4.
Is it possible to have both Openwrt ánd HA on the same NUC with Proxmox?
On HA I have the DHCP server in Adguard, filtering ads on my local network.
Beside that I have DuckDNS and Wireguard configured, so when I am outside with my phone I don't have ads either.