Mounting Issues

Hi all,

as I am new on this forum and also a newbie regarding OpenWRT I hope you can help me out as I am lost right now.

I use OpenWRT with a Zappiti Duo 4K HDR media player which has two 3,5" HDD slots with it and is based on a Realtek RTD1295.

So far I only needed OpenWRT when re-starting the Zappiti because it sometimes lost the correct mounting paths in Samba which lead to the fact that I could not access to one or both HDDs inside the device via home network (Desktop PC, Laptop via Windows Explorer). So normally I than went to NAS Services --> Samba and manually corrected the mounting paths. That was not prefect but it worked.

But now I have an issue which I cannot solve as I just have access to the left HDD slot, means if I switch the HDDs, just the left slot is working. And than I think I made it worse :frowning:

Some information in advance:
Firmware Version
OpenWrt Chaos Calmer 15.05.1 / LuCI QA170623_Kylin_2017-08-21_SQA_Dailybuild_2in1_NAS-1-gdc12a34 Release (git-17.233.32017-dc12a34)
Kernel Version

What I did so far:

  • when above mentioned corrections did not work I checked System --> Software and thought "maybe removing mount-block package and re-install it". I did that but under "Available packages" I just found a block-mount package. Maybe this was already the first failure. Anyways, I do not exactly remember if it was the same before I did the exchange of the packages, but under Disk Management just one HDD is shown (left slot) and also under Mounting Points I just have this one HDD.
  • so I switched the HDDs and wrote down the UUID of both so, and that was the plan, I can add the mounting point for second HDD manually. But that did not work too.
  • two days later I decided to remove block-mount again and re-install it and not checked the available packages again in advance. After I removed it I discovered that block-mount is not available in the packages list and so the option System --> Mounting Points is gone :confused:

So actually I do not know how to proceed. I would like to reset the whole OpenWRT to the point when I bought the device, but via Zappiti Factory Reset (has Android as OS) that did not work. This was confirmed by an online help forum and there they mentioned a link which leads to a dead end. So I do not know how to get the point where all worked fine respective what to do that all works again.

I hope that you experts here can help me out :slight_smile:
Thanks to all in advance.

If you need more information please let me know. I will fully assist.