Motion on 19.07 : ffmpeg_global_deinit: No ffmpeg functionality included```

Hello, and thanks for helping.

Installed 'motion' in my 19.07 router. And then also the version of ffpmeg in the repository.

I start 'motion' in shell and get this, meanwhile, nothing shows up on the browser.
The 'motion' configuration file is at "/etc/motion.conf" not as listed below " /etc/motion/motion.conf" This could be part of the problem, but I never moved the file. I have /overlay on USB, if that makes a difference.

Thanks for your help.

root@OpenWrt:~# motion
[0:Unknown] [ALR] [ALL] conf_load: could not open configfile /etc/motion/motion.conf: No such file or directory
[0:Unknown] [CRT] [ALL] conf_load: No config file to process, using default values
[0:Unknown] [NTC] [ALL] motion_startup: Using default log level (NTC) (6)
[0:Unknown] [NTC] [ALL] motion_startup: Logging to syslog
[0:Unknown] [NTC] [ALL] motion_startup: Motion 4.2.2 Started
[0:Unknown] [NTC] [ALL] motion_startup: Using default log type (ALL)
[0:Unknown] [NTC] [ALL] motion_startup: Using log type (ALL) log level (NTC)
[0:Unknown] [NTC] [ENC] ffmpeg_global_init: No ffmpeg functionality included
[0:Unknown] [NTC] [ALL] translate_init: Language: English
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[0:Unknown] [NTC] [ALL] main: Waiting for threads to finish, pid: 1865
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [NTC] [ALL] mlp_capture: Video signal lost - Adding grey image
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
[1:Unknown] [WRN] [ALL] mlp_retry: Retrying until successful connection with camera
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Motion thread 1 restart
[0:Unknown] [NTC] [ALL] motion_start_thread: Camera ID: 0 Camera Name: (null) Device: /dev/video0
[1:Unknown] [NTC] [ALL] motion_init: Camera 0 started: motion detection Enabled
[1:Unknown] [NTC] [VID] vid_start: Opening V4L2 device
[1:Unknown] [NTC] [VID] v4l2_device_open: Using videodevice /dev/video0 and input -1
[1:Unknown] [ALR] [VID] v4l2_device_open: Failed to open video device /dev/video0: No such file or directory
[1:Unknown] [ERR] [VID] vid_start: V4L2 device failed to open
[1:Unknown] [WRN] [ALL] motion_init: Could not fetch initial image from camera 
[1:Unknown] [WRN] [ALL] motion_init: Motion continues using width and height from config file(s)
[1:Unknown] [NTC] [ALL] image_ring_resize: Resizing pre_capture buffer to 1 items
^C[1:Unknown] [NTC] [ALL] mlp_actions: End of event 1
[1:Unknown] [NTC] [ALL] motion_loop: Thread exiting
[0:Unknown] [NTC] [ALL] main: Threads finished
[0:Unknown] [NTC] [ALL] main: Motion terminating
[0:Unknown] [NTC] [ENC] ffmpeg_global_deinit: No ffmpeg functionality included```

Patented functionality is not part of the binary distribution, if you need it, you'll need to build from source and enable BUILD_PATENTED.

@slh for the very talented user, your response is a breeze. But for me, after banging my head against the wall, I still don't get what you're driving at. Can you please drop it down more than a few notches, if you can. I simply want to plug in a USB camera to motion and see the video on my browser, going to the local IP. That's all. Thanks!