More Vlan Id's then philically available ports

Good evening,

I flashed my Hootoo HT-05 router with the openwrt firmware. So far so good, I can connect by wifi however my wan connection doesn't get an ip adres. Phisically there is also a problem with the amount of internet ports, there is only one port but I can see Port 0, 1, 2, 3, 4, 5, CPU, 7
The Wan cable is connected in port 4.

Anyone an idea?

Use the preformatted (</>) button and post the contents of your /etc/config/network (after "hiding" any sensitive data). That will have most of the information for people to understand your device and its configuration.


1 Like

Thank you for your reply however after a telnet command I get this message: "telnet
Connecting To not open connection to the host, on port 23: Connect failed" so I don't know how to retrieve this info. Any idea how to solve this?

Telnet was disabled because it is insecure. Use ssh instead. On Windows, you can use PuTTY.
To copy the file, use scp or WinSCP.

1 Like

Thank you for supporting a noob :slight_smile:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fdf1:ba02:42ce::/48'

config interface 'lan'
	option ifname 'eth0.1'
	option type 'bridge'
	option _orig_ifname 'eth0.1 wlan0'
	option _orig_bridge 'true'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config interface 'wan'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option hostname 'Openwrt'
	option ifname 'eth0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 4t 5 6t 7'

Kind regards,


You want to connect all LAN clients using wireless, and the single physical ethernet port is dedicated to WAN, right?

Remove the ifname. LAN has no physical ports, only wireless.

Remove the tagging from port 4 (WAN port). Some providers do require a VLAN tag, but it would be different from VID 1.


Set the WAN ifname to eth0.1.
(thank you @mk24)


The chip used in the router has 5 Ethernet outputs from the switch section of the chip. But on pocket routers to save space and cost it is common to only connect one or two to a physical port. The other ones are left unconnected at the chip pins and can never be used for anything.

Unless you have VLAN capable equipment on the other end of the cable, you have to choose to dedicate the single Ethernet port to either LAN or WAN.

It starts out being attached to the LAN so you can log in to the router and configure it. After you bring wifi up on the LAN then you can disconnect the Ethernet and log in by wifi then move the Ethernet port into the WAN network so you can connect it to a modem and on to the Internet.

With the switch configuration posted there is a single VLAN number 1, the CPU is tagged on it, and the single external port is untagged. Thus the only active link into the CPU is eth0.1. Set the WAN network to that and detach everything else from eth0.

You can identify for sure which switch port number is the Ethernet jack by running swconfig dev switch0 show with a live Ethernet cable plugged in, and again with it unplugged, to see which port loses its connection. The CPU port is always connected.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.