Module tries to compile with wrong kernel version?!

I have a luci app in a feed. To install everything, I just copied in the feed and include it in the Makefile.
Suddenly, while some module is building, it access linux-4.19.88 (does not exist) and not linux-4.19.86. It would be much easier, if it just would use the symlink linux that is also in the directory and always maps to the correct one.

make[2]: Entering directory '/home/XXX/openwrt/package/kernel/linux'
can't open file '/home/XXX/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.19.88/.config' at /home/XXX/openwrt/scripts/ line 32.
grep: /home/XXX/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.19.88/modules.builtin: No such file or directory
ERROR: module '/home/XXX/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-4.19.88/drivers/md/md-mod.ko' is missing.
make[2]: *** [modules/ /home/XXX/openwrt/bin/targets/x86/64/packages/kmod-md-mod_4.19.88-1_x86_64.ipk] Error 1

I have no idea, why the wrong kernel version is used. :confused:

Oh, contains LINUX_VERSION-4.19 = .88. Hmmm, so actually I have the wrong kernel version while building?

The x86 target has KERNEL_PATCHVER:=4.19. Where is the .86 specified?


make target/linux/clean && make target/linux/compile

But something is strange. The kernel config file that drops out of make menuconfig is not enough? I still had to select one option manually...

make clean exists to be used...



It takes so long. :confused: But yeah, I will do this more frequently. Thanks! :slight_smile: