Modem has internet but Router doesn't

Hello,
I have a zyxel vmg4005-b50a modem, and connected to it is a Netgear AC2000/AC124 router running the current snapshot for it.

The modem can ping sites, but from the router or anything connected to it I can't. The router worked fine when plugged into to the lan port of the old modem/router combi which i replaced with the current because of a new isp.

The router also gets a dhcp lease from the modem (in that wan interface) but i can't ping anything from it. However, it does resolve the hostnames to ip adresses when I ping e.g. google.com.

Wireless itself works fine.

Thanks for your help

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid ''
        option encryption 'psk2'
        option key ''

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option encryption 'sae'
        option key ''
        option ieee80211w '2'
        option ssid ''

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'ap'
        option ssid ''
        option key ''
        option encryption 'sae'
        option ieee80211w '2'
        option network 'lan'
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdb5:3f67:e1fc::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option type 'bridge'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'