Modem configuration for ADSL2+

Try modprobing clip instead of ipoa.

It say clip is loaded however IPoA still don't show up

placing code / command line on separate line makes it easier to read

# opkg files kmod-ipoa .

I configured my DSL section in Network -> Interfaces as you told me to do.
My country is France so my Annex is A (Annex A).

My IP is indeed a static one.

In interfaces WAN I put static, I put all the info as you told to me with static ip configuration (and everything is correct, my IP, the subnet, gateway etc)

I have plugged my RJ11 cable and nothing work, my DSL status in Status -> Overview, show the DSL line as "down"
I just read this tutorial and I may need to put my modem in bridged mode but I don't how to do

Some other country may use Annex A like Romania, Moldova, Spain also Ireland but not all ISP

Please help :sneezing_face:

Well as it turns out I was partly correct and partly wrong about the configuration. As you have a static IP over ATM line you neex to install ipoa package from OpenWrt repository. Setting a static IP ON WAN will not work because you need to dial into your ISP network through the phone line just like pppoe but instead of the dynamic IP you get a static one. You may also need your username and password for this. I need to look for some info about Ipoa so I'll get back to you later and in the meantime try to download the ipoa/ipoatm pkg.

Edit: I am using self-compiled firmware from OpenWrt source and right now I cant install kmod packages. You'll need to install the pkg and provide screenshots so I know what to tell you.

opkg update
opkg install kmod-ipoa
1 Like

Here some info : (but this is in french)
mine is "FREE dégroupé" aka "dégroupé"

I'm 99% sure that for IPoA authentication process I don't need a username and a password just a MAC address

I already installed the kmod-ipoa package (see the post history in this topic, we have already installed this package :slight_smile: )

Look this one they also mention using static IP for using a custom modem with my ISP:

May I ask you how did you find all these info you told me in your first post ?

I dont really know how it works, I have never used it myself. If I could install the package I would provide more details on how to use it.

If you have the package then LuCI should have the correct protocol in place. Just go to the WAN interface and edit it and choose the IPOA protocol instead of the Static one. I am not sure how it will display in there. Then choose change protocol and after that if you dont know how to proceed then please provide screenshots.

They are also using VDSL instead of ADSL (which I have), not sure if you have VDSL or ADSL.

Years of experience I guess :slight_smile:

1 Like

I have blanked some of my personals information like my IP and MAC address etc thank you for help :slight_smile:

How can I put this DSL to UP and not DOWN ?

As I told even after IPoA package install I still don't see any new protocol

I think you dont have ADSL line plugged into W8980 at the moment and this is why it shows DOWN status in DSL. Anyway I think there is no LuCI support for IPoA in OpenWrt or so it seems to me (I could be wrong) because when you list luci-proto you only get this:

opkg find luci-proto*
luci-proto-3g - git-19.086.62748-9dd2927-1 - Support for 3G
luci-proto-hnet - git-19.086.62748-9dd2927-1 - Support for hnet
luci-proto-ipip - git-19.086.62748-9dd2927-1 - Support for IPIP tunnels (IPv4-in-IPv4 RFC2003)
luci-proto-ipv6 - git-19.086.62748-9dd2927-1 - Support for DHCPv6/6in4/6to4/6rd/DS-Lite
luci-proto-ncm - git-19.086.62748-9dd2927-1 - Support for NCM
luci-proto-openconnect - git-19.086.62748-9dd2927-1 - Support for OpenConnect VPN
luci-proto-ppp - git-19.086.62748-9dd2927-1 - Support for PPP/PPPoE/PPPoA/PPtP
luci-proto-pppossh - git-19.086.62748-9dd2927-1 - Support for pppossh
luci-proto-qmi - git-19.086.62748-9dd2927-1 - Support for QMI
luci-proto-relay - git-19.086.62748-9dd2927-1 - Support for relayd pseudo bridges
luci-proto-vpnc - git-19.086.62748-9dd2927-1 - Support for VPNC VPN
luci-proto-wireguard - git-19.086.62748-9dd2927-1 - Support for WireGuard VPN

It doesnt list IPoATM so I think this is the reason why you dont see a protocol in LuCI and unfortunately there seems to be no documentation about it so maybe some of the developers can provide more information on how to set it up through SSH within network config.

For now you can try this to be able to use internet without double NAT issues.

Btw can you post a screenshot with all the protocols available in WAN interface? Just click on the drop-down menu and grab a screenshot of the protocols listed.

1 Like

Change the Wan protocol in your fourth screenshot

1 Like

Thank you now we know why IPoATM/IPoA don't show up in luci :slight_smile:

I think it should be possible to use ipoa through network config but there's no documentation about it. Create a post in the developers section and ask for ipoa config and someone maybe able to help you there.

1 Like

Yes but what protocol should I choose ? There should be a way to use IPoA because IPoA is used in many country as I told before

you might need to talk to your ip first to find out what settings to use

Make sure to get your modem out of Down and into Showtime first, without DSL sync it does not really matter what you try in higher layers....


I don't know how to put my DSL line to "UP", it always stay to down. I have tried to connect the RJ11 cable and even to reboot but nothing happen

What should I do to put DSL into normal state ??

root@OpenWrt:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          
ATU-C System Vendor ID:                   
Chipset:                                  Lantiq-VRX200
Firmware Version:               
API Version:                    
XTSE Capabilities:                        , , , , , , , 
Line Mode:                                
Line State:                               DOWN [0x200: silent]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 0
Errored seconds (ES):                     Near: 0 / Far: 0
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 51522798 / Far: 51522797
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L3 - No power
Latency [Interleave Delay]:               0.0 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 0 b/s / Up: 0 b/s
Line Attenuation (LATN):                  Down: 0.0 dB / Up: 0.0 dB
Signal Attenuation (SATN):                Down: 0.0 dB / Up: 0.0 dB
Noise Margin (SNR):                       Down: 0.0 dB / Up: 0.0 dB
Aggregate Transmit Power (ACTATP):        Down: 0.0 dB / Up: 0.0 dB
Max. Attainable Data Rate (ATTNDR):       Down: 0 b/s / Up: 0 b/s
Line Uptime Seconds:                      0
Line Uptime:                              down

dsl_control is enabled in startup

Are you sure that you have Annex A and not Annex B? I think you should try to change the ADSL mode to Annex A+L+M and then reboot the router and connect the line and see if it works. If it still doesn't work then change to Annex B and reboot the router again. Also try to uss auto values wherever you can.

Edit: So while looking for documentation I came across PPPoA and it seems that in this mode you need to remove the VCI and VPI values and config altogether to make it work (I'm not sure if it is entirely accurate). Could this also be the case for IPoA?

Yes this is a Annex A modem because where I brought it they say explicitly it's a annex A modem

Your dsl status says your line is silent.

You need to do some toubleshooting first
Check with your ISP that your line is active.
Do the usual like checking ADSL filter, trying different phone sockets and use a different rj11 cable etc.
Ask again your ISP what settings you need to use.
Try a different modem if you can.

Look this one they also mention using static IP for using a custom modem with my ISP:

These instructions look quite involved have followed all the steps. Especially the one about cloning the MAC address.