Mod_openssl for lighttpd [mips_24kc]

I was trying to enable TLS/SSL in Lighttpd config and got the following error:

--Warning: please add "mod_openssl" to server.modules list in lighttpd.conf.  A future release of lighttpd 1.4.x *will not* automatically load mod_openssl and lighttpd *will not* use SSL/TLS where your lighttpd.conf contains ssl.* directives.
--(plugin.c.229) dlopen() failed for: /usr/lib/lighttpd/mod_openssl.so Error loading shared library /usr/lib/lighttpd/mod_openssl.so: No such file or directory
--(server.c.1141) loading plugins finally failed

There is no mod_openssl in the library folder. Thus adding "mod_openssl" to server.modules list in lighttpd.conf also failed.

(plugin.c.229) dlopen() failed for: /usr/lib/lighttpd/mod_openssl.so Error loading shared library /usr/lib/lighttpd/mod_openssl.so: No such file or directory

root@GL-AR150:/~# ls /usr/lib/lighttpd/
mod_access.so      mod_cgi.so         mod_dirlisting.so  mod_expire.so      mod_fastcgi.so     mod_indexfile.so   mod_proxy.so       mod_staticfile.so

I then tried to install the module but couldn't find in the repository. I am using OpenWRT 18.06, Package architecture: mips_24kc and Lighttpd version: lighttpd/1.4.48 (ssl)

I am surprised to see ssl is mentioned on the version info. Am I doing something wrong?

Here is my config file:

$SERVER["socket"] == ":443" {
    ssl.engine                  = "enable"
    ssl.pemfile                 = "/etc/lighttpd/ssl/domain.pem"
    server.document-root = "/www/" 	
}

Any help will be appreciated. :slight_smile: