MochaBin-5G @ KickStarter

Another chance to get one MochaBin at Indiegogo !


Hey, what nonsense facts? I would like to argue about it more. Could you provide your point of view? What did I say wrong? Feel free to reach Marvell about it. We got it as official information that the Armada series are dropped out, and I provided it as proof that A7040 is not recommended for new products. That was also confirmed by @robimarko in this thread.

Yeah, some manufacturers have it in stock, and they need to sell it. Because they prepared HW schematics, bought components, created a prototype and ran mass production, and didn't want to bear losses.

We are using their products that is indeed true. We are still quite satisfied with Marvell Armada 385, which we use for Turris Omnia routers, but on the other hand, there are still issues with Marvell Armada 3720. Just take a look at the problems that Marvell ESPRESSObin has, and we also have it for Turris MOX. Even we opened several tickets to them, but we ended up that Marvell would not provide any support for it. So we tried to fix issues in the kernel ourselves. It is still not enough. I can speak about missing PCI MSI and Multi-MSI interrupts necessary for using AX Wi-Fi cards. PCI driver aardvark itself is questionable, too, as there was discussion about removing it from the kernel.

Even without missing documentation for A3720, our kernel guys are doing their best as much as they can to improve the state of armada-37xx in kernel in all the things I mentioned even in cpufreq. Sometimes it is hard to get a reply in such cases as this one.

Just take a look, who is trying to have better support for it in the kernel, and you would be surprised. :wink:
Of course, we reached other manufacturers, but it is hard to get chips in small quantities and with good specifications. So, yes. We will be using Marvell in our new products as well.

Well, hopefully, you will enjoy MochaBin-5G as you seem to be interested in it. I wish you luck.

Why shouldn't A7040 be used in new designs?
It will be manufactured and sold for years to come, the feature development for it has stopped for Marvell SDK but that means nothing for anybody else.
I would have preferred A8040 at least because of SERDES lanes so there wouldn't have to be more compromises, but its not like anybody asked.

I agree that kernel support from Marvell has been really bad, especially for A3720 which has been really riddled with bugs (I have to support Espressobin Ultras, so I know the pain), and it's mostly been Turris guys trying to fix it.
This is the classic issue when you only care about your SDK and that's it.
A3720 CPUFreq scaling is still ignored by Marvell.

The issue is that other vendors are even worse, there you can't even get this level of docs, have you ever tried working on QCA?

1 Like

Well, you should ask Marvell about it. I just know that Marvell admitted publicly that A385, A3720, A7040, A8040 ended. They were removed from the Marvell website, so you could not find them even listed there.
And what I could add to 7040 is that Marvell labeled it as "Not recommended for new products".

I doubt it will be manufactured anymore due to chips outages, etc. They just want to get rid of what they have left in the warehouse, and that's it.

I assume they want to move the market to Octeon TX2 instead, but they have a ton of users of all of the SoC-s you listed.
For example, currently, all of the DENT Prestera switches use the A7040 + A385 combo, I kind of doubt this will get updated anytime soon.

I deal with ODM-s regularly and they haven't mentioned that they cant get the SoC-s, they are having issues with pretty much anything else though.

BTW, I am just working on fixing the CN9130-CRB support that's upstream as its completely broken currently.

We got one development sample with CN9130, too! :wink:

Then you are dealing with the same issue as me, I even sent out 2 patches upstream to even get the GPIO controller enabled but nobody has bothered to look at it so far.
I have 4-5 more in queue to get the SD slot, switch, SFP etc working.
U-boot support is broken for MMC completelly.

Take a look also at simple user I am, without no business nor paid interest but trying to help at freetime, to contribute on resolving such issue…

Sure you’ll be surprised, also…

@erdoukki @robimarko I got a Mochbin Dev Board running OpenWRT SNAPSHOT on it now.
I would like to add some packages to the image to run it as the www facing router of hardware DMZ.

Interested in learning how far you can push it to run OpenWRT with additional useful services as a powerful SOHO router?
I would create a new topic to go into details (internet in countryside France is horrible, so building imagebuilder env. gonna take me some while=

1 Like

A little more,
More soon...
Stay tuned !

Hello, I am trying to build GlobalScale u-boot.
Maybe this will be useful to someone.

I want to load efi into it as it doesn't work out of the box right now.

If any idea?

@S199p.Wa1k9r thanks for sharing your work !

I was asked already about this, I will take a look at your work

I have made a quick post about my pasts notes on ARM64 uefi boot on EspressoBin.
They may help for MochaBin and also may work with factory u-boot.


I still managed to install FreeBSD 13.1-RELEASE
on MOCHAbin, for this you have to build EDK2 UEFI.

Here's what came out, it's dmesg

While PCIe and Ethernet do not work.

This is a great board for OPNsense.
What do you think about this?
How to make Ethernet work?

Hmm I just received the mochabin, I wonder would there be a way to increase space on the opkg manager?

At the moment I did checked some ways of doing it but it does make it complicated as most is done via linux.

Is there maybe a tool to increase the firmwares img size and then manage partitions like partmgr for windows?

From my understanding this is what I need to do in order to have more space?

Hey guys,

does anyone know how I can build a new mainline kernel for this device? Doesn't have to be 6.2, but 5.15 would be really nice as I am planning on doing a deep dive into nftables on RHEL. But unfortunately I always get problems with the switch chip not being able to initialize.+

I already opened another thread here. I really hope someone can assist me!


@modzilla - in the future, please do not cross-post. I've left this one since it does point to your other post (which now has some answers and thus could be useful for future readers), but in general it is best to stick to a single thread. Thanks!