Mixing 802.11n and 802.11ac on 5GHz

Sorry for the noob question here. Despite of having a fair understanding and being using OpenWRT for quite some time, I now have a noob question... :slight_smile:

I have always configured my 5Ghz radio as "AC" only (VHT80), but now I have to support an old MacBook Air that has only 802.11n support.

The first thing I've tried was changing htmode to "VHT40". But per documentation this seems to be 802.11ac only and the old MacBook was not able to connect to the 5Ghz band (2.4Ghz is connecting OK but it has too much interference where I live).

Then I changed htmode to HT40 and the old MacBook connected successfully. But with this all 802.11ac clients now are connecting in 802.11n mode as well (no more 802.11ac).

I searched online and in the documentation and I was not able to find a clear answer about which configuration I should use to support mixed 802.11n and 802.11ac (@40Mhz) in the 5GHz band.

Below is my current "/etc/config/wireless" configured with HT40 which is allowing the 802.11n client to connect to the 5GHz radio but seems to downgrade all 802.11ac clients to 802.11n speeds.

Any advice would be greatly appreciated. Thanks!

root@ap3:~# cat  /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'BR'
        option cell_density '0'
        option channel '36'
        option htmode 'HT40'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'dshome5ghz'
        option encryption 'psk2+ccmp'
        option key '****'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option channel '6'
        option country 'BR'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'dshome'
        option encryption 'psk2+ccmp'
        option key '****'
1 Like

OK, there was an issue with my test.

When the 802.11n client did not connect to the 5GHz band, OpenWRT5Ghz radio was configured as VHT40 at channel 100.

I then changed the OpenWRT 5GHz configuration to HT40 at channel 36. In this mode the 802.11n client connected successfully, and I had wrongly assumed that the VHT40 configuration was the culprit.

However, keeping the 36 channel and changing the mode back to VHT40 allowed the “mixed mode” I was looking for (simultaneous connections of 802.11n and 802.11ac to the 5GHz radio).

So the root cause was that the old MacBookAir is not able to connect to DFS channels in 802.11n.

And the lesson learned is that the VHT40 (ac) mode is in fact backward compatible with HT40 mode (n). I believe this is not clear in the OpenWRT configuration, and the LuCI UI also does not help (VHT40 shows as “AC” even if the 802.11n are allowed to connect).

Marking as “solved”.